*** empty log message ***
This commit is contained in:
parent
bfafac4785
commit
ac64397ed3
12 changed files with 216 additions and 7 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.1 2013/12/13 14:38:35 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2013/12/30 06:37:11 ryoon Exp $
|
||||
|
||||
PKGNAME= qt5-qtbase-${QTVERSION}
|
||||
PKGREVISION= 1
|
||||
COMMENT= C++ X GUI toolkit
|
||||
|
||||
.include "../../x11/qt5-qtbase/Makefile.common"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.6 2013/12/28 09:11:24 jperkin Exp $
|
||||
# $NetBSD: Makefile.common,v 1.7 2013/12/30 06:37:11 ryoon Exp $
|
||||
# used by x11/qt5-dbus/Makefile
|
||||
# used by x11/qt5-mysql/Makefile
|
||||
# used by x11/qt5-odbc/Makefile
|
||||
|
@ -47,7 +47,7 @@ BUILDLINK_TRANSFORM+= opt:-ldl:${BUILDLINK_LDADD.dl:M*}
|
|||
HAS_CONFIGURE= yes
|
||||
USE_LANGUAGES= c c++
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake perl:build
|
||||
USE_TOOLS+= gmake perl:build pkg-config
|
||||
|
||||
CONFIG_SHELL= ${PERL5}
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.4 2013/12/17 23:22:35 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.5 2013/12/30 06:37:11 ryoon Exp $
|
||||
|
||||
SHA1 (qt-everywhere-opensource-src-5.2.0.tar.xz) = 7d9d8cad4434bc200d9ed87b3c7cb39654a2f1b4
|
||||
RMD160 (qt-everywhere-opensource-src-5.2.0.tar.xz) = b2dd68f622fa7ff271ef621a7c7f17f2ecf7be9d
|
||||
|
@ -30,6 +30,13 @@ SHA1 (patch-qtdeclarative_examples_quick_customitems_painteditem_painteditem.pro
|
|||
SHA1 (patch-qtdeclarative_src_qml_jsruntime_qv4alloca__p.h) = 9a1a4bb03776e3e6331120933accd0cf46503533
|
||||
SHA1 (patch-qtdeclarative_src_qmldevtools_qmldevtools.pro) = 6f0e65eb6c4a5bfd05a603d9cbfc6fdc22e46d3b
|
||||
SHA1 (patch-qtdeclarative_tests_auto_qml_qjsengine_tst__qjsengine.cpp) = b1cc5a386dd0f1b3651adb9babee87be84221998
|
||||
SHA1 (patch-qtmultimedia_src_gsttools_qgstreamervideoinputdevicecontrol.cpp) = 9281d212f28dab5fece2f7a0cc9bddf0e58922dc
|
||||
SHA1 (patch-qtmultimedia_src_plugins_gstreamer_audiodecoder_qgstreameraudiodecoderserviceplugin.cpp) = ac97ed7ec63e3cfc060ce7e90dfe7f053f9dd851
|
||||
SHA1 (patch-qtmultimedia_src_plugins_gstreamer_camerabin_camerabincontrol.cpp) = e2b0022da1f523324159efdcd29237f82380aed8
|
||||
SHA1 (patch-qtmultimedia_src_plugins_gstreamer_camerabin_camerabinserviceplugin.cpp) = 4c5f0d3d5a0c6b3075232272abe00b467575194f
|
||||
SHA1 (patch-qtmultimedia_src_plugins_gstreamer_mediacapture_qgstreamercaptureserviceplugin.cpp) = 224a3097498d12284f10a9adb5a774356092f374
|
||||
SHA1 (patch-qtmultimedia_src_plugins_gstreamer_mediacapture_qgstreamerv4l2input.cpp) = 55aee0426b057461861605dadd4687932988bd78
|
||||
SHA1 (patch-qtmultimedia_src_plugins_gstreamer_mediaplayer_qgstreamerplayerserviceplugin.cpp) = 729d69245a1ab6fe9b01a63673102685b39d7add
|
||||
SHA1 (patch-qtquick1_tests_auto_declarative_qdeclarativeimage_tst__qdeclarativeimage.cpp) = b1efdea5596a76eeae37a70bd49bb7741a8b7c5f
|
||||
SHA1 (patch-qtscript_src_3rdparty_javascriptcore_JavaScriptCore_config.h) = 66dc22ee78727c84f1e82dc10bb342d514f8f9a0
|
||||
SHA1 (patch-qtscript_src_3rdparty_javascriptcore_JavaScriptCore_runtime_JSValue.h) = ee35790f58ec9cf4d1a370f5549d92b5a680f557
|
||||
|
|
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-qtmultimedia_src_gsttools_qgstreamervideoinputdevicecontrol.cpp,v 1.1 2013/12/30 06:37:11 ryoon Exp $
|
||||
|
||||
--- qtmultimedia/src/gsttools/qgstreamervideoinputdevicecontrol.cpp.orig 2013-12-20 09:05:17.000000000 +0000
|
||||
+++ qtmultimedia/src/gsttools/qgstreamervideoinputdevicecontrol.cpp
|
||||
@@ -44,7 +44,12 @@
|
||||
#include <QtCore/QDir>
|
||||
#include <QtCore/QDebug>
|
||||
|
||||
+#ifdef __linux__
|
||||
#include <linux/types.h>
|
||||
+#include <linux/videodev2.h>
|
||||
+#elif defined(__NetBSD__)
|
||||
+#include <sys/videoio.h>
|
||||
+#endif
|
||||
#include <sys/time.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/poll.h>
|
||||
@@ -54,7 +59,6 @@
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/mman.h>
|
||||
-#include <linux/videodev2.h>
|
||||
|
||||
QGstreamerVideoInputDeviceControl::QGstreamerVideoInputDeviceControl(QObject *parent)
|
||||
:QVideoDeviceSelectorControl(parent), m_selectedDevice(0)
|
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-qtmultimedia_src_plugins_gstreamer_audiodecoder_qgstreameraudiodecoderserviceplugin.cpp,v 1.1 2013/12/30 06:37:11 ryoon Exp $
|
||||
|
||||
--- qtmultimedia/src/plugins/gstreamer/audiodecoder/qgstreameraudiodecoderserviceplugin.cpp.orig 2013-12-20 09:09:03.000000000 +0000
|
||||
+++ qtmultimedia/src/plugins/gstreamer/audiodecoder/qgstreameraudiodecoderserviceplugin.cpp
|
||||
@@ -49,7 +49,12 @@
|
||||
#include <QtCore/QDir>
|
||||
#include <QtCore/QDebug>
|
||||
|
||||
+#if defined(__linux__)
|
||||
#include <linux/types.h>
|
||||
+#include <linux/videodev2.h>
|
||||
+#elif defined(__NetBSD__)
|
||||
+#include <sys/videoio.h>
|
||||
+#endif
|
||||
#include <sys/time.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/poll.h>
|
||||
@@ -59,7 +64,6 @@
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/mman.h>
|
||||
-#include <linux/videodev2.h>
|
||||
#include <gst/gst.h>
|
||||
|
||||
// #define QT_SUPPORTEDMIMETYPES_DEBUG
|
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-qtmultimedia_src_plugins_gstreamer_camerabin_camerabincontrol.cpp,v 1.1 2013/12/30 06:37:11 ryoon Exp $
|
||||
|
||||
--- qtmultimedia/src/plugins/gstreamer/camerabin/camerabincontrol.cpp.orig 2013-12-20 09:31:52.000000000 +0000
|
||||
+++ qtmultimedia/src/plugins/gstreamer/camerabin/camerabincontrol.cpp
|
||||
@@ -50,7 +50,12 @@
|
||||
#include <QtCore/qfile.h>
|
||||
#include <QtCore/qmetaobject.h>
|
||||
|
||||
+#ifdef __linux__
|
||||
#include <linux/types.h>
|
||||
+#include <linux/videodev2.h>
|
||||
+#elif defined(__NetBSD__)
|
||||
+#include <sys/videoio.h>
|
||||
+#endif
|
||||
#include <sys/time.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/poll.h>
|
||||
@@ -60,7 +65,6 @@
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/mman.h>
|
||||
-#include <linux/videodev2.h>
|
||||
|
||||
QT_BEGIN_NAMESPACE
|
||||
|
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-qtmultimedia_src_plugins_gstreamer_camerabin_camerabinserviceplugin.cpp,v 1.1 2013/12/30 06:37:11 ryoon Exp $
|
||||
|
||||
--- qtmultimedia/src/plugins/gstreamer/camerabin/camerabinserviceplugin.cpp.orig 2013-12-20 09:28:04.000000000 +0000
|
||||
+++ qtmultimedia/src/plugins/gstreamer/camerabin/camerabinserviceplugin.cpp
|
||||
@@ -50,7 +50,12 @@
|
||||
#include "camerabinservice.h"
|
||||
#include <private/qgstutils_p.h>
|
||||
|
||||
+#ifdef __linux__
|
||||
#include <linux/types.h>
|
||||
+#include <linux/videodev2.h>
|
||||
+#elif defined(__NetBSD__)
|
||||
+#include <sys/videoio.h>
|
||||
+#endif
|
||||
#include <sys/time.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/poll.h>
|
||||
@@ -60,7 +65,6 @@
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/mman.h>
|
||||
-#include <linux/videodev2.h>
|
||||
#include <gst/gst.h>
|
||||
|
||||
QT_BEGIN_NAMESPACE
|
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-qtmultimedia_src_plugins_gstreamer_mediacapture_qgstreamercaptureserviceplugin.cpp,v 1.1 2013/12/30 06:37:11 ryoon Exp $
|
||||
|
||||
--- qtmultimedia/src/plugins/gstreamer/mediacapture/qgstreamercaptureserviceplugin.cpp.orig 2013-12-20 09:17:00.000000000 +0000
|
||||
+++ qtmultimedia/src/plugins/gstreamer/mediacapture/qgstreamercaptureserviceplugin.cpp
|
||||
@@ -51,7 +51,12 @@
|
||||
#include "qgstreamercaptureservice.h"
|
||||
#include <private/qgstutils_p.h>
|
||||
|
||||
+#ifdef __linux__
|
||||
#include <linux/types.h>
|
||||
+#include <linux/videodev2.h>
|
||||
+#elif defined(__NetBSD__)
|
||||
+#include <sys/videoio.h>
|
||||
+#endif
|
||||
#include <sys/time.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/poll.h>
|
||||
@@ -61,7 +66,6 @@
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/mman.h>
|
||||
-#include <linux/videodev2.h>
|
||||
#include <gst/gst.h>
|
||||
|
||||
QMediaService* QGstreamerCaptureServicePlugin::create(const QString &key)
|
|
@ -0,0 +1,45 @@
|
|||
$NetBSD: patch-qtmultimedia_src_plugins_gstreamer_mediacapture_qgstreamerv4l2input.cpp,v 1.1 2013/12/30 06:37:11 ryoon Exp $
|
||||
|
||||
NetBSD doesn't have support for v4l2_frmsizeenum and related logic.
|
||||
Should be fixed properly.
|
||||
|
||||
--- qtmultimedia/src/plugins/gstreamer/mediacapture/qgstreamerv4l2input.cpp.orig 2013-12-20 09:12:19.000000000 +0000
|
||||
+++ qtmultimedia/src/plugins/gstreamer/mediacapture/qgstreamerv4l2input.cpp
|
||||
@@ -44,7 +44,12 @@
|
||||
#include <QtCore/qdebug.h>
|
||||
#include <QtCore/qfile.h>
|
||||
|
||||
+#if defined(__linux__)
|
||||
+#include <linux/videodev2.h>
|
||||
#include <linux/types.h>
|
||||
+#elif defined(__NetBSD__)
|
||||
+#include <sys/videoio.h>
|
||||
+#endif
|
||||
#include <sys/time.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/poll.h>
|
||||
@@ -54,7 +59,6 @@
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/mman.h>
|
||||
-#include <linux/videodev2.h>
|
||||
|
||||
QT_BEGIN_NAMESPACE
|
||||
static inline uint qHash(const QSize& key) { return uint(key.width()*256+key.height()); }
|
||||
@@ -154,7 +158,7 @@ void QGstreamerV4L2Input::updateSupporte
|
||||
|
||||
|
||||
//get the list of resolutions:
|
||||
-
|
||||
+#if !defined(__NetBSD__)
|
||||
foreach (quint32 format, supportedFormats) {
|
||||
struct v4l2_frmsizeenum formatSize;
|
||||
memset(&formatSize, 0, sizeof(formatSize));
|
||||
@@ -256,6 +260,7 @@ void QGstreamerV4L2Input::updateSupporte
|
||||
m_ratesByResolution[s].unite(frameRates.toSet());
|
||||
}
|
||||
}
|
||||
+#endif
|
||||
|
||||
f.close();
|
||||
|
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-qtmultimedia_src_plugins_gstreamer_mediaplayer_qgstreamerplayerserviceplugin.cpp,v 1.1 2013/12/30 06:37:11 ryoon Exp $
|
||||
|
||||
--- qtmultimedia/src/plugins/gstreamer/mediaplayer/qgstreamerplayerserviceplugin.cpp.orig 2013-12-20 09:21:00.000000000 +0000
|
||||
+++ qtmultimedia/src/plugins/gstreamer/mediaplayer/qgstreamerplayerserviceplugin.cpp
|
||||
@@ -51,7 +51,12 @@
|
||||
#include "qgstreamerplayerservice.h"
|
||||
#include <private/qgstutils_p.h>
|
||||
|
||||
+#ifdef __linux__
|
||||
#include <linux/types.h>
|
||||
+#include <linux/videodev2.h>
|
||||
+#elif defined(__NetBSD__)
|
||||
+#include <sys/videoio.h>
|
||||
+#endif
|
||||
#include <sys/time.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/poll.h>
|
||||
@@ -61,7 +66,6 @@
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/mman.h>
|
||||
-#include <linux/videodev2.h>
|
||||
#include <gst/gst.h>
|
||||
|
||||
|
|
@ -1,8 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.1 2013/12/13 14:38:35 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2013/12/30 06:37:11 ryoon Exp $
|
||||
|
||||
.include "../../x11/qt5-qtbase/Makefile.common"
|
||||
|
||||
PKGNAME= qt5-qtmultimedia-${QTVERSION}
|
||||
PKGREVISION= 1
|
||||
COMMENT= Qt5 module for multimedia
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2013/12/15 09:42:44 ryoon Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2013/12/30 06:37:11 ryoon Exp $
|
||||
lib/pkgconfig/Qt5Multimedia.pc
|
||||
lib/pkgconfig/Qt5MultimediaQuick_p.pc
|
||||
lib/pkgconfig/Qt5MultimediaWidgets.pc
|
||||
|
@ -253,6 +253,8 @@ qt5/lib/libQt5MultimediaQuick_p.la
|
|||
qt5/lib/libQt5MultimediaQuick_p.prl
|
||||
qt5/lib/libQt5MultimediaWidgets.la
|
||||
qt5/lib/libQt5MultimediaWidgets.prl
|
||||
qt5/lib/libqgsttools_p.la
|
||||
qt5/lib/libqgsttools_p.prl
|
||||
qt5/lib/pkgconfig/Qt5Multimedia.pc
|
||||
qt5/lib/pkgconfig/Qt5MultimediaQuick_p.pc
|
||||
qt5/lib/pkgconfig/Qt5MultimediaWidgets.pc
|
||||
|
@ -261,7 +263,10 @@ qt5/mkspecs/modules/qt_lib_multimedia_private.pri
|
|||
qt5/mkspecs/modules/qt_lib_multimediawidgets.pri
|
||||
qt5/mkspecs/modules/qt_lib_multimediawidgets_private.pri
|
||||
qt5/mkspecs/modules/qt_lib_qtmultimediaquicktools_private.pri
|
||||
qt5/plugins/mediaservice/libqtmedia_audioengine.la
|
||||
qt5/plugins/mediaservice/libgstaudiodecoder.la
|
||||
qt5/plugins/mediaservice/libgstcamerabin.la
|
||||
qt5/plugins/mediaservice/libgstmediacapture.la
|
||||
qt5/plugins/mediaservice/libgstmediaplayer.la
|
||||
qt5/plugins/playlistformats/libqtmultimedia_m3u.la
|
||||
qt5/qml/QtAudioEngine/libdeclarative_audioengine.la
|
||||
qt5/qml/QtAudioEngine/plugins.qmltypes
|
||||
|
|
Loading…
Reference in a new issue