hfstospell: replace patch that forced c++14 with FORCE_CXX_STD

Patch didn't apply any longer after autoconf update
This commit is contained in:
wiz 2024-01-24 16:58:05 +00:00
parent 713e1c8849
commit ac935d30e5
3 changed files with 6 additions and 76 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.16 2023/11/08 13:21:05 wiz Exp $
# $NetBSD: Makefile,v 1.17 2024/01/24 16:58:05 wiz Exp $
GITHUB_PROJECT= hfst-ospell
DISTNAME= hfstospell-0.5.3
PKGREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GITHUB:=hfst/}
GITHUB_PROJECT= hfst-ospell
GITHUB_TAG= v${PKGVERSION_NOREV}
MAINTAINER= bsiegert@NetBSD.org
@ -15,7 +15,9 @@ LICENSE= apache-2.0
GNU_CONFIGURE= yes
USE_TOOLS+= pkg-config autoreconf autoconf automake aclocal
USE_LIBTOOL= yes
USE_LANGUAGES= c c++11
USE_LANGUAGES= c c++
FORCE_CXX_STD= c++14
PKGCONFIG_OVERRIDE+= hfstospell.pc.in

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.7 2023/08/31 18:55:12 bsiegert Exp $
$NetBSD: distinfo,v 1.8 2024/01/24 16:58:05 wiz Exp $
BLAKE2s (hfstospell-0.5.3.tar.gz) = b9f17c9d2c995cc87466ad314ac6e53e7b0c6c930a536275544b7f93d8f0a038
SHA512 (hfstospell-0.5.3.tar.gz) = f25bae6c083894139ba1e3dbd24f010e1c4695bdfe4c2499d31f2f0bd2f5688b662ea15666b46f174fc75f0aa6f5cd114456f735b1d49bcf33322221b6f57ff5
Size (hfstospell-0.5.3.tar.gz) = 152654 bytes
SHA1 (patch-configure) = a6a4aa1180ba97808014bfff2760375b5f077c89

View file

@ -1,71 +0,0 @@
$NetBSD: patch-configure,v 1.2 2021/01/15 14:33:52 mef Exp $
Let's not force C++20 when the libxml++ dependency can't deal with it.
--- configure.orig 2021-01-15 23:14:58.236623702 +0900
+++ configure 2021-01-15 23:22:01.601329062 +0900
@@ -19482,15 +19482,15 @@ ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS
ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking whether C++ compiler accepts -std=c++20" >&5
-printf %s "checking whether C++ compiler accepts -std=c++20... " >&6; }
+{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking whether C++ compiler accepts -std=c++14" >&5
+printf %s "checking whether C++ compiler accepts -std=c++14... " >&6; }
if test ${ax_cv_check_cxxflags___std_cpp20+y}
then :
printf %s "(cached) " >&6
else $as_nop
ax_check_save_flags=$CXXFLAGS
- CXXFLAGS="$CXXFLAGS -std=c++20"
+ CXXFLAGS="$CXXFLAGS -std=c++14"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -19515,7 +19515,7 @@ fi
printf "%s\n" "$ax_cv_check_cxxflags___std_cpp20" >&6; }
if test x"$ax_cv_check_cxxflags___std_cpp20" = xyes
then :
- CXXFLAGS="$CXXFLAGS -std=c++20"
+ CXXFLAGS="$CXXFLAGS -std=c++14"
else $as_nop
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking whether C++ compiler accepts -std=c++2a" >&5
@@ -19554,15 +19554,15 @@ then :
CXXFLAGS="$CXXFLAGS -std=c++2a"
else $as_nop
- { printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking whether C++ compiler accepts -std=c++17" >&5
-printf %s "checking whether C++ compiler accepts -std=c++17... " >&6; }
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking whether C++ compiler accepts -std=c++14" >&5
+printf %s "checking whether C++ compiler accepts -std=c++14... " >&6; }
if test ${ax_cv_check_cxxflags___std_cpp17+y}
then :
printf %s "(cached) " >&6
else $as_nop
ax_check_save_flags=$CXXFLAGS
- CXXFLAGS="$CXXFLAGS -std=c++17"
+ CXXFLAGS="$CXXFLAGS -std=c++14"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -19587,7 +19587,7 @@ fi
printf "%s\n" "$ax_cv_check_cxxflags___std_cpp17" >&6; }
if test x"$ax_cv_check_cxxflags___std_cpp17" = xyes
then :
- CXXFLAGS="$CXXFLAGS -std=c++17"
+ CXXFLAGS="$CXXFLAGS -std=c++14"
else $as_nop
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking whether C++ compiler accepts -std=c++1z" >&5
@@ -19623,7 +19623,7 @@ fi
printf "%s\n" "$ax_cv_check_cxxflags___std_cpp1z" >&6; }
if test x"$ax_cv_check_cxxflags___std_cpp1z" = xyes
then :
- CXXFLAGS="$CXXFLAGS -std=c++1z"
+ CXXFLAGS="$CXXFLAGS -std=c++14"
else $as_nop
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking whether C++ compiler accepts -std=c++14" >&5