Update dict-server and dict-client to 1.12.1
dictl.in: Fix for Debian bug #677868 reported by Stepan Golosunov. dictd.8: Fixes for mistypes found by A. Costa. Thanks! dictzip: Fix for sf.net bug #3390567 reported by Ivo Danihelka. INSTALL: Fix for sf.net bug #3398178 colorit: Fix for option -c. Now it works correctly. examples/dictd_virtual.conf: Fix incorrect keyword for virtual database. Thanks to Marc-Jano Knopp for the report!
This commit is contained in:
parent
42e8caf6cb
commit
acacf6d808
6 changed files with 8 additions and 83 deletions
|
@ -1,9 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.36 2012/06/17 13:18:43 cheusov Exp $
|
||||
# $NetBSD: Makefile,v 1.37 2012/07/22 15:32:50 cheusov Exp $
|
||||
|
||||
.include "../../textproc/dict-server/Makefile.common"
|
||||
|
||||
PKGNAME= ${DISTNAME:S/dictd/dict-client/}
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= textproc
|
||||
COMMENT= Dictionary Service Protocol client
|
||||
|
||||
|
|
|
@ -1,9 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.29 2011/05/07 10:06:02 cheusov Exp $
|
||||
# $NetBSD: Makefile,v 1.30 2012/07/22 15:32:50 cheusov Exp $
|
||||
|
||||
.include "../../textproc/dict-server/Makefile.common"
|
||||
|
||||
PKGNAME= ${DISTNAME:S/dictd/dict-server/}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= textproc
|
||||
COMMENT= Dictionary Service Protocol server
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile.common,v 1.4 2012/05/12 15:18:23 cheusov Exp $
|
||||
# $NetBSD: Makefile.common,v 1.5 2012/07/22 15:32:50 cheusov Exp $
|
||||
# used by textproc/colorit/Makefile
|
||||
# used by textproc/dict-server/Makefile
|
||||
# used by textproc/dict-client/Makefile
|
||||
DISTNAME= dictd-1.12.0
|
||||
DISTNAME= dictd-1.12.1
|
||||
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=dict/} \
|
||||
ftp://ftp.dict.org/pub/dict/
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.21 2012/06/17 13:18:42 cheusov Exp $
|
||||
$NetBSD: distinfo,v 1.22 2012/07/22 15:32:50 cheusov Exp $
|
||||
|
||||
SHA1 (dictd-1.12.0.tar.gz) = 0a1b0c4103e5c3c8b749f9a5dc005cb70e4639e8
|
||||
RMD160 (dictd-1.12.0.tar.gz) = 56abaebf57baabcb72b96ccf6ec5c39cc3a67ceb
|
||||
Size (dictd-1.12.0.tar.gz) = 423183 bytes
|
||||
SHA1 (patch-colorit.in) = 84e205155cce66b36196c03417deab74c10d8a1a
|
||||
SHA1 (patch-dictl.in) = 56a0010eefb041474e250e746ba429e66ffd2086
|
||||
SHA1 (dictd-1.12.1.tar.gz) = 5870cc0f727f89091d0ae8a054b37e891f4cf145
|
||||
RMD160 (dictd-1.12.1.tar.gz) = 6c8b2ea5a8afa26fde019dea686d52ab5007ea17
|
||||
Size (dictd-1.12.1.tar.gz) = 423870 bytes
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
$NetBSD: patch-colorit.in,v 1.1 2012/05/12 15:18:24 cheusov Exp $
|
||||
|
||||
# Fix for -c option. Commited to upstream.
|
||||
--- colorit.in.orig 2008-02-08 10:59:15.000000000 +0000
|
||||
+++ colorit.in
|
||||
@@ -6,15 +6,6 @@
|
||||
|
||||
sysconfdir=@sysconfdir@
|
||||
|
||||
-if test -r $HOME/.coloritrc; then
|
||||
- config_file=$HOME/.coloritrc
|
||||
-else if test -r "$sysconfdir/colorit.conf"; then
|
||||
- config_file="$sysconfdir/colorit.conf"
|
||||
-else
|
||||
- echo "configuration file is not readable" > "/dev/stderr"
|
||||
- exit 1
|
||||
-fi fi
|
||||
-
|
||||
usage (){
|
||||
printf "\
|
||||
colorit is intended to markup stdin or input files\n\
|
||||
@@ -37,6 +28,8 @@ colorit 0.0.1\n\
|
||||
|
||||
pp='m4'
|
||||
|
||||
+config_file=$HOME/.coloritrc
|
||||
+
|
||||
while test $# -ne 0; do
|
||||
case $1 in
|
||||
-h|--help)
|
||||
@@ -70,6 +63,15 @@ while test $# -ne 0; do
|
||||
shift
|
||||
done
|
||||
|
||||
+if test -r "$config_file"; then
|
||||
+ :
|
||||
+elif test -r "$sysconfdir/colorit.conf"; then
|
||||
+ config_file="$sysconfdir/colorit.conf"
|
||||
+else
|
||||
+ echo "configuration file is not readable" > "/dev/stderr"
|
||||
+ exit 1
|
||||
+fi
|
||||
+
|
||||
if test "_$pp" = "_-"; then
|
||||
pp=
|
||||
fi
|
|
@ -1,25 +0,0 @@
|
|||
$NetBSD: patch-dictl.in,v 1.1 2012/06/17 13:18:42 cheusov Exp $
|
||||
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=677868
|
||||
--- dictl.in.orig 2009-01-10 21:16:56.000000000 +0000
|
||||
+++ dictl.in
|
||||
@@ -59,11 +59,17 @@ echo apple |
|
||||
|
||||
#####################################
|
||||
|
||||
+shquote (){
|
||||
+ __cmd=`printf '%s\n' "$1" | sed "s|'|'\\\\\''|g"`
|
||||
+ printf "%s\n" "'$__cmd'"
|
||||
+}
|
||||
+
|
||||
cmd='dict'
|
||||
while test $# -ne 0; do
|
||||
- cmd="$cmd '$1'"
|
||||
+ cmd="$cmd "`shquote "$1"`
|
||||
shift
|
||||
done
|
||||
-cmd=$(echo $cmd | charset2charset $DICTL_CHARSET $DICTL_SERVER_CHARSET)
|
||||
|
||||
-eval $cmd -P - | charset2charset $DICTL_SERVER_CHARSET $DICTL_CHARSET
|
||||
+cmd=$(printf '%s\n' "$cmd" | charset2charset $DICTL_CHARSET $DICTL_SERVER_CHARSET)
|
||||
+
|
||||
+eval "$cmd" | charset2charset $DICTL_SERVER_CHARSET $DICTL_CHARSET
|
Loading…
Reference in a new issue