the ffserver program uses dlopen(), so include dlopen.buildlink3.mk

and ensure -ldl is passed when linking ffserver where appropriate.

fixes build on Linux.
This commit is contained in:
grant 2005-03-05 13:32:10 +00:00
parent 5206b3ffab
commit ace46b1f0a
3 changed files with 16 additions and 5 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.11 2005/02/05 19:40:22 tron Exp $
# $NetBSD: Makefile,v 1.12 2005/03/05 13:32:10 grant Exp $
DISTNAME= ffmpeg-0.4.8
PKGREVISION= 3
@ -90,4 +90,5 @@ CONFIGURE_ARGS+= --enable-vorbis
CONFIGURE_ARGS+= --disable-vorbis
.endif
.include "../../mk/dlopen.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.7 2005/02/24 11:24:02 agc Exp $
$NetBSD: distinfo,v 1.8 2005/03/05 13:32:10 grant Exp $
SHA1 (ffmpeg-0.4.8.tar.gz) = 629a0f8f4daa3da1dedd8ba58bfdec4c47581bb4
RMD160 (ffmpeg-0.4.8.tar.gz) = 8196b92b16506ddd848410c20407a7416011447e
Size (ffmpeg-0.4.8.tar.gz) = 1352874 bytes
SHA1 (patch-aa) = ed0dadc9112d8ae1cdcb30bc08f7e8c27195e027
SHA1 (patch-aa) = e57ba32021ff55f7b545581eae9f0027cddbd883
SHA1 (patch-ab) = f596db3c555ab772eae2da5b8144c23fb4f2eaa0
SHA1 (patch-ac) = 6f137ca14131e00c2db89cbe44657f32f3513e98
SHA1 (patch-ad) = e058ddcb0ad4211c16d2f4c5fe0859723316b3a8

View file

@ -1,6 +1,6 @@
$NetBSD: patch-aa,v 1.2 2004/05/25 21:49:26 wiz Exp $
$NetBSD: patch-aa,v 1.3 2005/03/05 13:32:10 grant Exp $
--- configure.orig 2003-09-28 17:26:39.000000000 +0200
--- configure.orig 2003-09-29 01:26:39.000000000 +1000
+++ configure
@@ -148,11 +148,10 @@ FFSLDFLAGS=""
need_inet_aton="yes"
@ -15,3 +15,13 @@ $NetBSD: patch-aa,v 1.2 2004/05/25 21:49:26 wiz Exp $
LDFLAGS="$LDFLAGS -export-dynamic"
;;
BSD/OS)
@@ -959,6 +958,9 @@ if test "$vhook" = "yes" ; then
echo "#define HAVE_VHOOK 1" >> $TMPH
extralibs="$extralibs $ldl"
fi
+if test "$ffserver" = "yes" ; then
+ extralibs="$extralibs $ldl"
+fi
if test "$lshared" = "yes" ; then
echo "BUILD_SHARED=yes" >> config.mak
echo "PIC=-fPIC" >> config.mak