Make the package realize that amd64 is a LP64 architecture.

Prevent crash when the requested display mode cannot be used.
Bump PKGREVISION.
This commit is contained in:
kristerw 2004-04-02 18:47:39 +00:00
parent 15e87bcc76
commit aceac3e7b1
3 changed files with 24 additions and 6 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.48 2004/03/31 04:39:17 xtraeme Exp $
# $NetBSD: Makefile,v 1.49 2004/04/02 18:47:39 kristerw Exp $
#
DISTNAME= xmame-0.80.1
PKGNAME= xmess-0.80.1
PKGREVISION= 1
CATEGORIES= emulators games x11
MASTER_SITES= http://x.mame.net/download/
EXTRACT_SUFX= .tar.bz2
@ -15,7 +16,7 @@ RESTRICTED= "selling is not allowed"
NO_SRC_ON_CDROM= ${RESTRICTED}
NO_BIN_ON_CDROM= ${RESTRICTED}
USE_BUILDLINK2= YES
USE_BUILDLINK3= YES
USE_PKGINSTALL= YES
USE_X11= YES
USE_GNU_TOOLS+= make
@ -25,6 +26,8 @@ UNLIMIT_RESOURCES= datasize
.include "../../mk/bsd.prefs.mk"
BUILD_DEFS+= USE_ESOUND
ROMPATH= ${PREFIX}/share/${TARGET}
SPOOLDIR= /var/games/${TARGET}
@ -33,8 +36,6 @@ MAKE_FLAGS+= LIBS="${LDFLAGS} ${LIBS}"
MAKE_FLAGS+= CFLAGS="${CFLAGS}"
MAKE_FLAGS+= X11INC= X11LIB=
BUILD_DEFS+= USE_ESOUND
.if !empty(USE_ESOUND:M[Yy][Ee][Ss])
MAKE_FLAGS+= SOUND_ESOUND=1
.include "../../audio/esound/buildlink3.mk"
@ -43,9 +44,10 @@ MAKE_FLAGS+= SOUND_ESOUND=1
MAME_DISP_METHOD?= x11
# Determine which CPU-specific code to use.
.for MARCH in alpha m68k i386 ia64
.for MARCH in alpha m68k i386 ia64 mips
MAME_CPU.${MARCH}?= ${MARCH}
.endfor
MAME_CPU.x86_64?= amd64
.if !defined(MAME_CPU.${MACHINE_ARCH})
. include "../../mk/endian.mk"
_MAME_CPU.big-endian= risc

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.20 2004/03/31 04:39:17 xtraeme Exp $
$NetBSD: distinfo,v 1.21 2004/04/02 18:47:39 kristerw Exp $
SHA1 (xmame-0.80.1.tar.bz2) = a45670eac5087fb9c697a1205bb14b7df9d7702b
Size (xmame-0.80.1.tar.bz2) = 12460829 bytes
SHA1 (patch-aa) = 0b9ffcb7c4305e7c349f229b2646acb31553d549
SHA1 (patch-ab) = 2aea6b094792498939294a285e151bed6b4ab01e
SHA1 (patch-ae) = f30af6853b77307126ad4a230d4237bc570a0ca4

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ab,v 1.14 2004/04/02 18:47:39 kristerw Exp $
--- src/unix/video-drivers/x11_window.c.orig 2004-03-27 02:15:43.000000000 +0100
+++ src/unix/video-drivers/x11_window.c 2004-03-27 02:17:58.000000000 +0100
@@ -912,8 +912,8 @@
/* else we have failed clean up before retrying without MITSHM */
shmdt ((char *) scaled_buffer_ptr);
scaled_buffer_ptr = NULL;
- XDestroyImage (image);
- image = NULL;
+ XFree(xvimage);
+ xvimage = NULL;
}
}
fprintf (stderr_file, "Failed\nReverting to normal XPutImage() mode\n");