Update gnome-vfs2, gnome-vfs2-cdda and gnome-vfs2-smb to 2.14.0:

gnome-vfs 2.14.0
	* Fix circular dependency on gnome-mount
	* Fix some details in gnome_vfs_xfer callbacks
	* Avoid crash with symlinks that has ':' in them
	* Update hal volume manager policies
	* Fix leaks
	* Better smb authentication code
	* Fix permission reading bug introduced in 2.13.92

gnome-vfs 2.13.92
	* Build fixes
	* Fix memory leaks
	* Some optimizations
	* New readdir option GNOME_VFS_FILE_INFO_NAME_ONLY that only returns
	  filenames (not stat info).
	* use pmount in /media if not using gnome-mount or hal-mount
	* Fixes for encrypted drives/volumes in hal backend
	* Mime detection fix for multiple magic matches of same prio
	* HAL volume operation fixes
	* More robust gnome_vfs_make_uri_from_input_internal
	* Fix Avahi resolving of non-local hostnames

gnome-vfs 2.13.91
	* Eject fixes for volume manager
	* Windows 2000 portability fixes
	* Revert overwrite error dialog change that caused problems
	* ssh fixes for newer BSD and OSX releases

gnome-vfs 2.13.4
	* Add support for gnome-mount
	* Re-add thread prioritizing
	* Add gnome_vfs_get_mime_type_for_name_and_data () and
          gnome_vfs_get_mime_type_for_name ()
	* Deprecate gnome_vfs_mime_type_from_name ()
	* Skip attempts to overwrite a file onto itself in
          gnome_vfs_xfer and friends.
	* Retrun GNOME_VFS_ERROR_INTERRUPTED when aborting transfers
	* inotify: Fix various crashers and bugs
	* ftp-method: Basic support for proxies
	* http-method: Fix SSL support
	* http-mehtod: Fix bugs introduced during the neon upgrade
	* Various hal related volume fixes
	* Hide some more private functions
	* Some documentation updates
	* Translation updates

gnome-vfs 2.13.3
        * load modules with BIND_LOCAL
	* inotify fix

gnome-vfs 2.13.2
	* Support Avahi 0.6
	* Support passwords in mount
	* Inotify support
	* Update neon import to 0.25
	* Leak fixes
	* Win32 fixes
	* Add GNOME_VFS_FILE_INFO_FIELDS_IDS to see if uid/gid are valid
	* Update to lates xdgmime
	* Use the glib GThreadPool code instead of our own threadpool

gnome-vfs 2.13.1
	* Support for recent samba
	* Fix bug when resolving nested symlinks
	* Sync to upstream xdg-mime code
	* Various fixes to gnomevfs-* apps
	* New functions gnome_vfs_exists, gnome_vfs_get_slow_mime
	* Better ls parsing for ftp
	* Return GNOME_VFS_ERROR_CANCELLED when authentication is cancelled
	* Add avahi support
	* Fix problem when mounting cd multiple times
	* Hide private symbols
	* Better docs
	* Fix metadata removal issue with deletion in Nautilus
This commit is contained in:
jmmv 2006-03-30 21:07:48 +00:00
parent 4a08dc6ced
commit ad0c76d1ae
12 changed files with 136 additions and 59 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.13 2006/03/07 06:30:55 joerg Exp $
# $NetBSD: Makefile,v 1.14 2006/03/30 21:07:48 jmmv Exp $
#
GNOME_VFS2_NAME= cdda
PKGREVISION= 4
CATEGORIES= audio
CPPFLAGS+= -I${BUILDLINK_PREFIX.cdparanoia}/include/cdparanoia

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.8 2006/03/06 00:18:22 wiz Exp $
# $NetBSD: Makefile,v 1.9 2006/03/30 21:07:48 jmmv Exp $
#
GNOME_VFS2_NAME= smb
GNOME_VFS2_FLAG= samba
PKGREVISION= 3
CATEGORIES= net
EGFILES+= modules/smb-module.conf

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.59 2006/03/29 20:41:12 jmmv Exp $
# $NetBSD: Makefile,v 1.60 2006/03/30 21:07:48 jmmv Exp $
PKGCONFIG_OVERRIDE= gnome-vfs-2.0.pc.in
PKGCONFIG_OVERRIDE+= gnome-vfs-module-2.0.pc.in
@ -13,14 +13,12 @@ GCONF2_SCHEMAS+= desktop_gnome_url_handlers.schemas
GCONF2_SCHEMAS+= system_dns_sd.schemas
GCONF2_SCHEMAS+= system_http_proxy.schemas
GCONF2_SCHEMAS+= system_smb.schemas
GCONF2_SCHEMAS+= system_storage.schemas
LDFLAGS.Darwin+= -lresolv
BUILDLINK_DEPENDS.glib2+= glib2>=2.6.0
BUILDLINK_DEPENDS.glib2+= glib2>=2.9.3
.include "Makefile.common"
PKGREVISION= 5
.include "../../devel/GConf2/schemas.mk"

View file

@ -1,11 +1,13 @@
# $NetBSD: Makefile.common,v 1.29 2006/01/20 13:29:13 jmmv Exp $
# $NetBSD: Makefile.common,v 1.30 2006/03/30 21:07:48 jmmv Exp $
#
DISTNAME= gnome-vfs-2.12.2
GNOME_VFS2_VERSION= 2.14.0
DISTNAME= gnome-vfs-${GNOME_VFS2_VERSION}
PKGNAME= ${DISTNAME:S/vfs/vfs2/}
CATEGORIES?= sysutils
CATEGORIES+= gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gnome-vfs/2.12/}
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gnome-vfs/2.14/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= jmmv@NetBSD.org
@ -37,6 +39,8 @@ CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc
CPPFLAGS+= -DPREFIX="\"${PREFIX}\""
CPPFLAGS+= -DPKG_SYSCONFDIR="\"${PKG_SYSCONFDIR}\""
INSTALL_MAKE_FLAGS+= modulesconfdir=${PREFIX}/share/examples/gnome-vfs-2.0/modules
PKG_SYSCONFSUBDIR= gnome-vfs-2.0
EGDIR= ${PREFIX}/share/examples/gnome-vfs-2.0
@ -82,7 +86,7 @@ SUBST_STAGE.libs= pre-configure
SUBST_FILES.libs= modules/Makefile.in
SUBST_SED.libs= -e 's|../libgnomevfs/libgnomevfs-2.la|${BUILDLINK_PREFIX.gnome-vfs2}/lib/libgnomevfs-2.la|g'
BUILDLINK_DEPENDS.gnome-vfs2+= gnome-vfs2>=2.12.1.1
BUILDLINK_DEPENDS.gnome-vfs2+= gnome-vfs2>=${GNOME_VFS2_VERSION}
.include "../../sysutils/gnome-vfs2/buildlink3.mk"
PRINT_PLIST_AWK+= /^@dirrm lib\/gnome-vfs-2.0\/modules$$/ \

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.19 2006/01/20 13:29:13 jmmv Exp $
@comment $NetBSD: PLIST,v 1.20 2006/03/30 21:07:48 jmmv Exp $
bin/gnomevfs-cat
bin/gnomevfs-copy
bin/gnomevfs-info
@ -49,6 +49,7 @@ include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-module-callback-module-api.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-module-shared.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-module.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-parse-ls.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-pty.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-socket-buffer.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-socket.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-ssl.h
@ -73,6 +74,67 @@ lib/libgnomevfs-2.la
lib/pkgconfig/gnome-vfs-2.0.pc
lib/pkgconfig/gnome-vfs-module-2.0.pc
libexec/gnome-vfs-daemon
share/doc/gnome-vfs-2.0/about.html
share/doc/gnome-vfs-2.0/advanced-operations.html
share/doc/gnome-vfs-2.0/data-types.html
share/doc/gnome-vfs-2.0/gnome-vfs-2.0.devhelp
share/doc/gnome-vfs-2.0/gnome-vfs-2.0.devhelp2
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-application-registry.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-async-ops.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-cancellation.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-context.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-directory-basic-ops.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-directory-find-ops.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-directory-list-ops.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-dns-sd.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-drive.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-advanced-ops.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-basic-ops.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-info-ops.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-info.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-rw-ops.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-size.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-trunc-ops.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-inet-connection.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-init.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-method.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-mime-database-deprecated.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-mime-database.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-mime-monitor.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-mime.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-module-callback-module-api.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-module-callback.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-module-shared.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-module.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-monitor.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-parse-ls.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-resolve.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-result.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-socket-buffer.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-socket.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-ssl.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-standard-callbacks.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-transform.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-uri.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-utils.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-volume-monitor.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-volume.html
share/doc/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-xfer.html
share/doc/gnome-vfs-2.0/gnome-vfs-directory-operations.html
share/doc/gnome-vfs-2.0/gnome-vfs-file-and-dirs-ops.html
share/doc/gnome-vfs-2.0/gnome-vfs-first-steps.html
share/doc/gnome-vfs-2.0/gnome-vfs-writing-modules.html
share/doc/gnome-vfs-2.0/home.png
share/doc/gnome-vfs-2.0/index.html
share/doc/gnome-vfs-2.0/index.sgml
share/doc/gnome-vfs-2.0/left.png
share/doc/gnome-vfs-2.0/mime-registry.html
share/doc/gnome-vfs-2.0/modules.html
share/doc/gnome-vfs-2.0/networking.html
share/doc/gnome-vfs-2.0/right.png
share/doc/gnome-vfs-2.0/style.css
share/doc/gnome-vfs-2.0/up.png
share/doc/gnome-vfs-2.0/volumes.html
share/examples/gnome-vfs-2.0/modules/default-modules.conf
share/examples/gnome-vfs-2.0/modules/ssl-modules.conf
share/gconf/schemas/desktop_default_applications.schemas
@ -80,7 +142,6 @@ share/gconf/schemas/desktop_gnome_url_handlers.schemas
share/gconf/schemas/system_dns_sd.schemas
share/gconf/schemas/system_http_proxy.schemas
share/gconf/schemas/system_smb.schemas
share/gconf/schemas/system_storage.schemas
${PKGLOCALEDIR}/locale/af/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/am/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/ar/LC_MESSAGES/gnome-vfs-2.0.mo
@ -153,11 +214,13 @@ ${PKGLOCALEDIR}/locale/wa/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/xh/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/yi/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/zh_CN/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/zh_HK/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/zh_TW/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/zu/LC_MESSAGES/gnome-vfs-2.0.mo
@comment in GConf2: @dirrm share/gconf/schemas
@dirrm share/examples/gnome-vfs-2.0/modules
@dirrm share/examples/gnome-vfs-2.0
@dirrm share/doc/gnome-vfs-2.0
@dirrm lib/gnome-vfs-2.0/modules
@dirrm lib/gnome-vfs-2.0/include
@dirrm lib/gnome-vfs-2.0

View file

@ -1,22 +1,23 @@
$NetBSD: distinfo,v 1.47 2006/03/29 20:41:12 jmmv Exp $
$NetBSD: distinfo,v 1.48 2006/03/30 21:07:48 jmmv Exp $
SHA1 (gnome-vfs-2.12.2.tar.bz2) = fa8248e18cb8b44f617a5b1bb776df37628828ea
RMD160 (gnome-vfs-2.12.2.tar.bz2) = 831d83c791631e7273fdebec1047da6055757104
Size (gnome-vfs-2.12.2.tar.bz2) = 1558218 bytes
SHA1 (gnome-vfs-2.14.0.tar.bz2) = 32ca078efe4bd8785d4f01f210a465c460966db5
RMD160 (gnome-vfs-2.14.0.tar.bz2) = 8f5eb53c1458a514af12edcc902f74d0121b50e9
Size (gnome-vfs-2.14.0.tar.bz2) = 1807647 bytes
SHA1 (patch-aa) = a5a3ac6be3e2a888eaaab108807d2aff651e62db
SHA1 (patch-ab) = 6320180870f234a150dfe40f8f990deec7a2a0b5
SHA1 (patch-ac) = 5b8ffa3994440c09da0b2fe53b05ccb333b0778e
SHA1 (patch-ad) = fe233b03b0fc97f7bd34b29d79fef38f900365f4
SHA1 (patch-ae) = 572b40dfa035dab5ef374aa73d2acacfcb72d641
SHA1 (patch-af) = 6724c4a43d0d9525f5361ba7380c91adbf656e56
SHA1 (patch-ag) = 78f7d50beaeab8b33c554e6cfaf510cdba3b00ba
SHA1 (patch-ah) = 4bd07f6c3d356505babba2a14e250c5f480296c0
SHA1 (patch-ah) = 0927ade189c14472e5768b7e4775854de519f19c
SHA1 (patch-ai) = 6afefb35bfe3fc37e84048b95ccc272a01542ec2
SHA1 (patch-aj) = 0159ed71a69f4f15a4353d0bb9400e9341b59b9d
SHA1 (patch-am) = 4e037da71db0d3aae236475a0f2ead12738f35f9
SHA1 (patch-ao) = 0cc64574f6d430ca385f22d28690b9cea9181390
SHA1 (patch-ap) = 98ad7700d01007510467e2ae4ee8554f54f15320
SHA1 (patch-aq) = 1d5ed4d6c1b3a282e68bedf6892fa8a9678ea39b
SHA1 (patch-ar) = 99c99d0d90ed7a0d804b349f532d3a17c780d506
SHA1 (patch-ar) = edb0363525d023d14b43aabd89ccebe4d6695a8e
SHA1 (patch-au) = e3c681dd445d0774981a50eb22ae14ff4db5902c
SHA1 (patch-aw) = 22801eb932f8f7e7256be3863fcd5273a7a5213e
SHA1 (patch-ax) = a8bea4b2f4432506e9d4407beaaa2e3655ca6235
SHA1 (patch-ax) = 06a104c8ae3caf01a2bf6899cd2b85980c0bb26d
SHA1 (patch-az) = 50d74fbf4973a5f6366a20b89e17bab450e73784

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ac,v 1.9 2006/03/30 21:07:48 jmmv Exp $
http://bugzilla.gnome.org/show_bug.cgi?id=336390
--- libgnomevfs/gnome-vfs-address.c.orig 2005-12-09 11:39:00.000000000 +0100
+++ libgnomevfs/gnome-vfs-address.c
@@ -388,8 +388,7 @@ static gboolean
v6_v6_equal (const struct sockaddr_in6 *a,
const struct sockaddr_in6 *b)
{
- return IN6_ARE_ADDR_EQUAL (a->sin6_addr.s6_addr,
- b->sin6_addr.s6_addr);
+ return IN6_ARE_ADDR_EQUAL (&a->sin6_addr, &b->sin6_addr);
}
static gboolean

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ag,v 1.8 2004/11/28 13:00:17 recht Exp $
--- modules/Makefile.in.orig Thu Oct 28 16:16:58 2004
+++ modules/Makefile.in Sat Nov 27 20:52:14 2004
@@ -291,7 +291,7 @@
# Not currently supported
# libnfs.la
-modulesconfdir = $(sysconfdir)/gnome-vfs-2.0/modules
+modulesconfdir = $(datadir)/examples/gnome-vfs-2.0/modules
@HAVE_CDDA_TRUE@CDDA_CONF = cdda-module.conf
@HAVE_SAMBA_TRUE@SMB_CONF = smb-module.conf
@HAVE_SSL_TRUE@SSL_CONF = ssl-modules.conf

View file

@ -1,17 +1,15 @@
$NetBSD: patch-ah,v 1.6 2005/10/07 16:10:44 drochner Exp $
$NetBSD: patch-ah,v 1.7 2006/03/30 21:07:48 jmmv Exp $
--- libgnomevfs/gnome-vfs-resolve.c.orig 2005-04-19 13:54:52.000000000 +0200
http://bugzilla.gnome.org/show_bug.cgi?id=336391
--- libgnomevfs/gnome-vfs-resolve.c.orig 2005-12-02 19:00:26.000000000 +0100
+++ libgnomevfs/gnome-vfs-resolve.c
@@ -172,9 +172,11 @@ _gnome_vfs_result_from_gai_error (int er
@@ -172,7 +172,7 @@ _gnome_vfs_result_from_gai_error (int er
case EAI_NONAME: return GNOME_VFS_ERROR_HOST_NOT_FOUND;
#ifdef EAI_ADDRFAMILY
- case EAI_ADDRFAMILY:
+ case EAI_ADDRFAMILY: return GNOME_VFS_ERROR_HOST_HAS_NO_ADDRESS;
+ case EAI_ADDRFAMILY: return GNOME_VFS_ERROR_HOST_HAS_NO_ADDRESS;
#endif
+#ifdef EAI_NODATA
#ifdef EAI_NODATA
case EAI_NODATA: return GNOME_VFS_ERROR_HOST_HAS_NO_ADDRESS;
+#endif
#ifdef EAI_SYSTEM
case EAI_SYSTEM: return gnome_vfs_result_from_errno ();
#endif

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aj,v 1.6 2006/03/30 21:07:48 jmmv Exp $
--- libgnomevfs/gnome-vfs-volume-ops.c.orig 2006-03-06 10:09:51.000000000 +0100
+++ libgnomevfs/gnome-vfs-volume-ops.c
@@ -25,6 +25,7 @@
#include <sys/types.h>
#include <errno.h>
+#include <signal.h>
#include <string.h>
#include <stdlib.h>
#include <glib.h>

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ar,v 1.1 2004/10/24 18:03:24 recht Exp $
$NetBSD: patch-ar,v 1.2 2006/03/30 21:07:48 jmmv Exp $
--- modules/pty-open.c.orig Sun Oct 24 19:06:16 2004
+++ modules/pty-open.c Sun Oct 24 19:17:26 2004
@@ -554,6 +554,7 @@
--- libgnomevfs/gnome-vfs-pty.c.orig 2005-11-22 15:10:17.000000000 +0100
+++ libgnomevfs/gnome-vfs-pty.c
@@ -629,6 +629,7 @@ _gnome_vfs_pty_set_size(int master, int
static char *
_gnome_vfs_pty_ptsname(int master)
{
@ -10,7 +10,7 @@ $NetBSD: patch-ar,v 1.1 2004/10/24 18:03:24 recht Exp $
#if defined(HAVE_PTSNAME_R)
gsize len = 1024;
char *buf = NULL;
@@ -599,6 +600,7 @@
@@ -674,6 +675,7 @@ _gnome_vfs_pty_ptsname(int master)
return g_strdup_printf("/dev/pts/%d", pty);
}
#endif
@ -18,7 +18,7 @@ $NetBSD: patch-ar,v 1.1 2004/10/24 18:03:24 recht Exp $
return NULL;
}
@@ -606,10 +608,10 @@
@@ -681,10 +683,10 @@ static int
_gnome_vfs_pty_getpt(void)
{
int fd, flags;
@ -31,7 +31,7 @@ $NetBSD: patch-ar,v 1.1 2004/10/24 18:03:24 recht Exp $
fd = posix_openpt(O_RDWR | O_NOCTTY);
#else
/* Try to allocate a pty by accessing the pty master multiplex. */
@@ -628,7 +630,7 @@
@@ -703,7 +705,7 @@ _gnome_vfs_pty_getpt(void)
static int
_gnome_vfs_pty_grantpt(int master)
{
@ -40,7 +40,7 @@ $NetBSD: patch-ar,v 1.1 2004/10/24 18:03:24 recht Exp $
return grantpt(master);
#else
return 0;
@@ -638,6 +640,9 @@
@@ -713,6 +715,9 @@ _gnome_vfs_pty_grantpt(int master)
static int
_gnome_vfs_pty_unlockpt(int fd)
{
@ -50,11 +50,11 @@ $NetBSD: patch-ar,v 1.1 2004/10/24 18:03:24 recht Exp $
#ifdef HAVE_UNLOCKPT
return unlockpt(fd);
#elif defined(TIOCSPTLCK)
@@ -645,6 +650,7 @@
return ioctl(fd, TIOCSPTLCK, &zero);
@@ -721,6 +726,7 @@ _gnome_vfs_pty_unlockpt(int fd)
#else
return -1;
+#endif
#endif
+#endif
}
static int

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ax,v 1.1 2005/12/05 07:52:49 rillig Exp $
$NetBSD: patch-ax,v 1.2 2006/03/30 21:07:48 jmmv Exp $
--- libgnomevfs/gnome-vfs-mime-handlers.c.orig 2005-05-26 14:25:10.000000000 +0200
+++ libgnomevfs/gnome-vfs-mime-handlers.c 2005-12-05 08:49:19.899254800 +0100
--- libgnomevfs/gnome-vfs-mime-handlers.c.orig 2006-02-06 11:11:51.000000000 +0100
+++ libgnomevfs/gnome-vfs-mime-handlers.c
@@ -40,6 +40,10 @@
#define GCONF_DEFAULT_VIEWER_EXEC_PATH "/desktop/gnome/applications/component_viewer/exec"
@ -12,4 +12,4 @@ $NetBSD: patch-ax,v 1.1 2005/12/05 07:52:49 rillig Exp $
+
#define MIXED_API_WARNING "Cannot call %s with a GNOMEVFSMimeApplication structure "\
"constructed by the deprecated application registry", \
__FUNCTION__
G_GNUC_FUNCTION