Add breezy (brz), a successor to bazaar (bzr).
Breezy (brz) is a decentralized revision control system, designed to be easy for developers and end users alike. By default, Breezy provides support for both the `Bazaar <https://www.bazaar-vcs.org>`_ and `Git <https://www.git-scm.com/>`_ file formats. To learn how to use Breezy, see the official documentation in the `doc` directory or refer to the Bazaar documentation at <https://www.breezy-vcs.org/doc/en/>. Breezy is a friendly fork of the Bazaar (``bzr``) project, hosted on http://bazaar.canonical.com/. It is backwards compatibility with Bazaar's disk format and protocols. One of the key differences with Bazaar is that Breezy also runs on Python 3.3 and later, in addition to Python 2.7.
This commit is contained in:
parent
7970825f08
commit
ad6eb2941c
6 changed files with 2932 additions and 0 deletions
16
devel/breezy/DESCR
Normal file
16
devel/breezy/DESCR
Normal file
|
@ -0,0 +1,16 @@
|
|||
Breezy (brz) is a decentralized revision control system, designed to be
|
||||
easy for developers and end users alike.
|
||||
|
||||
By default, Breezy provides support for both the `Bazaar
|
||||
<https://www.bazaar-vcs.org>`_ and `Git <https://www.git-scm.com/>`_ file
|
||||
formats.
|
||||
|
||||
To learn how to use Breezy, see the official documentation in the `doc`
|
||||
directory or refer to the Bazaar documentation at
|
||||
<https://www.breezy-vcs.org/doc/en/>.
|
||||
|
||||
Breezy is a friendly fork of the Bazaar (``bzr``) project, hosted on
|
||||
http://bazaar.canonical.com/. It is backwards compatibility with
|
||||
Bazaar's disk format and protocols. One of the key differences with
|
||||
Bazaar is that Breezy also runs on Python 3.3 and later, in addition to
|
||||
Python 2.7.
|
7
devel/breezy/MESSAGE
Normal file
7
devel/breezy/MESSAGE
Normal file
|
@ -0,0 +1,7 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.1 2019/10/27 13:05:46 rhialto Exp $
|
||||
|
||||
bzr requires security/py-paramiko in order to push branches over sftp
|
||||
and www/py-curl to verify https certificates. For the "shelve" command
|
||||
devel/py-curses is required.
|
||||
===========================================================================
|
55
devel/breezy/Makefile
Normal file
55
devel/breezy/Makefile
Normal file
|
@ -0,0 +1,55 @@
|
|||
# $NetBSD: Makefile,v 1.1 2019/10/27 13:05:46 rhialto Exp $
|
||||
|
||||
DISTNAME= breezy-3.0.1
|
||||
CATEGORIES= devel scm
|
||||
MASTER_SITES= https://launchpad.net/brz/${PKGVERSION_NOREV:R}/${PKGVERSION_NOREV}/+download/
|
||||
|
||||
MAINTAINER= rhialto@NetBSD.org
|
||||
HOMEPAGE= http://breezy-vcs.org/
|
||||
COMMENT= Friendly distributed version control system
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
# For building from repo instead of release tarball:
|
||||
#BUILD_DEPENDS+= ${PYPKGPREFIX}-cython>=0:../../devel/py-cython
|
||||
DEPENDS+= ${PYPKGPREFIX}-configobj>0:../../devel/py-configobj
|
||||
DEPENDS+= ${PYPKGPREFIX}-dulwich>0:../../devel/py-dulwich
|
||||
DEPENDS+= ${PYPKGPREFIX}-fastimport>0:../../devel/py-fastimport
|
||||
DEPENDS+= ${PYPKGPREFIX}-six>0:../../lang/py-six
|
||||
# Not yet packaged; only needed for lp: shortcuts.
|
||||
#DEPENDS+= ${PYPKGPREFIX}-launchpadlib>=1.6.3:../../devel/py-launchpadlib
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-testtools>=0:../../devel/py-testtools
|
||||
|
||||
USE_TOOLS+= gmake msgfmt
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 38 37 36 35 34 33
|
||||
|
||||
REPLACE_PYTHON+= breezy/git/bzr-receive-pack
|
||||
REPLACE_PYTHON+= breezy/git/bzr-upload-pack
|
||||
REPLACE_PYTHON+= breezy/git/git-remote-bzr
|
||||
REPLACE_PYTHON+= breezy/git/git_remote_helper.py
|
||||
REPLACE_PYTHON+= breezy/patiencediff.py breezy/_patiencediff_py.py
|
||||
REPLACE_PYTHON+= breezy/plugins/bash_completion/bashcomp.py
|
||||
REPLACE_PYTHON+= breezy/tests/ssl_certs/create_ssls.py
|
||||
REPLACE_PYTHON+= breezy/version_info_formats/format_python.py
|
||||
REPLACE_PYTHON+= brz
|
||||
REPLACE_PYTHON+= contrib/brz_access
|
||||
#REPLACE_PYTHON+= tools/*.py tools/subunit-sum tools/time_graph.py
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
SUBST_CLASSES+= python
|
||||
SUBST_MESSAGE.python= Fix python path for test case.
|
||||
SUBST_STAGE.python= post-extract
|
||||
SUBST_FILES.python+= Makefile
|
||||
SUBST_SED.python+= -e 's,=python,=${PYTHONBIN},'
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC} && ${PYTHONBIN} tools/generate_docs.py man
|
||||
|
||||
do-test:
|
||||
cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ./brz selftest -v
|
||||
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
2830
devel/breezy/PLIST
Normal file
2830
devel/breezy/PLIST
Normal file
File diff suppressed because it is too large
Load diff
7
devel/breezy/distinfo
Normal file
7
devel/breezy/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2019/10/27 13:05:46 rhialto Exp $
|
||||
|
||||
SHA1 (breezy-3.0.1.tar.gz) = c90e5dc90d5fdc3219cc1b6efd86e8b3f28bd085
|
||||
RMD160 (breezy-3.0.1.tar.gz) = 1d6ac8f21600da771a513bee158bee45090270c1
|
||||
SHA512 (breezy-3.0.1.tar.gz) = 5376498e04c31092b34d445c7439c6d46439fd7800af224db15d3c85e8264e23514c34d4a9a9cb9555ec4cd5d6d2a47b0b96f0707d28c933e79824d34bee975c
|
||||
Size (breezy-3.0.1.tar.gz) = 15187201 bytes
|
||||
SHA1 (patch-breezy_tests_test__server.py) = 768c43eb412fc688c49ac5037c4dc18b046b1be0
|
17
devel/breezy/patches/patch-breezy_tests_test__server.py
Normal file
17
devel/breezy/patches/patch-breezy_tests_test__server.py
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-breezy_tests_test__server.py,v 1.1 2019/10/27 13:05:46 rhialto Exp $
|
||||
|
||||
Stub out call to shutdown() since it mysteriously fails with
|
||||
an OSError exception with EINVAL.
|
||||
See https://bugs.launchpad.net/brz/+bug/1849971
|
||||
|
||||
--- breezy/tests/test_server.py.orig 2019-06-16 22:18:58.000000000 +0000
|
||||
+++ breezy/tests/test_server.py
|
||||
@@ -381,7 +381,7 @@ class TestingTCPServerMixin(object):
|
||||
socket.
|
||||
"""
|
||||
try:
|
||||
- sock.shutdown(socket.SHUT_RDWR)
|
||||
+ # sock.shutdown(socket.SHUT_RDWR) # fails with EINVAL
|
||||
sock.close()
|
||||
except Exception as e:
|
||||
if self.ignored_exceptions(e):
|
Loading…
Reference in a new issue