we already patched SUBDIRS= # empty because this only builds imake, so

also comment out #define IHaveSubdirs.

imake builds different targets for "includes" based on whether
IHaveSubdirs is defined. however, this was only working by chance
because if IHaveSubdirs is defined, the shell code
used is:

	for blah in $(SUBDIRS); do

which doesn't work with Solaris sh(1) or ksh(1), where NetBSD sh(1),
bash(1), etc. just skip empty for loops.

fixes install on Solaris.
This commit is contained in:
grant 2004-07-03 04:05:13 +00:00
parent ed0e189c1c
commit ad75d933c1
2 changed files with 16 additions and 7 deletions

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.3 2004/03/28 22:06:16 xtraeme Exp $ $NetBSD: distinfo,v 1.4 2004/07/03 04:05:13 grant Exp $
SHA1 (XFree86-4.4.0-src-1.tgz) = 44b38a7044c82d0b2f785b0e6a935349abcb5d79 SHA1 (XFree86-4.4.0-src-1.tgz) = 44b38a7044c82d0b2f785b0e6a935349abcb5d79
Size (XFree86-4.4.0-src-1.tgz) = 11760814 bytes Size (XFree86-4.4.0-src-1.tgz) = 11760814 bytes
SHA1 (XFree86-4.4.0-src-3.tgz) = a012694d5a5aa3df1d9a3a52363d73cf8f03326b SHA1 (XFree86-4.4.0-src-3.tgz) = a012694d5a5aa3df1d9a3a52363d73cf8f03326b
Size (XFree86-4.4.0-src-3.tgz) = 11239253 bytes Size (XFree86-4.4.0-src-3.tgz) = 11239253 bytes
SHA1 (patch-aa) = 554472267b9a5bc6614b11c6688325c1fd7ffc0e SHA1 (patch-aa) = 554472267b9a5bc6614b11c6688325c1fd7ffc0e
SHA1 (patch-ab) = f9da29ae63b2adc563df4230ce8daa9fc75ad8ca SHA1 (patch-ab) = ae70833052df746763d7e02fe364e851357be7fd
SHA1 (patch-ac) = ae90c06b50d5d8b84054cc66beec0d0e3049d0aa SHA1 (patch-ac) = ae90c06b50d5d8b84054cc66beec0d0e3049d0aa
SHA1 (patch-ad) = 90584e5732fb882f431afd69f6fd1c26c9d22bee SHA1 (patch-ad) = 90584e5732fb882f431afd69f6fd1c26c9d22bee
SHA1 (patch-ae) = b34f46d715e90159df3897cf20023b58b9deff67 SHA1 (patch-ae) = b34f46d715e90159df3897cf20023b58b9deff67

View file

@ -1,8 +1,17 @@
$NetBSD: patch-ab,v 1.1.1.1 2004/01/24 08:43:27 xtraeme Exp $ $NetBSD: patch-ab,v 1.2 2004/07/03 04:05:13 grant Exp $
--- include/Imakefile.orig 2003-07-03 14:43:15.000000000 +0200 --- include/Imakefile.orig 2001-08-28 03:40:56.000000000 +1000
+++ include/Imakefile 2003-07-03 14:44:23.000000000 +0200 +++ include/Imakefile
@@ -15,7 +15,7 @@ @@ -4,7 +4,7 @@ XCOMM $Xorg: Imakefile,v 1.3 2000/08/18
XCOMM $XFree86: xc/include/Imakefile,v 3.29 2001/08/27 17:40:56 dawes Exp $
-#define IHaveSubdirs
+XCOMM #define IHaveSubdirs
#define PassCDebugFlags /**/
#if BuildGlxExt || BuildGLXLibrary
@@ -15,7 +15,7 @@ GLXDIR = GL
DPSDIR = DPS DPSDIR = DPS
#endif #endif
@ -11,7 +20,7 @@ $NetBSD: patch-ab,v 1.1.1.1 2004/01/24 08:43:27 xtraeme Exp $
#ifdef Win32Architecture #ifdef Win32Architecture
EXTRA_HEADERS = Xw32defs.h Xwinsock.h EXTRA_HEADERS = Xw32defs.h Xwinsock.h
@@ -50,9 +50,6 @@ @@ -50,9 +50,6 @@ all::
BuildIncludes($(HEADERS),X11,..) BuildIncludes($(HEADERS),X11,..)