Provide a patch to configure. Expand AUTOMAKE_PATTERNS so that we don't
need autoconf as a build dependency.
This commit is contained in:
parent
6f4d4be1f3
commit
ad883543b0
3 changed files with 430 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.11 2001/08/27 14:35:15 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2002/03/15 17:05:37 skrll Exp $
|
||||
|
||||
DISTNAME= eperl-2.2.14
|
||||
CATEGORIES= lang perl5 textproc
|
||||
|
@ -8,7 +8,6 @@ MAINTAINER= packages@netbsd.org
|
|||
HOMEPAGE= http://www.engelschall.com/sw/eperl/
|
||||
COMMENT= Interpreter/preprocessor for Perl embedded in text documents
|
||||
|
||||
BUILD_DEPENDS+= autoconf>=2.13:../../devel/autoconf
|
||||
DEPENDS= libperl>=${LIBPERL5_REQD}:../../lang/libperl
|
||||
|
||||
USE_PERL5= # defined
|
||||
|
@ -18,8 +17,7 @@ PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/Parse/ePerl/.packlist
|
|||
GNU_CONFIGURE= # defined
|
||||
ALL_TARGET= all libeperl.a
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && ${LOCALBASE}/bin/autoreconf
|
||||
AUTOMAKE_PATTERNS+= config_ac.h.in
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC}/mod/Parse; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.4 2001/06/09 15:15:28 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.5 2002/03/15 17:05:37 skrll Exp $
|
||||
|
||||
SHA1 (eperl-2.2.14.tar.gz) = cf05566602d93019a38638a6958739a1e192ead7
|
||||
Size (eperl-2.2.14.tar.gz) = 199664 bytes
|
||||
|
@ -6,3 +6,4 @@ SHA1 (patch-aa) = 6eae0f635bae79bdd6fa88878f191e59b5f4fe92
|
|||
SHA1 (patch-ab) = 09a2274193bea7052a5367d18ec2e15ed7596129
|
||||
SHA1 (patch-ac) = c876f95efa24d348c8c42fa91123d0db316315bc
|
||||
SHA1 (patch-ad) = a96ebbbafb70829ca00fda2a840172034250e31e
|
||||
SHA1 (patch-ae) = 25b88531b1356ea1191911887204d49111aed263
|
||||
|
|
426
textproc/eperl/patches/patch-ae
Normal file
426
textproc/eperl/patches/patch-ae
Normal file
|
@ -0,0 +1,426 @@
|
|||
$NetBSD: patch-ae,v 1.1 2002/03/15 17:05:39 skrll Exp $
|
||||
|
||||
--- configure.orig Sun Aug 2 14:48:40 1998
|
||||
+++ configure
|
||||
@@ -26,7 +26,7 @@
|
||||
|
||||
|
||||
# Guess values for system-dependent variables and create Makefiles.
|
||||
-# Generated automatically using autoconf version 2.12
|
||||
+# Generated automatically using autoconf version 2.13
|
||||
# Copyright (C) 1992, 93, 94, 95, 96 Free Software Foundation, Inc.
|
||||
#
|
||||
# This configure script is free software; the Free Software Foundation
|
||||
@@ -79,6 +79,7 @@
|
||||
# Initialize some other variables.
|
||||
subdirs=
|
||||
MFLAGS= MAKEFLAGS=
|
||||
+SHELL=${CONFIG_SHELL-/bin/sh}
|
||||
# Maximum number of lines to put in a shell here document.
|
||||
ac_max_here_lines=12
|
||||
|
||||
@@ -362,7 +363,7 @@
|
||||
verbose=yes ;;
|
||||
|
||||
-version | --version | --versio | --versi | --vers)
|
||||
- echo "configure generated by autoconf version 2.12"
|
||||
+ echo "configure generated by autoconf version 2.13"
|
||||
exit 0 ;;
|
||||
|
||||
-with-* | --with-*)
|
||||
@@ -532,9 +533,11 @@
|
||||
# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
|
||||
ac_cpp='$CPP $CPPFLAGS'
|
||||
ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
|
||||
-ac_link='${CC-cc} -o conftest $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
|
||||
+ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
|
||||
cross_compiling=$ac_cv_prog_cc_cross
|
||||
|
||||
+ac_exeext=
|
||||
+ac_objext=o
|
||||
if (echo "testing\c"; echo 1,2,3) | grep c >/dev/null; then
|
||||
# Stardent Vistra SVR4 grep lacks -e, says ghazi@caip.rutgers.edu.
|
||||
if (echo -n testing; echo 1,2,3) | sed s/-n/xn/ | grep xn >/dev/null; then
|
||||
@@ -571,7 +574,7 @@
|
||||
if test "${with_perl+set}" = set; then
|
||||
withval="$with_perl"
|
||||
perlprog=$with_perl
|
||||
-perlvers=`$perlprog -v | grep version | sed -e 's/.* version //' -e 's/ built.*//' -e 's/ with.*//'`
|
||||
+perlvers=`$perlprog -v | grep "This is perl" | sed -e 's/.* version //' -e 's/.* v//' -e 's/ built.*//' -e 's/ with.*//'`
|
||||
|
||||
else
|
||||
TMPFILE=/tmp/x.$$
|
||||
@@ -583,7 +586,7 @@
|
||||
if test -f "$dir/$perl"; then
|
||||
if test -x "$dir/$perl"; then
|
||||
perl="$dir/$perl"
|
||||
- version=`$perl -v | grep version | sed -e 's/.* version //' -e 's/ built.*//' -e 's/ with.*//'`
|
||||
+ version=`$perl -v | grep "This is perl" | sed -e 's/.* version //' -e 's/.* v//' -e 's/ built.*//' -e 's/ with.*//'`
|
||||
versionnum="`echo $version | sed -e 's/\.//g' -e 's/_//g'`"
|
||||
versionnum=`expr $versionnum - $c`
|
||||
echo "$versionnum $version $perl" >>$TMPFILE
|
||||
@@ -600,7 +603,7 @@
|
||||
PATH_PERL=$perlprog
|
||||
echo "$ac_t""$perlprog v$perlvers" 1>&6
|
||||
case $perlvers in
|
||||
- 5.003* | 5.004* | 5.005* | 5.006* )
|
||||
+ 5.003* | 5.004* | 5.005* | 5.006* | 5.[1-9]* )
|
||||
;;
|
||||
* ) echo ""
|
||||
echo "Latest Perl found on your system is $perlvers,"
|
||||
@@ -617,6 +620,12 @@
|
||||
perlvnum=`echo $perlvers | sed -e 's/\.//' -e 's/_//'` ;;
|
||||
5.00[3-6] )
|
||||
perlvnum=`echo $perlvers | sed -e 's/\.//' -e 's/$/00/'` ;;
|
||||
+ 5.[1-9].[0-9][0-9] )
|
||||
+ perlvnum=`echo $perlvers | sed -e 's/\./10/' -e 's/\.//'` ;;
|
||||
+ 5.[1-9].[0-9] )
|
||||
+ perlvnum=`echo $perlvers | sed -e 's/\./10/' -e 's/\./0/'` ;;
|
||||
+ 5.[1-9] )
|
||||
+ perlvnum=`echo $perlvers | sed -e 's/\./10/' -e 's/$/00/'` ;;
|
||||
* )
|
||||
perlvnum=`echo $perlvers | sed -e 's/\.//' -e 's/_//'` ;;
|
||||
esac
|
||||
@@ -770,8 +779,9 @@
|
||||
if test -n "$CC"; then
|
||||
ac_cv_prog_CC="$CC" # Let the user override the test.
|
||||
else
|
||||
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:"
|
||||
- for ac_dir in $PATH; do
|
||||
+ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
|
||||
+ ac_dummy="$PATH"
|
||||
+ for ac_dir in $ac_dummy; do
|
||||
test -z "$ac_dir" && ac_dir=.
|
||||
if test -f $ac_dir/$ac_word; then
|
||||
ac_cv_prog_CC="gcc"
|
||||
@@ -799,9 +809,10 @@
|
||||
if test -n "$CC"; then
|
||||
ac_cv_prog_CC="$CC" # Let the user override the test.
|
||||
else
|
||||
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:"
|
||||
+ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
|
||||
ac_prog_rejected=no
|
||||
- for ac_dir in $PATH; do
|
||||
+ ac_dummy="$PATH"
|
||||
+ for ac_dir in $ac_dummy; do
|
||||
test -z "$ac_dir" && ac_dir=.
|
||||
if test -f $ac_dir/$ac_word; then
|
||||
if test "$ac_dir/$ac_word" = "/usr/ucb/cc"; then
|
||||
@@ -836,6 +847,40 @@
|
||||
echo "$ac_t""no" 1>&6
|
||||
fi
|
||||
|
||||
+ if test -z "$CC"; then
|
||||
+ case "`uname -s`" in
|
||||
+ *win32* | *WIN32*)
|
||||
+ # Extract the first word of "cl", so it can be a program name with args.
|
||||
+set dummy cl; ac_word=$2
|
||||
+echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
||||
+echo "configure:857: checking for $ac_word" >&5
|
||||
+if eval "test \"`echo '$''{'ac_cv_prog_CC'+set}'`\" = set"; then
|
||||
+ echo $ac_n "(cached) $ac_c" 1>&6
|
||||
+else
|
||||
+ if test -n "$CC"; then
|
||||
+ ac_cv_prog_CC="$CC" # Let the user override the test.
|
||||
+else
|
||||
+ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
|
||||
+ ac_dummy="$PATH"
|
||||
+ for ac_dir in $ac_dummy; do
|
||||
+ test -z "$ac_dir" && ac_dir=.
|
||||
+ if test -f $ac_dir/$ac_word; then
|
||||
+ ac_cv_prog_CC="cl"
|
||||
+ break
|
||||
+ fi
|
||||
+ done
|
||||
+ IFS="$ac_save_ifs"
|
||||
+fi
|
||||
+fi
|
||||
+CC="$ac_cv_prog_CC"
|
||||
+if test -n "$CC"; then
|
||||
+ echo "$ac_t""$CC" 1>&6
|
||||
+else
|
||||
+ echo "$ac_t""no" 1>&6
|
||||
+fi
|
||||
+ ;;
|
||||
+ esac
|
||||
+ fi
|
||||
test -z "$CC" && { echo "configure: error: no acceptable cc found in \$PATH" 1>&2; exit 1; }
|
||||
fi
|
||||
|
||||
@@ -846,15 +891,17 @@
|
||||
# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
|
||||
ac_cpp='$CPP $CPPFLAGS'
|
||||
ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
|
||||
-ac_link='${CC-cc} -o conftest $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
|
||||
+ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
|
||||
cross_compiling=$ac_cv_prog_cc_cross
|
||||
|
||||
-cat > conftest.$ac_ext <<EOF
|
||||
-#line 854 "configure"
|
||||
+cat > conftest.$ac_ext << EOF
|
||||
+
|
||||
+#line 900 "configure"
|
||||
#include "confdefs.h"
|
||||
+
|
||||
main(){return(0);}
|
||||
EOF
|
||||
-if { (eval echo configure:858: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
|
||||
+if { (eval echo configure:905: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
ac_cv_prog_cc_works=yes
|
||||
# If we can't run a trivial program, we are probably using a cross compiler.
|
||||
if (./conftest; exit) 2>/dev/null; then
|
||||
@@ -868,6 +915,12 @@
|
||||
ac_cv_prog_cc_works=no
|
||||
fi
|
||||
rm -fr conftest*
|
||||
+ac_ext=c
|
||||
+# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
|
||||
+ac_cpp='$CPP $CPPFLAGS'
|
||||
+ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
|
||||
+ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
|
||||
+cross_compiling=$ac_cv_prog_cc_cross
|
||||
|
||||
echo "$ac_t""$ac_cv_prog_cc_works" 1>&6
|
||||
if test $ac_cv_prog_cc_works = no; then
|
||||
@@ -899,11 +952,15 @@
|
||||
|
||||
if test $ac_cv_prog_gcc = yes; then
|
||||
GCC=yes
|
||||
- ac_test_CFLAGS="${CFLAGS+set}"
|
||||
- ac_save_CFLAGS="$CFLAGS"
|
||||
- CFLAGS=
|
||||
- echo $ac_n "checking whether ${CC-cc} accepts -g""... $ac_c" 1>&6
|
||||
-echo "configure:907: checking whether ${CC-cc} accepts -g" >&5
|
||||
+else
|
||||
+ GCC=
|
||||
+fi
|
||||
+
|
||||
+ac_test_CFLAGS="${CFLAGS+set}"
|
||||
+ac_save_CFLAGS="$CFLAGS"
|
||||
+CFLAGS=
|
||||
+echo $ac_n "checking whether ${CC-cc} accepts -g""... $ac_c" 1>&6
|
||||
+echo "configure:964: checking whether ${CC-cc} accepts -g" >&5
|
||||
if eval "test \"`echo '$''{'ac_cv_prog_cc_g'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
@@ -918,16 +975,20 @@
|
||||
fi
|
||||
|
||||
echo "$ac_t""$ac_cv_prog_cc_g" 1>&6
|
||||
- if test "$ac_test_CFLAGS" = set; then
|
||||
- CFLAGS="$ac_save_CFLAGS"
|
||||
- elif test $ac_cv_prog_cc_g = yes; then
|
||||
+if test "$ac_test_CFLAGS" = set; then
|
||||
+ CFLAGS="$ac_save_CFLAGS"
|
||||
+elif test $ac_cv_prog_cc_g = yes; then
|
||||
+ if test "$GCC" = yes; then
|
||||
CFLAGS="-g -O2"
|
||||
else
|
||||
- CFLAGS="-O2"
|
||||
+ CFLAGS="-g"
|
||||
fi
|
||||
else
|
||||
- GCC=
|
||||
- test "${CFLAGS+set}" = set || CFLAGS="-g"
|
||||
+ if test "$GCC" = yes; then
|
||||
+ CFLAGS="-O2"
|
||||
+ else
|
||||
+ CFLAGS=
|
||||
+ fi
|
||||
fi
|
||||
|
||||
# Extract the first word of "ranlib", so it can be a program name with args.
|
||||
@@ -940,8 +1001,9 @@
|
||||
if test -n "$RANLIB"; then
|
||||
ac_cv_prog_RANLIB="$RANLIB" # Let the user override the test.
|
||||
else
|
||||
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:"
|
||||
- for ac_dir in $PATH; do
|
||||
+ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
|
||||
+ ac_dummy="$PATH"
|
||||
+ for ac_dir in $ac_dummy; do
|
||||
test -z "$ac_dir" && ac_dir=.
|
||||
if test -f $ac_dir/$ac_word; then
|
||||
ac_cv_prog_RANLIB="ranlib"
|
||||
@@ -969,8 +1031,9 @@
|
||||
if test -n "$AR"; then
|
||||
ac_cv_prog_AR="$AR" # Let the user override the test.
|
||||
else
|
||||
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:"
|
||||
- for ac_dir in $PATH; do
|
||||
+ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
|
||||
+ ac_dummy="$PATH"
|
||||
+ for ac_dir in $ac_dummy; do
|
||||
test -z "$ac_dir" && ac_dir=.
|
||||
if test -f $ac_dir/$ac_word; then
|
||||
ac_cv_prog_AR="ar"
|
||||
@@ -997,8 +1060,9 @@
|
||||
if test -n "$SIZE"; then
|
||||
ac_cv_prog_SIZE="$SIZE" # Let the user override the test.
|
||||
else
|
||||
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:"
|
||||
- for ac_dir in $PATH; do
|
||||
+ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
|
||||
+ ac_dummy="$PATH"
|
||||
+ for ac_dir in $ac_dummy; do
|
||||
test -z "$ac_dir" && ac_dir=.
|
||||
if test -f $ac_dir/$ac_word; then
|
||||
ac_cv_prog_SIZE="size"
|
||||
@@ -1103,6 +1167,7 @@
|
||||
# SunOS /usr/etc/install
|
||||
# IRIX /sbin/install
|
||||
# AIX /bin/install
|
||||
+# AIX 4 /usr/bin/installbsd, which doesn't work without a -g flag
|
||||
# AFS /usr/afsws/bin/install, which mishandles nonexistent args
|
||||
# SVR4 /usr/ucb/install, which tries to use the nonexistent group "staff"
|
||||
# ./install, which can be erroneously created by make from ./install.sh.
|
||||
@@ -1112,19 +1177,20 @@
|
||||
if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
- IFS="${IFS= }"; ac_save_IFS="$IFS"; IFS="${IFS}:"
|
||||
+ IFS="${IFS= }"; ac_save_IFS="$IFS"; IFS=":"
|
||||
for ac_dir in $PATH; do
|
||||
# Account for people who put trailing slashes in PATH elements.
|
||||
case "$ac_dir/" in
|
||||
/|./|.//|/etc/*|/usr/sbin/*|/usr/etc/*|/sbin/*|/usr/afsws/bin/*|/usr/ucb/*) ;;
|
||||
*)
|
||||
# OSF1 and SCO ODT 3.0 have their own names for install.
|
||||
- for ac_prog in ginstall installbsd scoinst install; do
|
||||
+ # Don't use installbsd from OSF since it installs stuff as root
|
||||
+ # by default.
|
||||
+ for ac_prog in ginstall scoinst install; do
|
||||
if test -f $ac_dir/$ac_prog; then
|
||||
if test $ac_prog = install &&
|
||||
grep dspmsg $ac_dir/$ac_prog >/dev/null 2>&1; then
|
||||
# AIX install. It has an incompatible calling convention.
|
||||
- # OSF/1 installbsd also uses dspmsg, but is usable.
|
||||
:
|
||||
else
|
||||
ac_cv_path_install="$ac_dir/$ac_prog -c"
|
||||
@@ -1154,6 +1220,8 @@
|
||||
# It thinks the first close brace ends the variable substitution.
|
||||
test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='${INSTALL}'
|
||||
|
||||
+test -z "$INSTALL_SCRIPT" && INSTALL_SCRIPT='${INSTALL_PROGRAM}'
|
||||
+
|
||||
test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
|
||||
|
||||
INSTALL_DATA='${INSTALL} -m 644'
|
||||
@@ -1261,8 +1329,8 @@
|
||||
Syntax Error
|
||||
EOF
|
||||
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
||||
-{ (eval echo configure:1265: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
||||
-ac_err=`grep -v '^ *+' conftest.out`
|
||||
+{ (eval echo configure:1333: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
||||
+ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
||||
if test -z "$ac_err"; then
|
||||
:
|
||||
else
|
||||
@@ -1278,8 +1346,25 @@
|
||||
Syntax Error
|
||||
EOF
|
||||
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
||||
-{ (eval echo configure:1282: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
||||
-ac_err=`grep -v '^ *+' conftest.out`
|
||||
+{ (eval echo configure:1350: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
||||
+ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
||||
+if test -z "$ac_err"; then
|
||||
+ :
|
||||
+else
|
||||
+ echo "$ac_err" >&5
|
||||
+ echo "configure: failed program was:" >&5
|
||||
+ cat conftest.$ac_ext >&5
|
||||
+ rm -rf conftest*
|
||||
+ CPP="${CC-cc} -nologo -E"
|
||||
+ cat > conftest.$ac_ext <<EOF
|
||||
+#line 1361 "configure"
|
||||
+#include "confdefs.h"
|
||||
+#include <assert.h>
|
||||
+Syntax Error
|
||||
+EOF
|
||||
+ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
||||
+{ (eval echo configure:1367: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
||||
+ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
||||
if test -z "$ac_err"; then
|
||||
:
|
||||
else
|
||||
@@ -1292,6 +1377,8 @@
|
||||
rm -f conftest*
|
||||
fi
|
||||
rm -f conftest*
|
||||
+fi
|
||||
+rm -f conftest*
|
||||
ac_cv_prog_CPP="$CPP"
|
||||
fi
|
||||
CPP="$ac_cv_prog_CPP"
|
||||
@@ -1314,8 +1401,8 @@
|
||||
#include <float.h>
|
||||
EOF
|
||||
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
||||
-{ (eval echo configure:1318: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
||||
-ac_err=`grep -v '^ *+' conftest.out`
|
||||
+{ (eval echo configure:1405: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
||||
+ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
||||
if test -z "$ac_err"; then
|
||||
rm -rf conftest*
|
||||
ac_cv_header_stdc=yes
|
||||
@@ -1418,8 +1505,8 @@
|
||||
#include <$ac_hdr>
|
||||
EOF
|
||||
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
||||
-{ (eval echo configure:1422: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
||||
-ac_err=`grep -v '^ *+' conftest.out`
|
||||
+{ (eval echo configure:1509: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
||||
+ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
||||
if test -z "$ac_err"; then
|
||||
rm -rf conftest*
|
||||
eval "ac_cv_header_$ac_safe=yes"
|
||||
@@ -1459,7 +1546,7 @@
|
||||
#endif
|
||||
EOF
|
||||
if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
|
||||
- egrep "bool[^a-zA-Z_0-9]" >/dev/null 2>&1; then
|
||||
+ egrep "(^|[^a-zA-Z_0-9])bool[^a-zA-Z_0-9]" >/dev/null 2>&1; then
|
||||
rm -rf conftest*
|
||||
ac_cv_type_bool=yes
|
||||
else
|
||||
@@ -1726,7 +1813,7 @@
|
||||
# Ultrix sh set writes to stderr and can't be redirected directly,
|
||||
# and sets the high bit in the cache file unless we assign to the vars.
|
||||
(set) 2>&1 |
|
||||
- case `(ac_space=' '; set) 2>&1` in
|
||||
+ case `(ac_space=' '; set | grep ac_space) 2>&1` in
|
||||
*ac_space=\ *)
|
||||
# `set' does not quote correctly, so add quotes (double-quote substitution
|
||||
# turns \\\\ into \\, and sed turns \\ into \).
|
||||
@@ -1793,7 +1880,7 @@
|
||||
echo "running \${CONFIG_SHELL-/bin/sh} $0 $ac_configure_args --no-create --no-recursion"
|
||||
exec \${CONFIG_SHELL-/bin/sh} $0 $ac_configure_args --no-create --no-recursion ;;
|
||||
-version | --version | --versio | --versi | --vers | --ver | --ve | --v)
|
||||
- echo "$CONFIG_STATUS generated by autoconf version 2.12"
|
||||
+ echo "$CONFIG_STATUS generated by autoconf version 2.13"
|
||||
exit 0 ;;
|
||||
-help | --help | --hel | --he | --h)
|
||||
echo "\$ac_cs_usage"; exit 0 ;;
|
||||
@@ -1813,9 +1900,11 @@
|
||||
s/@@/%@/; s/@@/@%/; s/@g\$/%g/' > conftest.subs <<\\CEOF
|
||||
$ac_vpsub
|
||||
$extrasub
|
||||
+s%@SHELL@%$SHELL%g
|
||||
s%@CFLAGS@%$CFLAGS%g
|
||||
s%@CPPFLAGS@%$CPPFLAGS%g
|
||||
s%@CXXFLAGS@%$CXXFLAGS%g
|
||||
+s%@FFLAGS@%$FFLAGS%g
|
||||
s%@DEFS@%$DEFS%g
|
||||
s%@LDFLAGS@%$LDFLAGS%g
|
||||
s%@LIBS@%$LIBS%g
|
||||
@@ -1865,6 +1954,7 @@
|
||||
s%@dmalloc@%$dmalloc%g
|
||||
s%@SET_MAKE@%$SET_MAKE%g
|
||||
s%@INSTALL_PROGRAM@%$INSTALL_PROGRAM%g
|
||||
+s%@INSTALL_SCRIPT@%$INSTALL_SCRIPT%g
|
||||
s%@INSTALL_DATA@%$INSTALL_DATA%g
|
||||
s%@CPP@%$CPP%g
|
||||
|
Loading…
Reference in a new issue