Require C++11 when building with Clang. Fix fallout of Boost update due

to MOC's limited C preprocessor. Derive template arguments of make_pair
automatically.
This commit is contained in:
joerg 2013-02-26 23:37:32 +00:00
parent e50ac4f4e9
commit ad8c20e185
6 changed files with 78 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.13 2013/02/16 11:23:26 wiz Exp $
# $NetBSD: Makefile,v 1.14 2013/02/26 23:37:32 joerg Exp $
DISTNAME= rocs-${_KDE_VERSION}
PKGREVISION= 10
@ -13,4 +13,9 @@ COMMENT= KDE graph theory IDE
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/kdelibs4/buildlink3.mk"
.include "../../mk/compiler.mk"
.if !empty(PKGSRC_COMPILER:Mclang)
CXXFLAGS+= -std=c++11
.endif
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,9 @@
$NetBSD: distinfo,v 1.3 2012/06/16 04:45:34 markd Exp $
$NetBSD: distinfo,v 1.4 2013/02/26 23:37:32 joerg Exp $
SHA1 (rocs-4.8.4.tar.xz) = 991e5aa15e59cc432a9c9f140fe90bd47f8f8e15
RMD160 (rocs-4.8.4.tar.xz) = 1960ba3fbaabf2a9658f260d7a96de2b699b0829
Size (rocs-4.8.4.tar.xz) = 665416 bytes
SHA1 (patch-src_Plugins_AssignValues_assignvalueswidget.h) = 4bb8cc6a7bd276a3f2b1dbf2797f519def0263e8
SHA1 (patch-src_Plugins_DataStructure_Graph_GraphStructure.cpp) = dca421dd83d7f293c84a776626315ebca3beedda
SHA1 (patch-src_Plugins_GenerateGraph_generategraphwidget.h) = e24a9018a75bc2d769c51a314bd4b667c8b097ee
SHA1 (patch-src_Plugins_TransformEdges_transformedgeswidget.h) = 5232f933597dd6f31957f6d6f804993fd60cacc5

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_Plugins_AssignValues_assignvalueswidget.h,v 1.1 2013/02/26 23:37:32 joerg Exp $
--- src/Plugins/AssignValues/assignvalueswidget.h.orig 2011-11-17 20:57:24.000000000 +0000
+++ src/Plugins/AssignValues/assignvalueswidget.h
@@ -21,8 +21,10 @@
#include <QWidget>
+#ifndef Q_MOC_RUN
#include <boost/graph/adjacency_list.hpp>
#include <boost/graph/topology.hpp>
+#endif
#include <KDialog>
#include "Rocs_Typedefs.h"

View file

@ -0,0 +1,22 @@
$NetBSD: patch-src_Plugins_DataStructure_Graph_GraphStructure.cpp,v 1.1 2013/02/26 23:37:32 joerg Exp $
--- src/Plugins/DataStructure/Graph/GraphStructure.cpp.orig 2013-02-26 22:55:07.000000000 +0000
+++ src/Plugins/DataStructure/Graph/GraphStructure.cpp
@@ -153,7 +153,7 @@ QScriptValue Rocs::GraphStructure::dijks
BOOST_FOREACH( PointerPtr p, this->pointers() )
{
edges[counter] = Edge(node_mapping[p->from().get()], node_mapping[p->to().get()]);
- edge_mapping[std::make_pair<int,int>(node_mapping[p->from().get()], node_mapping[p->to().get()])] = p;
+ edge_mapping[std::make_pair(node_mapping[p->from().get()], node_mapping[p->to().get()])] = p;
if (!p->value().isEmpty()) {
weights[counter] = p->value().toDouble();
} else {
@@ -163,7 +163,7 @@ QScriptValue Rocs::GraphStructure::dijks
// if graph is directed, also add back-edges
if(!this->directed()) {
edges[counter] = Edge(node_mapping[p->to().get()], node_mapping[p->from().get()]);
- edge_mapping[std::make_pair<int,int>(node_mapping[p->to().get()], node_mapping[p->from().get()])] = p;
+ edge_mapping[std::make_pair(node_mapping[p->to().get()], node_mapping[p->from().get()])] = p;
if (!p->value().isEmpty()) {
weights[counter] = p->value().toDouble();
} else {

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_Plugins_GenerateGraph_generategraphwidget.h,v 1.1 2013/02/26 23:37:32 joerg Exp $
--- src/Plugins/GenerateGraph/generategraphwidget.h.orig 2012-01-02 19:52:41.000000000 +0000
+++ src/Plugins/GenerateGraph/generategraphwidget.h
@@ -22,8 +22,10 @@
#include <QWidget>
#include <KDialog>
+#ifndef Q_MOC_RUN
#include <boost/graph/adjacency_list.hpp>
#include <boost/graph/topology.hpp>
+#endif
class QGridLayout;
class Document;

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_Plugins_TransformEdges_transformedgeswidget.h,v 1.1 2013/02/26 23:37:32 joerg Exp $
--- src/Plugins/TransformEdges/transformedgeswidget.h.orig 2011-09-26 09:45:24.000000000 +0000
+++ src/Plugins/TransformEdges/transformedgeswidget.h
@@ -22,8 +22,10 @@
#include <QWidget>
#include <KDialog>
+#ifndef Q_MOC_RUN
#include <boost/graph/adjacency_list.hpp>
#include <boost/graph/topology.hpp>
+#endif
#include "Rocs_Typedefs.h"