update to 2.28.2
This switches to the new glib-2.28 branch which is intended to help transition to glib/gtk3. Still binary compatible. (The unix socket credential passing stuff needs work, but this is new and thus no regression.)
This commit is contained in:
parent
d489a65c92
commit
adaca7ef2a
7 changed files with 243 additions and 57 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.178 2011/02/20 17:40:54 jmmv Exp $
|
||||
# $NetBSD: Makefile,v 1.179 2011/03/09 11:22:04 drochner Exp $
|
||||
|
||||
.include "Makefile.common"
|
||||
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= devel
|
||||
|
||||
COMMENT= Some useful routines for C programming (glib2)
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
# $NetBSD: Makefile.common,v 1.6 2010/11/20 01:36:49 obache Exp $
|
||||
# $NetBSD: Makefile.common,v 1.7 2011/03/09 11:22:04 drochner Exp $
|
||||
#
|
||||
# used by devel/glib2/Makefile
|
||||
# used by sysutils/gio-fam/Makefile
|
||||
|
||||
# When updating this package, please apply patch-ak to configure.in and
|
||||
# then run a matching version of autoconf to regen patch-aa.
|
||||
DISTNAME= glib-2.26.1
|
||||
DISTNAME= glib-2.28.2
|
||||
PKGNAME= ${DISTNAME:S/glib/glib2/}
|
||||
CATEGORIES= # empty; redefined in Makefile
|
||||
MASTER_SITES= ftp://ftp.gtk.org/pub/glib/2.26/ \
|
||||
${MASTER_SITE_GNOME:=sources/glib/2.26/}
|
||||
MASTER_SITES= ftp://ftp.gtk.org/pub/glib/2.28/ \
|
||||
${MASTER_SITE_GNOME:=sources/glib/2.28/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.56 2010/11/15 14:36:03 drochner Exp $
|
||||
@comment $NetBSD: PLIST,v 1.57 2011/03/09 11:22:04 drochner Exp $
|
||||
bin/gdbus
|
||||
bin/gio-querymodules
|
||||
bin/glib-compile-schemas
|
||||
|
@ -19,7 +19,11 @@ include/glib/gio-unix-2.0/gio/gunixinputstream.h
|
|||
include/glib/gio-unix-2.0/gio/gunixmounts.h
|
||||
include/glib/gio-unix-2.0/gio/gunixoutputstream.h
|
||||
include/glib/gio-unix-2.0/gio/gunixsocketaddress.h
|
||||
include/glib/glib-2.0/gio/gaction.h
|
||||
include/glib/glib-2.0/gio/gactiongroup.h
|
||||
include/glib/glib-2.0/gio/gappinfo.h
|
||||
include/glib/glib-2.0/gio/gapplication.h
|
||||
include/glib/glib-2.0/gio/gapplicationcommandline.h
|
||||
include/glib/glib-2.0/gio/gasyncinitable.h
|
||||
include/glib/glib-2.0/gio/gasyncresult.h
|
||||
include/glib/glib-2.0/gio/gbufferedinputstream.h
|
||||
|
@ -83,6 +87,8 @@ include/glib/glib-2.0/gio/gnetworkaddress.h
|
|||
include/glib/glib-2.0/gio/gnetworkservice.h
|
||||
include/glib/glib-2.0/gio/goutputstream.h
|
||||
include/glib/glib-2.0/gio/gpermission.h
|
||||
include/glib/glib-2.0/gio/gpollableinputstream.h
|
||||
include/glib/glib-2.0/gio/gpollableoutputstream.h
|
||||
include/glib/glib-2.0/gio/gproxy.h
|
||||
include/glib/glib-2.0/gio/gproxyaddress.h
|
||||
include/glib/glib-2.0/gio/gproxyaddressenumerator.h
|
||||
|
@ -91,6 +97,8 @@ include/glib/glib-2.0/gio/gresolver.h
|
|||
include/glib/glib-2.0/gio/gseekable.h
|
||||
include/glib/glib-2.0/gio/gsettings.h
|
||||
include/glib/glib-2.0/gio/gsettingsbackend.h
|
||||
include/glib/glib-2.0/gio/gsimpleaction.h
|
||||
include/glib/glib-2.0/gio/gsimpleactiongroup.h
|
||||
include/glib/glib-2.0/gio/gsimpleasyncresult.h
|
||||
include/glib/glib-2.0/gio/gsimplepermission.h
|
||||
include/glib/glib-2.0/gio/gsocket.h
|
||||
|
@ -104,8 +112,14 @@ include/glib/glib-2.0/gio/gsocketlistener.h
|
|||
include/glib/glib-2.0/gio/gsocketservice.h
|
||||
include/glib/glib-2.0/gio/gsrvtarget.h
|
||||
include/glib/glib-2.0/gio/gtcpconnection.h
|
||||
include/glib/glib-2.0/gio/gtcpwrapperconnection.h
|
||||
include/glib/glib-2.0/gio/gthemedicon.h
|
||||
include/glib/glib-2.0/gio/gthreadedsocketservice.h
|
||||
include/glib/glib-2.0/gio/gtlsbackend.h
|
||||
include/glib/glib-2.0/gio/gtlscertificate.h
|
||||
include/glib/glib-2.0/gio/gtlsclientconnection.h
|
||||
include/glib/glib-2.0/gio/gtlsconnection.h
|
||||
include/glib/glib-2.0/gio/gtlsserverconnection.h
|
||||
include/glib/glib-2.0/gio/gvfs.h
|
||||
include/glib/glib-2.0/gio/gvolume.h
|
||||
include/glib/glib-2.0/gio/gvolumemonitor.h
|
||||
|
@ -225,14 +239,18 @@ man/man1/gtester.1
|
|||
share/aclocal/glib-2.0.m4
|
||||
share/aclocal/glib-gettext.m4
|
||||
share/aclocal/gsettings.m4
|
||||
share/gdb/auto-load/libglib-2.0.so.0.2600.1-gdb.py
|
||||
share/gdb/auto-load/libgobject-2.0.so.0.2600.1-gdb.py
|
||||
share/gdb/auto-load/libglib-2.0.so.0.2800.2-gdb.py
|
||||
share/gdb/auto-load/libgobject-2.0.so.0.2800.2-gdb.py
|
||||
share/glib-2.0/gdb/glib.py
|
||||
share/glib-2.0/gdb/gobject.py
|
||||
share/glib-2.0/gettext/mkinstalldirs
|
||||
share/glib-2.0/gettext/po/Makefile.in.in
|
||||
share/glib-2.0/schemas/gschema.dtd
|
||||
share/gtk-doc/html/gio/GAction.html
|
||||
share/gtk-doc/html/gio/GActionGroup.html
|
||||
share/gtk-doc/html/gio/GAppInfo.html
|
||||
share/gtk-doc/html/gio/GApplication.html
|
||||
share/gtk-doc/html/gio/GApplicationCommandLine.html
|
||||
share/gtk-doc/html/gio/GAsyncInitable.html
|
||||
share/gtk-doc/html/gio/GAsyncResult.html
|
||||
share/gtk-doc/html/gio/GBufferedInputStream.html
|
||||
|
@ -243,6 +261,7 @@ share/gtk-doc/html/gio/GConverter.html
|
|||
share/gtk-doc/html/gio/GCredentials.html
|
||||
share/gtk-doc/html/gio/GDBusAuthObserver.html
|
||||
share/gtk-doc/html/gio/GDBusConnection.html
|
||||
share/gtk-doc/html/gio/GDBusError.html
|
||||
share/gtk-doc/html/gio/GDBusMessage.html
|
||||
share/gtk-doc/html/gio/GDBusMethodInvocation.html
|
||||
share/gtk-doc/html/gio/GDBusProxy.html
|
||||
|
@ -280,6 +299,8 @@ share/gtk-doc/html/gio/GNetworkAddress.html
|
|||
share/gtk-doc/html/gio/GNetworkService.html
|
||||
share/gtk-doc/html/gio/GOutputStream.html
|
||||
share/gtk-doc/html/gio/GPermission.html
|
||||
share/gtk-doc/html/gio/GPollableInputStream.html
|
||||
share/gtk-doc/html/gio/GPollableOutputStream.html
|
||||
share/gtk-doc/html/gio/GProxy.html
|
||||
share/gtk-doc/html/gio/GProxyAddress.html
|
||||
share/gtk-doc/html/gio/GProxyResolver.html
|
||||
|
@ -287,6 +308,8 @@ share/gtk-doc/html/gio/GResolver.html
|
|||
share/gtk-doc/html/gio/GSeekable.html
|
||||
share/gtk-doc/html/gio/GSettings.html
|
||||
share/gtk-doc/html/gio/GSettingsBackend.html
|
||||
share/gtk-doc/html/gio/GSimpleAction.html
|
||||
share/gtk-doc/html/gio/GSimpleActionGroup.html
|
||||
share/gtk-doc/html/gio/GSimpleAsyncResult.html
|
||||
share/gtk-doc/html/gio/GSimplePermission.html
|
||||
share/gtk-doc/html/gio/GSocket.html
|
||||
|
@ -297,9 +320,16 @@ share/gtk-doc/html/gio/GSocketConnection.html
|
|||
share/gtk-doc/html/gio/GSocketControlMessage.html
|
||||
share/gtk-doc/html/gio/GSocketListener.html
|
||||
share/gtk-doc/html/gio/GSocketService.html
|
||||
share/gtk-doc/html/gio/GSrvTarget.html
|
||||
share/gtk-doc/html/gio/GTcpConnection.html
|
||||
share/gtk-doc/html/gio/GTcpWrapperConnection.html
|
||||
share/gtk-doc/html/gio/GThemedIcon.html
|
||||
share/gtk-doc/html/gio/GThreadedSocketService.html
|
||||
share/gtk-doc/html/gio/GTlsBackend.html
|
||||
share/gtk-doc/html/gio/GTlsCertificate.html
|
||||
share/gtk-doc/html/gio/GTlsClientConnection.html
|
||||
share/gtk-doc/html/gio/GTlsConnection.html
|
||||
share/gtk-doc/html/gio/GTlsServerConnection.html
|
||||
share/gtk-doc/html/gio/GUnixConnection.html
|
||||
share/gtk-doc/html/gio/GUnixCredentialsMessage.html
|
||||
share/gtk-doc/html/gio/GUnixFDList.html
|
||||
|
@ -318,29 +348,31 @@ share/gtk-doc/html/gio/api-index-2-20.html
|
|||
share/gtk-doc/html/gio/api-index-2-22.html
|
||||
share/gtk-doc/html/gio/api-index-2-24.html
|
||||
share/gtk-doc/html/gio/api-index-2-26.html
|
||||
share/gtk-doc/html/gio/api-index-2-28.html
|
||||
share/gtk-doc/html/gio/api-index-deprecated.html
|
||||
share/gtk-doc/html/gio/api-index-full.html
|
||||
share/gtk-doc/html/gio/application.html
|
||||
share/gtk-doc/html/gio/async.html
|
||||
share/gtk-doc/html/gio/ch01.html
|
||||
share/gtk-doc/html/gio/ch02.html
|
||||
share/gtk-doc/html/gio/ch03.html
|
||||
share/gtk-doc/html/gio/ch24.html
|
||||
share/gtk-doc/html/gio/ch25.html
|
||||
share/gtk-doc/html/gio/ch25s02.html
|
||||
share/gtk-doc/html/gio/ch25s03.html
|
||||
share/gtk-doc/html/gio/ch26.html
|
||||
share/gtk-doc/html/gio/ch26s02.html
|
||||
share/gtk-doc/html/gio/ch26s03.html
|
||||
share/gtk-doc/html/gio/ch26s04.html
|
||||
share/gtk-doc/html/gio/ch26s05.html
|
||||
share/gtk-doc/html/gio/ch26s06.html
|
||||
share/gtk-doc/html/gio/ch26s07.html
|
||||
share/gtk-doc/html/gio/ch27.html
|
||||
share/gtk-doc/html/gio/ch27s02.html
|
||||
share/gtk-doc/html/gio/ch27s03.html
|
||||
share/gtk-doc/html/gio/ch27s04.html
|
||||
share/gtk-doc/html/gio/ch27s05.html
|
||||
share/gtk-doc/html/gio/ch27s06.html
|
||||
share/gtk-doc/html/gio/ch28.html
|
||||
share/gtk-doc/html/gio/ch28s02.html
|
||||
share/gtk-doc/html/gio/ch28s03.html
|
||||
share/gtk-doc/html/gio/ch28s04.html
|
||||
share/gtk-doc/html/gio/ch28s05.html
|
||||
share/gtk-doc/html/gio/ch28s06.html
|
||||
share/gtk-doc/html/gio/ch28s07.html
|
||||
share/gtk-doc/html/gio/ch29.html
|
||||
share/gtk-doc/html/gio/ch29s02.html
|
||||
share/gtk-doc/html/gio/ch29s03.html
|
||||
share/gtk-doc/html/gio/ch29s04.html
|
||||
share/gtk-doc/html/gio/ch29s05.html
|
||||
share/gtk-doc/html/gio/ch29s06.html
|
||||
share/gtk-doc/html/gio/conversion.html
|
||||
share/gtk-doc/html/gio/extending-gio.html
|
||||
share/gtk-doc/html/gio/extending.html
|
||||
|
@ -358,12 +390,11 @@ share/gtk-doc/html/gio/gio-Extension-Points.html
|
|||
share/gtk-doc/html/gio/gio-GContentType.html
|
||||
share/gtk-doc/html/gio/gio-GConverterInputstream.html
|
||||
share/gtk-doc/html/gio/gio-GConverterOutputstream.html
|
||||
share/gtk-doc/html/gio/gio-GDBusError.html
|
||||
share/gtk-doc/html/gio/gio-GFileAttribute.html
|
||||
share/gtk-doc/html/gio/gio-GIOError.html
|
||||
share/gtk-doc/html/gio/gio-GIOScheduler.html
|
||||
share/gtk-doc/html/gio/gio-GSrvTarget.html
|
||||
share/gtk-doc/html/gio/gio-Owning-Bus-Names.html
|
||||
share/gtk-doc/html/gio/gio-TLS-Overview.html
|
||||
share/gtk-doc/html/gio/gio-Unix-Mounts.html
|
||||
share/gtk-doc/html/gio/gio-Watching-Bus-Names.html
|
||||
share/gtk-doc/html/gio/gio-hierarchy.html
|
||||
|
@ -371,7 +402,7 @@ share/gtk-doc/html/gio/gio-querymodules.html
|
|||
share/gtk-doc/html/gio/gio.devhelp
|
||||
share/gtk-doc/html/gio/gio.devhelp2
|
||||
share/gtk-doc/html/gio/glib-compile-schemas.html
|
||||
share/gtk-doc/html/gio/gsettings.html
|
||||
share/gtk-doc/html/gio/gsettings-tool.html
|
||||
share/gtk-doc/html/gio/gvfs-overview.png
|
||||
share/gtk-doc/html/gio/highlevel-socket.html
|
||||
share/gtk-doc/html/gio/home.png
|
||||
|
@ -389,6 +420,7 @@ share/gtk-doc/html/gio/right.png
|
|||
share/gtk-doc/html/gio/settings.html
|
||||
share/gtk-doc/html/gio/streaming.html
|
||||
share/gtk-doc/html/gio/style.css
|
||||
share/gtk-doc/html/gio/tls.html
|
||||
share/gtk-doc/html/gio/tools.html
|
||||
share/gtk-doc/html/gio/types.html
|
||||
share/gtk-doc/html/gio/up.png
|
||||
|
@ -405,6 +437,7 @@ share/gtk-doc/html/glib/api-index-2-20.html
|
|||
share/gtk-doc/html/glib/api-index-2-22.html
|
||||
share/gtk-doc/html/glib/api-index-2-24.html
|
||||
share/gtk-doc/html/glib/api-index-2-26.html
|
||||
share/gtk-doc/html/glib/api-index-2-28.html
|
||||
share/gtk-doc/html/glib/api-index-2-4.html
|
||||
share/gtk-doc/html/glib/api-index-2-6.html
|
||||
share/gtk-doc/html/glib/api-index-2-8.html
|
||||
|
@ -499,6 +532,7 @@ share/gtk-doc/html/glib/glib.html
|
|||
share/gtk-doc/html/glib/gtester-report.html
|
||||
share/gtk-doc/html/glib/gtester.html
|
||||
share/gtk-doc/html/glib/gvariant-format-strings.html
|
||||
share/gtk-doc/html/glib/gvariant-text.html
|
||||
share/gtk-doc/html/glib/home.png
|
||||
share/gtk-doc/html/glib/index.html
|
||||
share/gtk-doc/html/glib/index.sgml
|
||||
|
@ -520,6 +554,7 @@ share/gtk-doc/html/gobject/api-index-2-2.html
|
|||
share/gtk-doc/html/gobject/api-index-2-22.html
|
||||
share/gtk-doc/html/gobject/api-index-2-24.html
|
||||
share/gtk-doc/html/gobject/api-index-2-26.html
|
||||
share/gtk-doc/html/gobject/api-index-2-28.html
|
||||
share/gtk-doc/html/gobject/api-index-2-4.html
|
||||
share/gtk-doc/html/gobject/api-index-2-6.html
|
||||
share/gtk-doc/html/gobject/api-index-2-8.html
|
||||
|
@ -668,6 +703,7 @@ share/locale/th/LC_MESSAGES/glib20.mo
|
|||
share/locale/tl/LC_MESSAGES/glib20.mo
|
||||
share/locale/tr/LC_MESSAGES/glib20.mo
|
||||
share/locale/tt/LC_MESSAGES/glib20.mo
|
||||
share/locale/ug/LC_MESSAGES/glib20.mo
|
||||
share/locale/uk/LC_MESSAGES/glib20.mo
|
||||
share/locale/vi/LC_MESSAGES/glib20.mo
|
||||
share/locale/wa/LC_MESSAGES/glib20.mo
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.146 2011/02/03 15:12:45 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.147 2011/03/09 11:22:04 drochner Exp $
|
||||
|
||||
SHA1 (glib-2.26.1.tar.bz2) = 8d35d5cf41d681dd6480a16be39f7d3cffbd29f0
|
||||
RMD160 (glib-2.26.1.tar.bz2) = e8b00fce55aa539ee00588500c0162a8877dc060
|
||||
Size (glib-2.26.1.tar.bz2) = 6704686 bytes
|
||||
SHA1 (glib-2.28.2.tar.bz2) = a15cb7caedde819ec74bd8b5cdf31f7372e5fd14
|
||||
RMD160 (glib-2.28.2.tar.bz2) = c6a6469018806ee733546d16fb738e2a3e84a5f0
|
||||
Size (glib-2.28.2.tar.bz2) = 6844578 bytes
|
||||
SHA1 (patch-aa) = 44a3cc4b457ea75a3516d5c49155a3720bde515f
|
||||
SHA1 (patch-ab) = 757cfd7f686d3e3147d13f530d1c85c7835bf762
|
||||
SHA1 (patch-ac) = 96e153339675457356f71e35d20375bed669d337
|
||||
|
@ -18,6 +18,8 @@ SHA1 (patch-al) = bde29693322c568f9a4ad090f1d469de5f69920e
|
|||
SHA1 (patch-am) = 062d3d295f00485ac3c3839dd4697957ebc66772
|
||||
SHA1 (patch-an) = dd136645f7555f3600562b055cdcb4f60b41ae78
|
||||
SHA1 (patch-ao) = 293b462565ef4991af807e79c1200df5458058e7
|
||||
SHA1 (patch-ap) = 3df3c29373efb491d1b0e96d57a192b1b30f2cfa
|
||||
SHA1 (patch-aq) = 65c5aa7833d31e54e1486e06bb72e632b8a16c9a
|
||||
SHA1 (patch-ba) = b235c2037bce84e0cdd9c87abaac274550ec0c95
|
||||
SHA1 (patch-cb) = 0f084c33fb67fbb8e12448034450699da26289ff
|
||||
SHA1 (patch-cc) = dd73079b727bca9013465204dc3b53b76a280e54
|
||||
|
@ -27,4 +29,4 @@ SHA1 (patch-cf) = 41ed2146e19cf088456795d4f0e8dc4af4368e44
|
|||
SHA1 (patch-cg) = f65c5a23102d3dee12bee68bd126385b3c3fe632
|
||||
SHA1 (patch-ch) = df8444835b9954f902936c8b6fab5b44ac350db0
|
||||
SHA1 (patch-ci) = f0191fd416222617a2e95e95a05c3dcf6b6ce2d2
|
||||
SHA1 (patch-cj) = f2135bffbc9c220696b005736d772fff5e9a5d58
|
||||
SHA1 (patch-cj) = a624367e0c5ba0b6bbd25e7e5a2664c284534a53
|
||||
|
|
99
devel/glib2/patches/patch-ap
Normal file
99
devel/glib2/patches/patch-ap
Normal file
|
@ -0,0 +1,99 @@
|
|||
$NetBSD: patch-ap,v 1.1 2011/03/09 11:22:04 drochner Exp $
|
||||
|
||||
--- gio/gcredentials.c.orig 2011-02-11 15:23:11.000000000 +0000
|
||||
+++ gio/gcredentials.c
|
||||
@@ -27,6 +27,9 @@
|
||||
#include <sys/socket.h>
|
||||
#include <string.h>
|
||||
#endif
|
||||
+#ifdef __NetBSD__
|
||||
+#include <string.h>
|
||||
+#endif
|
||||
#include <stdlib.h>
|
||||
|
||||
#include <gobject/gvaluecollector.h>
|
||||
@@ -82,6 +85,12 @@ struct _GCredentials
|
||||
struct ucred native;
|
||||
#elif defined(__FreeBSD__)
|
||||
struct cmsgcred native;
|
||||
+#elif defined(__NetBSD__)
|
||||
+ struct {
|
||||
+ pid_t pid;
|
||||
+ uid_t uid;
|
||||
+ gid_t gid;
|
||||
+ } native;
|
||||
#else
|
||||
#ifdef __GNUC__
|
||||
#warning Please add GCredentials support for your OS
|
||||
@@ -126,7 +135,7 @@ g_credentials_class_init (GCredentialsCl
|
||||
static void
|
||||
g_credentials_init (GCredentials *credentials)
|
||||
{
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) || defined(__NetBSD__)
|
||||
credentials->native.pid = getpid ();
|
||||
credentials->native.uid = geteuid ();
|
||||
credentials->native.gid = getegid ();
|
||||
@@ -178,7 +187,7 @@ g_credentials_to_string (GCredentials *c
|
||||
g_return_val_if_fail (G_IS_CREDENTIALS (credentials), NULL);
|
||||
|
||||
ret = g_string_new ("GCredentials:");
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) || defined(__NetBSD__)
|
||||
g_string_append (ret, "linux-ucred:");
|
||||
if (credentials->native.pid != -1)
|
||||
g_string_append_printf (ret, "pid=%" G_GINT64_FORMAT ",", (gint64) credentials->native.pid);
|
||||
@@ -233,7 +242,7 @@ g_credentials_is_same_user (GCredentials
|
||||
g_return_val_if_fail (error == NULL || *error == NULL, FALSE);
|
||||
|
||||
ret = FALSE;
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) || defined(__NetBSD__)
|
||||
if (credentials->native.uid == other_credentials->native.uid)
|
||||
ret = TRUE;
|
||||
#elif defined(__FreeBSD__)
|
||||
@@ -278,7 +287,7 @@ g_credentials_get_native (GCredentials
|
||||
|
||||
ret = NULL;
|
||||
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) || defined(__NetBSD__)
|
||||
if (native_type != G_CREDENTIALS_TYPE_LINUX_UCRED)
|
||||
{
|
||||
g_warning ("g_credentials_get_native: Trying to get credentials of type %d but only "
|
||||
@@ -328,7 +337,7 @@ g_credentials_set_native (GCredentials
|
||||
GCredentialsType native_type,
|
||||
gpointer native)
|
||||
{
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) || defined(__NetBSD__)
|
||||
if (native_type != G_CREDENTIALS_TYPE_LINUX_UCRED)
|
||||
{
|
||||
g_warning ("g_credentials_set_native: Trying to set credentials of type %d "
|
||||
@@ -337,7 +346,7 @@ g_credentials_set_native (GCredentials
|
||||
}
|
||||
else
|
||||
{
|
||||
- memcpy (&credentials->native, native, sizeof (struct ucred));
|
||||
+ memcpy (&credentials->native, native, sizeof (credentials->native));
|
||||
}
|
||||
#elif defined(__FreeBSD__)
|
||||
if (native_type != G_CREDENTIALS_TYPE_FREEBSD_CMSGCRED)
|
||||
@@ -384,7 +393,7 @@ g_credentials_get_unix_user (GCredential
|
||||
g_return_val_if_fail (G_IS_CREDENTIALS (credentials), -1);
|
||||
g_return_val_if_fail (error == NULL || *error == NULL, -1);
|
||||
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) || defined(__NetBSD__)
|
||||
ret = credentials->native.uid;
|
||||
#elif defined(__FreeBSD__)
|
||||
ret = credentials->native.cmcred_euid;
|
||||
@@ -428,7 +437,7 @@ g_credentials_set_unix_user (GCredential
|
||||
g_return_val_if_fail (error == NULL || *error == NULL, FALSE);
|
||||
|
||||
ret = FALSE;
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) || defined(__NetBSD__)
|
||||
credentials->native.uid = uid;
|
||||
ret = TRUE;
|
||||
#elif defined(__FreeBSD__)
|
50
devel/glib2/patches/patch-aq
Normal file
50
devel/glib2/patches/patch-aq
Normal file
|
@ -0,0 +1,50 @@
|
|||
$NetBSD: patch-aq,v 1.1 2011/03/09 11:22:04 drochner Exp $
|
||||
|
||||
--- gio/gsocket.c.orig 2011-02-11 15:23:12.000000000 +0000
|
||||
+++ gio/gsocket.c
|
||||
@@ -33,6 +33,9 @@
|
||||
#include <signal.h>
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
+#ifdef __NetBSD__
|
||||
+#include <sys/un.h>
|
||||
+#endif
|
||||
|
||||
#ifndef G_OS_WIN32
|
||||
# include <fcntl.h>
|
||||
@@ -3540,6 +3543,35 @@ g_socket_get_credentials (GSocket *soc
|
||||
&native_creds);
|
||||
}
|
||||
}
|
||||
+#elif defined(__NetBSD__)
|
||||
+ {
|
||||
+ struct unpcbid cred;
|
||||
+ socklen_t len = sizeof(cred);
|
||||
+ if (getsockopt(socket->priv->fd, 0, LOCAL_PEEREID, &cred, &len) < 0)
|
||||
+ {
|
||||
+ int errsv = get_socket_errno ();
|
||||
+ g_set_error (error,
|
||||
+ G_IO_ERROR,
|
||||
+ socket_io_error_from_errno (errsv),
|
||||
+ _("Unable to get pending error: %s"),
|
||||
+ socket_strerror (errsv));
|
||||
+ }
|
||||
+ else
|
||||
+ {
|
||||
+ struct {
|
||||
+ pid_t pid;
|
||||
+ uid_t uid;
|
||||
+ gid_t gid;
|
||||
+ } native_creds;
|
||||
+ native_creds.uid = cred.unp_euid;
|
||||
+ native_creds.gid = cred.unp_egid;
|
||||
+ native_creds.pid = cred.unp_pid;
|
||||
+ ret = g_credentials_new ();
|
||||
+ g_credentials_set_native (ret,
|
||||
+ G_CREDENTIALS_TYPE_LINUX_UCRED,
|
||||
+ &native_creds);
|
||||
+ }
|
||||
+ }
|
||||
#else
|
||||
g_set_error_literal (error,
|
||||
G_IO_ERROR,
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-cj,v 1.2 2011/02/03 15:12:45 wiz Exp $
|
||||
$NetBSD: patch-cj,v 1.3 2011/03/09 11:22:04 drochner Exp $
|
||||
|
||||
The mem-overflow test contains a declaration of an empty struct, which breaks
|
||||
on at least SunPro cc, and presumably some other non-gcc compilers. Skip this
|
||||
test for now, pending a better fix.
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=641350
|
||||
|
||||
--- glib/tests/Makefile.in.orig Sun Nov 14 01:02:00 2010
|
||||
+++ glib/tests/Makefile.in Tue Feb 1 12:25:15 2011
|
||||
@@ -59,7 +59,7 @@
|
||||
--- glib/tests/Makefile.in.orig 2011-02-08 17:40:51.000000000 +0000
|
||||
+++ glib/tests/Makefile.in
|
||||
@@ -59,7 +59,7 @@ am__EXEEXT_1 = testing$(EXEEXT) option-c
|
||||
string$(EXEEXT) markup-parse$(EXEEXT) markup-collect$(EXEEXT) \
|
||||
markup-escape$(EXEEXT) markup-subparser$(EXEEXT) \
|
||||
array-test$(EXEEXT) hostutils$(EXEEXT) gvariant$(EXEEXT) \
|
||||
|
@ -16,7 +16,7 @@ https://bugzilla.gnome.org/show_bug.cgi?id=641350
|
|||
base64$(EXEEXT) sequence$(EXEEXT) scannerapi$(EXEEXT) \
|
||||
shell$(EXEEXT) collate$(EXEEXT) utf8-pointer$(EXEEXT) \
|
||||
utf8-validate$(EXEEXT) utf8-misc$(EXEEXT) checksum$(EXEEXT) \
|
||||
@@ -134,8 +134,6 @@
|
||||
@@ -138,8 +138,6 @@ markup_parse_DEPENDENCIES = $(progs_ldad
|
||||
markup_subparser_SOURCES = markup-subparser.c
|
||||
markup_subparser_OBJECTS = markup-subparser.$(OBJEXT)
|
||||
markup_subparser_DEPENDENCIES = $(progs_ldadd)
|
||||
|
@ -25,26 +25,26 @@ https://bugzilla.gnome.org/show_bug.cgi?id=641350
|
|||
mem_overflow_DEPENDENCIES = $(progs_ldadd)
|
||||
node_SOURCES = node.c
|
||||
node_OBJECTS = node.$(OBJEXT)
|
||||
@@ -231,7 +229,7 @@
|
||||
$(gdatetime_SOURCES) gvariant.c hash.c hostutils.c \
|
||||
$(keyfile_SOURCES) list.c logging.c markup-collect.c \
|
||||
markup-escape.c markup-parse.c markup-subparser.c \
|
||||
- mem-overflow.c node.c $(option_context_SOURCES) pattern.c \
|
||||
+ node.c $(option_context_SOURCES) pattern.c \
|
||||
$(printf_SOURCES) $(protocol_SOURCES) queue.c $(rand_SOURCES) \
|
||||
regex.c scannerapi.c sequence.c shell.c slist.c \
|
||||
$(strfuncs_SOURCES) $(string_SOURCES) $(testing_SOURCES) \
|
||||
@@ -242,7 +240,7 @@
|
||||
$(gdatetime_SOURCES) gvariant.c hash.c hostutils.c \
|
||||
$(keyfile_SOURCES) list.c logging.c markup-collect.c \
|
||||
markup-escape.c markup-parse.c markup-subparser.c \
|
||||
- mem-overflow.c node.c $(option_context_SOURCES) pattern.c \
|
||||
+ node.c $(option_context_SOURCES) pattern.c \
|
||||
$(printf_SOURCES) $(protocol_SOURCES) queue.c $(rand_SOURCES) \
|
||||
regex.c scannerapi.c sequence.c shell.c slist.c \
|
||||
$(strfuncs_SOURCES) $(string_SOURCES) $(testing_SOURCES) \
|
||||
@@ -489,7 +487,7 @@
|
||||
EXTRA_DIST = 4096-random-bytes keyfiletest.ini bookmarks.xbel
|
||||
@@ -235,7 +233,7 @@ SOURCES = array-test.c base64.c bookmark
|
||||
$(fileutils_SOURCES) $(gdatetime_SOURCES) gvariant.c hash.c \
|
||||
hostutils.c $(keyfile_SOURCES) list.c logging.c \
|
||||
markup-collect.c markup-escape.c markup-parse.c \
|
||||
- markup-subparser.c mem-overflow.c node.c \
|
||||
+ markup-subparser.c node.c \
|
||||
$(option_context_SOURCES) pattern.c $(printf_SOURCES) \
|
||||
$(protocol_SOURCES) queue.c $(rand_SOURCES) regex.c \
|
||||
scannerapi.c sequence.c shell.c slist.c $(strfuncs_SOURCES) \
|
||||
@@ -246,7 +244,7 @@ DIST_SOURCES = array-test.c base64.c boo
|
||||
$(fileutils_SOURCES) $(gdatetime_SOURCES) gvariant.c hash.c \
|
||||
hostutils.c $(keyfile_SOURCES) list.c logging.c \
|
||||
markup-collect.c markup-escape.c markup-parse.c \
|
||||
- markup-subparser.c mem-overflow.c node.c \
|
||||
+ markup-subparser.c node.c \
|
||||
$(option_context_SOURCES) pattern.c $(printf_SOURCES) \
|
||||
$(protocol_SOURCES) queue.c $(rand_SOURCES) regex.c \
|
||||
scannerapi.c sequence.c shell.c slist.c $(strfuncs_SOURCES) \
|
||||
@@ -497,7 +495,7 @@ EXTRA_DIST = 4096-random-bytes keyfilete
|
||||
bookmarks.xbel
|
||||
TEST_PROGS = testing option-context keyfile fileutils printf protocol \
|
||||
rand strfuncs string markup-parse markup-collect markup-escape \
|
||||
- markup-subparser array-test hostutils gvariant mem-overflow \
|
||||
|
@ -52,7 +52,7 @@ https://bugzilla.gnome.org/show_bug.cgi?id=641350
|
|||
utils regex base64 sequence scannerapi shell collate \
|
||||
utf8-pointer utf8-validate utf8-misc checksum hash date node \
|
||||
convert list slist queue tree uri dir pattern logging error \
|
||||
@@ -666,9 +664,6 @@
|
||||
@@ -678,9 +676,6 @@ markup-parse$(EXEEXT): $(markup_parse_OB
|
||||
markup-subparser$(EXEEXT): $(markup_subparser_OBJECTS) $(markup_subparser_DEPENDENCIES)
|
||||
@rm -f markup-subparser$(EXEEXT)
|
||||
$(AM_V_CCLD)$(LINK) $(markup_subparser_OBJECTS) $(markup_subparser_LDADD) $(LIBS)
|
||||
|
@ -62,7 +62,7 @@ https://bugzilla.gnome.org/show_bug.cgi?id=641350
|
|||
node$(EXEEXT): $(node_OBJECTS) $(node_DEPENDENCIES)
|
||||
@rm -f node$(EXEEXT)
|
||||
$(AM_V_CCLD)$(LINK) $(node_OBJECTS) $(node_LDADD) $(LIBS)
|
||||
@@ -760,7 +755,6 @@
|
||||
@@ -773,7 +768,6 @@ distclean-compile:
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/markup-escape.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/markup-parse.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/markup-subparser.Po@am__quote@
|
||||
|
|
Loading…
Reference in a new issue