audio/id3ren: import id3ren-0.0.20130521

id3ren is used to rename batches of mp3 files by reading the ID3 tag
at the end of the file which contains the song name, artist, album, year,
and a comment.

The secondary function of id3ren is a tagger, which can create, modify,
or remove ID3 tags. The id3 fields can be set on the command line,
entered interactively, or "guessed" from the path and the filename.
This commit is contained in:
jmcneill 2020-08-30 10:41:01 +00:00
parent 2ee7f6d5e7
commit adbed4ec8d
6 changed files with 73 additions and 0 deletions

7
audio/id3ren/DESCR Normal file
View file

@ -0,0 +1,7 @@
id3ren is used to rename batches of mp3 files by reading the ID3 tag
at the end of the file which contains the song name, artist, album, year,
and a comment.
The secondary function of id3ren is a tagger, which can create, modify,
or remove ID3 tags. The id3 fields can be set on the command line,
entered interactively, or "guessed" from the path and the filename.

27
audio/id3ren/Makefile Normal file
View file

@ -0,0 +1,27 @@
# $NetBSD: Makefile,v 1.1 2020/08/30 10:41:01 jmcneill Exp $
GITHUB_PROJECT= id3ren
GITHUB_TAG= b061aba2bfa25bcde732776262cc2a19d66b416a
DISTNAME= b061aba2bfa25bcde732776262cc2a19d66b416a
PKGNAME= ${GITHUB_PROJECT}-0.0.20130521
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_GITHUB:=sebcode/}
DIST_SUBDIR= ${GITHUB_PROJECT}
EXTRACT_SUFX= .zip
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/sebcode/id3ren/
COMMENT= Rename batches of mp3 files using ID3 tags
LICENSE= gnu-gpl-v2
WRKSRC= ${WRKDIR}/id3ren-${GITHUB_TAG}
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/id3ren \
${DESTDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/id3ren.1 \
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/id3ren.1
.include "../../mk/bsd.pkg.mk"

3
audio/id3ren/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2020/08/30 10:41:01 jmcneill Exp $
bin/id3ren
man/man1/id3ren.1

8
audio/id3ren/distinfo Normal file
View file

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1 2020/08/30 10:41:01 jmcneill Exp $
SHA1 (id3ren/b061aba2bfa25bcde732776262cc2a19d66b416a-b061aba2bfa25bcde732776262cc2a19d66b416a.zip) = 174699ade0936480c12170485f98a0f83b34a717
RMD160 (id3ren/b061aba2bfa25bcde732776262cc2a19d66b416a-b061aba2bfa25bcde732776262cc2a19d66b416a.zip) = 9b1949739e1f983f25e2188b5411739d851e2052
SHA512 (id3ren/b061aba2bfa25bcde732776262cc2a19d66b416a-b061aba2bfa25bcde732776262cc2a19d66b416a.zip) = eca70a4b1eadc03482d73f8a71d59d7eb61404ae8d426b0aaa3654f0223d80559bb16502251574fe76aa1b1ac1fa709d079b8a3606395ac236dcf9b6c6b20b21
Size (id3ren/b061aba2bfa25bcde732776262cc2a19d66b416a-b061aba2bfa25bcde732776262cc2a19d66b416a.zip) = 44763 bytes
SHA1 (patch-src_Makefile) = 1861f10574f1fb7d53972ae0689861f3884d69a4
SHA1 (patch-src_id3ren.c) = 6ccc73cef01980e274363df9305cfd0952e972e4

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_Makefile,v 1.1 2020/08/30 10:41:01 jmcneill Exp $
Use PKG_SYSCONFDIR instead of hard-coding /etc.
--- src/Makefile.orig 2013-05-21 13:56:15.000000000 +0000
+++ src/Makefile
@@ -1,5 +1,5 @@
CFLAGSDEBUG = -g -O2 -Wall -DDEBUG
-CFLAGS = -s -O2 -Wall
+CFLAGS = -s -O2 -Wall -DPKG_SYSCONFDIR=\"$(PKG_SYSCONFDIR)\"
CC = gcc
RM = rm -f
INSTALL = install -D -s -m 755

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_id3ren.c,v 1.1 2020/08/30 10:41:01 jmcneill Exp $
Use PKG_SYSCONFDIR instead of hard-coding /etc.
--- src/id3ren.c.orig 2013-05-21 13:56:15.000000000 +0000
+++ src/id3ren.c
@@ -794,7 +794,7 @@ check_args (int argc, char *argv[])
#ifdef __WIN32__
read_config(program_path, CONFIG_GLOBAL);
#else
- read_config("/etc", CONFIG_GLOBAL);
+ read_config(PKG_SYSCONFDIR, CONFIG_GLOBAL);
#endif
}