Updating textproc/p5-Text-BibTeX from 0.38 to 0.40
pkgsrc changes: - Add license definition - Adjust dependencies - Add module type Upstream changes: Release 0.40 - 7 March, 2010 ---------------------------- * this release is very similar to 0.40_3, but now indexable by cpan. Release 0.40_3 - 18 February, 2010 ---------------------------------- * fixed Build.PL with correct build_requirements; * fixed test to use still not installed library; Release 0.40_2 - 15 February, 2010 ---------------------------------- * merged btparse library into Text::BibTeX code. I am sorry for all other languages that might be using this library. For them my suggestion is that they make Text::BibTeX as a dependency. * ported compilation and configuration tools from ExtUtils::MakeMaker to Module::Build. * back on track, trying to make Text::BibTeX work and compile easily on main platforms (sorry, for main platforms I assume Linux, Mac OS X and Windows running Strawberry Perl). * Thanks to Philip Kime for continuous poke so I work on this!! Created a THANKS file for this purpose.
This commit is contained in:
parent
c56693ca7e
commit
adc22db862
3 changed files with 89 additions and 6 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.17 2008/11/22 00:07:12 he Exp $
|
||||
# $NetBSD: Makefile,v 1.18 2010/03/09 21:54:01 sno Exp $
|
||||
|
||||
DISTNAME= Text-BibTeX-0.38
|
||||
DISTNAME= Text-BibTeX-0.40
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
SVR4_PKGNAME= p5tbt
|
||||
CATEGORIES= textproc perl5
|
||||
|
@ -12,10 +12,23 @@ MAINTAINER= pkgsrc-users@NetBSD.org
|
|||
HOMEPAGE= http://www.gerg.ca/software/btOOL/
|
||||
#HOMEPAGE= http://search.cpan.org/dist/Text-BibTeX/
|
||||
COMMENT= Perl library for reading, parsing, and processing BibTeX files
|
||||
LICENSE= ${PERL5_LICENSE}
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
BUILD_DEPENDS+= p5-Capture-Tiny>=0.06:../../devel/p5-Capture-Tiny
|
||||
BUILD_DEPENDS+= p5-Config-AutoConf>=0.14:../../devel/p5-Config-AutoConf
|
||||
BUILD_DEPENDS+= p5-ExtUtils-CBuilder>=0.27:../../devel/p5-ExtUtils-CBuilder
|
||||
BUILD_DEPENDS+= p5-Module-Build>=0.36030:../../devel/p5-Module-Build
|
||||
|
||||
USE_LANGUAGES+= c
|
||||
PERL5_PACKLIST= auto/Text/BibTeX/.packlist
|
||||
PERL5_MODULE_TYPE= Module::Build
|
||||
|
||||
ALL_ENV+= TMPDIR=${WRKDIR}/tmp
|
||||
|
||||
pre-configure:
|
||||
${MKDIR} ${WRKDIR}/tmp
|
||||
|
||||
.include "../../lang/perl5/module.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.5 2008/11/22 00:06:30 he Exp $
|
||||
$NetBSD: distinfo,v 1.6 2010/03/09 21:54:01 sno Exp $
|
||||
|
||||
SHA1 (Text-BibTeX-0.38.tar.gz) = b324e6a37c107d31ab8d930f29c95e7470378ca0
|
||||
RMD160 (Text-BibTeX-0.38.tar.gz) = 9b6c53840cce22a4fc5ac17c6fffecbfe8509096
|
||||
Size (Text-BibTeX-0.38.tar.gz) = 85432 bytes
|
||||
SHA1 (Text-BibTeX-0.40.tar.gz) = 4b65b761cd5a7ed404f48aad292f6a6a4da37701
|
||||
RMD160 (Text-BibTeX-0.40.tar.gz) = f9a8e7fe676c3fa835308ed269ddb020ae86f85a
|
||||
Size (Text-BibTeX-0.40.tar.gz) = 265444 bytes
|
||||
SHA1 (btparse-0.35.tar.gz) = bb52c5fc02c1326008bed31a3c8932dd832b8ea8
|
||||
RMD160 (btparse-0.35.tar.gz) = afdf8cc2abd0beaa53b142d7277758a32e26d256
|
||||
Size (btparse-0.35.tar.gz) = 470546 bytes
|
||||
SHA1 (patch-aa) = 33ca774fe490a9c6e809ac17202badf9843e8aaf
|
||||
|
|
69
textproc/p5-Text-BibTeX/patches/patch-aa
Normal file
69
textproc/p5-Text-BibTeX/patches/patch-aa
Normal file
|
@ -0,0 +1,69 @@
|
|||
$NetBSD: patch-aa,v 1.3 2010/03/09 21:54:01 sno Exp $
|
||||
|
||||
--- inc/MyBuilder.pm.orig 2010-03-07 18:53:31.000000000 +0000
|
||||
+++ inc/MyBuilder.pm
|
||||
@@ -75,9 +75,10 @@ sub ACTION_compile_xscode {
|
||||
# .o => .(a|bundle)
|
||||
my $lib_file = catfile( $archdir, "BibTeX.$Config{dlext}" );
|
||||
if ( !$self->up_to_date( [ @$objects ], $lib_file ) ) {
|
||||
+ my $btparselibdir = $self->install_path('usrlib');
|
||||
$cbuilder->link(
|
||||
module_name => 'Text::BibTeX',
|
||||
- extra_linker_flags => '-Lbtparse/src -lbtparse ',
|
||||
+ extra_linker_flags => "-Lbtparse/src -Wl,-R${btparselibdir} -lbtparse ",
|
||||
objects => $objects,
|
||||
lib_file => $lib_file,
|
||||
);
|
||||
@@ -142,24 +143,25 @@ sub ACTION_create_binaries {
|
||||
|
||||
print STDERR "\n** Creating binaries (dumpnames$EXEEXT, biblex$EXEEXT, bibparse$EXEEXT)\n";
|
||||
|
||||
+ my $btparselibdir = $self->install_path('usrlib');
|
||||
# NO INST?
|
||||
## FIXME - uptodate
|
||||
$CCL->($cbuilder,
|
||||
exe_file => "btparse/progs/dumpnames$EXEEXT",
|
||||
- extra_linker_flags => '-Lbtparse/src -lbtparse ',
|
||||
+ extra_linker_flags => "-Lbtparse/src -Wl,-R${btparselibdir} -lbtparse ",
|
||||
objects => [ "btparse/progs/dumpnames.o" ]);
|
||||
|
||||
# NO INST?
|
||||
## FIXME - uptodate
|
||||
$CCL->($cbuilder,
|
||||
exe_file => "btparse/progs/biblex$EXEEXT",
|
||||
- extra_linker_flags => '-Lbtparse/src -lbtparse ',
|
||||
+ extra_linker_flags => "-Lbtparse/src -Wl,-R${btparselibdir} -lbtparse ",
|
||||
objects => [ "btparse/progs/biblex.o" ]);
|
||||
|
||||
## FIXME - uptodate
|
||||
$CCL->($cbuilder,
|
||||
exe_file => "btparse/progs/bibparse$EXEEXT",
|
||||
- extra_linker_flags => '-Lbtparse/src -lbtparse ',
|
||||
+ extra_linker_flags => "-Lbtparse/src -Wl,-R${btparselibdir} -lbtparse ",
|
||||
objects => [ map {"btparse/progs/$_.o"} (qw.bibparse args getopt getopt1.) ]);
|
||||
|
||||
$self->copy_if_modified( from => "btparse/progs/dumpnames$EXEEXT",
|
||||
@@ -187,7 +189,7 @@ sub ACTION_create_tests {
|
||||
## FIXME - uptodate
|
||||
$CCL->($cbuilder,
|
||||
exe_file => "btparse/tests/simple_test$EXEEXT",
|
||||
- extra_linker_flags => '-Lbtparse/src -lbtparse ',
|
||||
+ extra_linker_flags => "-Lbtparse/src -Wl,-Rbtparse/src -lbtparse ",
|
||||
objects => [ map "btparse/tests/$_.o", (qw.simple_test testlib.) ]);
|
||||
|
||||
## FIXME - uptodate
|
||||
@@ -264,9 +266,13 @@ sub ACTION_test {
|
||||
if ($^O =~ /darwin/i) {
|
||||
$ENV{DYLD_LIBRARY_PATH} = catdir($self->blib,"usrlib").":$ENV{DYLD_LIBRARY_PATH}";
|
||||
}
|
||||
- if ($^O =~ /linux/i) {
|
||||
+ if ($^O =~ /(?:linux|bsd|sun|sol|dragonfly|hpux|irix)/i) {
|
||||
$ENV{LD_LIBRARY_PATH} = catdir($self->blib,"usrlib").":$ENV{LD_LIBRARY_PATH}";
|
||||
}
|
||||
+ if ($^O =~ /aix/i) {
|
||||
+ my $oldlibpath = $ENV{LIBPATH} || '/lib:/usr/lib';
|
||||
+ $ENV{LIBPATH} = catdir($self->blib,"usrlib").":$oldlibpath";
|
||||
+ }
|
||||
|
||||
$self->SUPER::ACTION_test
|
||||
}
|
Loading…
Reference in a new issue