Make dsniff and dsniff-nox11 build on NetBSD-current:

* In dsniff-nox11/Makefile, add a post-configure target to move
  missing/sys/queue.h out of the way if the configure script
  found a real sys/queue.h.
* Add patches to #include <string.h> in some files where I noticed warnings.

Bump PKGREVISION for both dsniff and dsniff-nox11.
This commit is contained in:
apb 2008-10-01 08:43:09 +00:00
parent eb887bd02b
commit add6a683f6
5 changed files with 34 additions and 8 deletions

View file

@ -1,13 +1,18 @@
# $NetBSD: Makefile,v 1.4 2008/01/28 00:45:27 rillig Exp $
# $NetBSD: Makefile,v 1.5 2008/10/01 08:43:09 apb Exp $
.include "../../security/dsniff/Makefile.common"
PKGNAME= dsniff-nox11-${VERS}
PKGREVISION= 1
PKGREVISION= 2
COMMENT= Password sniffer
CONFIGURE_ARGS+= --without-x
post-configure:
( cd ${WRKSRC} \
&& grep '#define.*HAVE_SYS_QUEUE_H' config.h >/dev/null \
&& mv missing/sys/queue.h missing/sys/queue.h.fake )
post-install:
${RM} ${PREFIX}/${PKGMANDIR}/man8/webspy.8

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.29 2007/01/30 20:47:58 joerg Exp $
# $NetBSD: Makefile,v 1.30 2008/10/01 08:43:09 apb Exp $
.include "Makefile.common"
PKGREVISION= 5
PKGREVISION= 6
COMMENT= Password sniffer (webspy)
DEPENDS+= dsniff-nox11-[0-9]*:../../security/dsniff-nox11

View file

@ -1,9 +1,10 @@
$NetBSD: distinfo,v 1.7 2007/02/18 18:56:13 adrianp Exp $
$NetBSD: distinfo,v 1.8 2008/10/01 08:43:09 apb Exp $
SHA1 (dsniff-2.3.tar.gz) = 671a1df823ab0657fc95e79112924a57281e9c3b
RMD160 (dsniff-2.3.tar.gz) = 89dad0259e90acef30a7aa5f3471de3aaeb06147
Size (dsniff-2.3.tar.gz) = 126797 bytes
SHA1 (patch-aa) = b50347c772c13abd6b62a80315c7bfecc139ba60
SHA1 (patch-ab) = 6385da7139dcb11ea29ffba468e7fac260b61b44
SHA1 (patch-ac) = 55ad4f73e53578857bc5ad7a445c8e6125c39215
SHA1 (patch-ac) = da25b9c7d6c06a18308ae8739bc5483341121dee
SHA1 (patch-ad) = cab09e1b1a61fd6a3fa96c24fff3cd1519146a3e
SHA1 (patch-ae) = e54a7be65c2e1d236b2427d216e1184ff6046a0b

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ac,v 1.1 2006/05/11 15:39:20 joerg Exp $
$NetBSD: patch-ac,v 1.2 2008/10/01 08:43:09 apb Exp $
--- arp.c.orig 2000-11-14 15:51:03.000000000 +0000
--- arp.c.orig 2000-11-14 17:51:03.000000000 +0200
+++ arp.c
@@ -17,7 +17,7 @@
#include <sys/sysctl.h>
@ -11,3 +11,11 @@ $NetBSD: patch-ac,v 1.1 2006/05/11 15:39:20 joerg Exp $
#define ether_addr_octet octet
#endif
#else /* !BSD */
@@ -32,6 +32,7 @@
#include <netinet/if_ether.h>
#include <stdio.h>
#include <stdlib.h>
+#include <string.h>
#include <unistd.h>
#ifdef BSD

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ae,v 1.1 2008/10/01 08:43:09 apb Exp $
--- buf.c.orig 2000-11-28 09:45:07.000000000 +0200
+++ buf.c
@@ -13,6 +13,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <stdarg.h>
+#include <string.h>
#include <unistd.h>
#include <ctype.h>
#include <err.h>