Update to 0.2.0: changes undocumented, but probably related
to libwpd-0.9.0 update.
This commit is contained in:
parent
0aa1d11a6a
commit
add7766273
4 changed files with 185 additions and 17 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.2 2010/11/25 10:28:34 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2010/11/25 10:52:19 wiz Exp $
|
||||
|
||||
DISTNAME= libwps-0.1.2
|
||||
PKGREVISION= 1
|
||||
DISTNAME= libwps-0.2.0
|
||||
CATEGORIES= converters
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=libwps/}
|
||||
|
||||
|
@ -17,7 +16,7 @@ USE_LIBTOOL= yes
|
|||
USE_TOOLS+= pkg-config
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --without-docs
|
||||
PKGCONFIG_OVERRIDE+= libwps-0.1.pc.in libwps-stream-0.1.pc.in
|
||||
PKGCONFIG_OVERRIDE+= libwps-0.2.pc.in
|
||||
|
||||
.include "../../converters/libwpd/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,12 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2010/10/16 15:26:08 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2010/11/25 10:52:19 wiz Exp $
|
||||
bin/wps2html
|
||||
bin/wps2raw
|
||||
bin/wps2text
|
||||
include/libwps-0.1/libwps/WPSDocument.h
|
||||
include/libwps-0.1/libwps/WPSStream.h
|
||||
include/libwps-0.1/libwps/WPSStreamImplementation.h
|
||||
include/libwps-0.1/libwps/libwps.h
|
||||
lib/libwps-0.1.la
|
||||
lib/libwps-stream-0.1.la
|
||||
lib/pkgconfig/libwps-0.1.pc
|
||||
lib/pkgconfig/libwps-stream-0.1.pc
|
||||
include/libwps-0.2/libwps/WPSDocument.h
|
||||
include/libwps-0.2/libwps/libwps.h
|
||||
lib/libwps-0.2.la
|
||||
lib/pkgconfig/libwps-0.2.pc
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2010/10/16 15:26:08 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.2 2010/11/25 10:52:19 wiz Exp $
|
||||
|
||||
SHA1 (libwps-0.1.2.tar.gz) = 3da402f74a6296425e88d0ab1cf197a5927288d6
|
||||
RMD160 (libwps-0.1.2.tar.gz) = a3f60fed70ab0c4f34091c10f4eb4a421cb87d44
|
||||
Size (libwps-0.1.2.tar.gz) = 413360 bytes
|
||||
SHA1 (libwps-0.2.0.tar.gz) = d7606be3832a0c45e0f2f4338449ab52d22c5930
|
||||
RMD160 (libwps-0.2.0.tar.gz) = c1d5b4bef52139d922335c4d5e843d2945ecbd03
|
||||
Size (libwps-0.2.0.tar.gz) = 402804 bytes
|
||||
SHA1 (patch-aa) = 5dd49b6bcb8c147409aa7192f365e9ab0a459ffb
|
||||
|
|
172
converters/libwps/patches/patch-aa
Normal file
172
converters/libwps/patches/patch-aa
Normal file
|
@ -0,0 +1,172 @@
|
|||
$NetBSD: patch-aa,v 1.1 2010/11/25 10:52:19 wiz Exp $
|
||||
|
||||
_U is defined in a NetBSD internal header.
|
||||
|
||||
--- src/conv/raw/RawListener.cpp.orig 2010-11-09 08:36:50.000000000 +0000
|
||||
+++ src/conv/raw/RawListener.cpp
|
||||
@@ -28,7 +28,7 @@
|
||||
#include <stdarg.h>
|
||||
#include "RawListener.h"
|
||||
|
||||
-#define _U(M, L) \
|
||||
+#define _RLU(M, L) \
|
||||
if (!m_printCallgraphScore) \
|
||||
__iuprintf M; \
|
||||
else \
|
||||
@@ -148,7 +148,7 @@ void RawListenerImpl::setDocumentMetaDat
|
||||
|
||||
void RawListenerImpl::startDocument()
|
||||
{
|
||||
- _U(("startDocument()\n"), LC_START_DOCUMENT);
|
||||
+ _RLU(("startDocument()\n"), LC_START_DOCUMENT);
|
||||
}
|
||||
|
||||
void RawListenerImpl::endDocument()
|
||||
@@ -163,7 +163,7 @@ void RawListenerImpl::definePageStyle(co
|
||||
|
||||
void RawListenerImpl::openPageSpan(const WPXPropertyList &propList)
|
||||
{
|
||||
- _U(("openPageSpan(%s)\n", getPropString(propList).cstr()),
|
||||
+ _RLU(("openPageSpan(%s)\n", getPropString(propList).cstr()),
|
||||
LC_OPEN_PAGE_SPAN);
|
||||
}
|
||||
|
||||
@@ -175,7 +175,7 @@ void RawListenerImpl::closePageSpan()
|
||||
|
||||
void RawListenerImpl::openHeader(const WPXPropertyList &propList)
|
||||
{
|
||||
- _U(("openHeader(%s)\n",
|
||||
+ _RLU(("openHeader(%s)\n",
|
||||
getPropString(propList).cstr()),
|
||||
LC_OPEN_HEADER_FOOTER);
|
||||
}
|
||||
@@ -188,7 +188,7 @@ void RawListenerImpl::closeHeader()
|
||||
|
||||
void RawListenerImpl::openFooter(const WPXPropertyList &propList)
|
||||
{
|
||||
- _U(("openFooter(%s)\n",
|
||||
+ _RLU(("openFooter(%s)\n",
|
||||
getPropString(propList).cstr()),
|
||||
LC_OPEN_HEADER_FOOTER);
|
||||
}
|
||||
@@ -206,7 +206,7 @@ void RawListenerImpl::defineParagraphSty
|
||||
|
||||
void RawListenerImpl::openParagraph(const WPXPropertyList &propList, const WPXPropertyListVector &tabStops)
|
||||
{
|
||||
- _U(("openParagraph(%s, tab-stops: %s)\n", getPropString(propList).cstr(), getPropString(tabStops).cstr()),
|
||||
+ _RLU(("openParagraph(%s, tab-stops: %s)\n", getPropString(propList).cstr(), getPropString(tabStops).cstr()),
|
||||
LC_OPEN_PARAGRAPH);
|
||||
}
|
||||
|
||||
@@ -222,7 +222,7 @@ void RawListenerImpl::defineCharacterSty
|
||||
|
||||
void RawListenerImpl::openSpan(const WPXPropertyList &propList)
|
||||
{
|
||||
- _U(("openSpan(%s)\n", getPropString(propList).cstr()), LC_OPEN_SPAN);
|
||||
+ _RLU(("openSpan(%s)\n", getPropString(propList).cstr()), LC_OPEN_SPAN);
|
||||
}
|
||||
|
||||
void RawListenerImpl::closeSpan()
|
||||
@@ -237,7 +237,7 @@ void RawListenerImpl::defineSectionStyle
|
||||
|
||||
void RawListenerImpl::openSection(const WPXPropertyList &propList, const WPXPropertyListVector &columns)
|
||||
{
|
||||
- _U(("openSection(%s, columns: %s)\n", getPropString(propList).cstr(), getPropString(columns).cstr()), LC_OPEN_SECTION);
|
||||
+ _RLU(("openSection(%s, columns: %s)\n", getPropString(propList).cstr(), getPropString(columns).cstr()), LC_OPEN_SECTION);
|
||||
}
|
||||
|
||||
void RawListenerImpl::closeSection()
|
||||
@@ -283,13 +283,13 @@ void RawListenerImpl::defineUnorderedLis
|
||||
|
||||
void RawListenerImpl::openOrderedListLevel(const WPXPropertyList &propList)
|
||||
{
|
||||
- _U(("openOrderedListLevel(%s)\n", getPropString(propList).cstr()),
|
||||
+ _RLU(("openOrderedListLevel(%s)\n", getPropString(propList).cstr()),
|
||||
LC_OPEN_ORDERED_LIST_LEVEL);
|
||||
}
|
||||
|
||||
void RawListenerImpl::openUnorderedListLevel(const WPXPropertyList &propList)
|
||||
{
|
||||
- _U(("openUnorderedListLevel(%s)\n", getPropString(propList).cstr()),
|
||||
+ _RLU(("openUnorderedListLevel(%s)\n", getPropString(propList).cstr()),
|
||||
LC_OPEN_UNORDERED_LIST_LEVEL);
|
||||
}
|
||||
|
||||
@@ -306,7 +306,7 @@ void RawListenerImpl::closeUnorderedList
|
||||
|
||||
void RawListenerImpl::openListElement(const WPXPropertyList &propList, const WPXPropertyListVector &tabStops)
|
||||
{
|
||||
- _U(("openListElement(%s, tab-stops: %s)\n", getPropString(propList).cstr(), getPropString(tabStops).cstr()),
|
||||
+ _RLU(("openListElement(%s, tab-stops: %s)\n", getPropString(propList).cstr(), getPropString(tabStops).cstr()),
|
||||
LC_OPEN_LIST_ELEMENT);
|
||||
}
|
||||
|
||||
@@ -317,7 +317,7 @@ void RawListenerImpl::closeListElement()
|
||||
|
||||
void RawListenerImpl::openFootnote(const WPXPropertyList &propList)
|
||||
{
|
||||
- _U(("openFootnote(%s)\n", getPropString(propList).cstr()),
|
||||
+ _RLU(("openFootnote(%s)\n", getPropString(propList).cstr()),
|
||||
LC_OPEN_FOOTNOTE);
|
||||
}
|
||||
|
||||
@@ -328,7 +328,7 @@ void RawListenerImpl::closeFootnote()
|
||||
|
||||
void RawListenerImpl::openEndnote(const WPXPropertyList &propList)
|
||||
{
|
||||
- _U(("openEndnote(number: %s)\n", getPropString(propList).cstr()),
|
||||
+ _RLU(("openEndnote(number: %s)\n", getPropString(propList).cstr()),
|
||||
LC_OPEN_ENDNOTE);
|
||||
}
|
||||
|
||||
@@ -339,7 +339,7 @@ void RawListenerImpl::closeEndnote()
|
||||
|
||||
void RawListenerImpl::openComment(const WPXPropertyList &propList)
|
||||
{
|
||||
- _U(("openComment(%s)\n", getPropString(propList).cstr()),
|
||||
+ _RLU(("openComment(%s)\n", getPropString(propList).cstr()),
|
||||
LC_OPEN_COMMENT);
|
||||
}
|
||||
|
||||
@@ -350,7 +350,7 @@ void RawListenerImpl::closeComment()
|
||||
|
||||
void RawListenerImpl::openTextBox(const WPXPropertyList &propList)
|
||||
{
|
||||
- _U(("openTextBox(%s)\n", getPropString(propList).cstr()),
|
||||
+ _RLU(("openTextBox(%s)\n", getPropString(propList).cstr()),
|
||||
LC_OPEN_TEXT_BOX);
|
||||
}
|
||||
|
||||
@@ -361,12 +361,12 @@ void RawListenerImpl::closeTextBox()
|
||||
|
||||
void RawListenerImpl::openTable(const WPXPropertyList &propList, const WPXPropertyListVector &columns)
|
||||
{
|
||||
- _U(("openTable(%s, columns: %s)\n", getPropString(propList).cstr(), getPropString(columns).cstr()), LC_OPEN_TABLE);
|
||||
+ _RLU(("openTable(%s, columns: %s)\n", getPropString(propList).cstr(), getPropString(columns).cstr()), LC_OPEN_TABLE);
|
||||
}
|
||||
|
||||
void RawListenerImpl::openTableRow(const WPXPropertyList &propList)
|
||||
{
|
||||
- _U(("openTableRow(%s)\n", getPropString(propList).cstr()),
|
||||
+ _RLU(("openTableRow(%s)\n", getPropString(propList).cstr()),
|
||||
LC_OPEN_TABLE_ROW);
|
||||
}
|
||||
|
||||
@@ -377,7 +377,7 @@ void RawListenerImpl::closeTableRow()
|
||||
|
||||
void RawListenerImpl::openTableCell(const WPXPropertyList &propList)
|
||||
{
|
||||
- _U(("openTableCell(%s)\n", getPropString(propList).cstr()),
|
||||
+ _RLU(("openTableCell(%s)\n", getPropString(propList).cstr()),
|
||||
LC_OPEN_TABLE_CELL);
|
||||
}
|
||||
|
||||
@@ -398,7 +398,7 @@ void RawListenerImpl::closeTable()
|
||||
|
||||
void RawListenerImpl::openFrame(const WPXPropertyList &propList)
|
||||
{
|
||||
- _U(("openFrame(%s)\n", getPropString(propList).cstr()),
|
||||
+ _RLU(("openFrame(%s)\n", getPropString(propList).cstr()),
|
||||
LC_OPEN_FRAME);
|
||||
}
|
||||
|
Loading…
Reference in a new issue