Remove CVE-2007-3304 related patches. CVE-2007-3304 was fixed

in Apache 2.2.6 and these patches are noop.
This commit is contained in:
taca 2010-03-05 00:22:59 +00:00
parent 5cecb768bc
commit addf9135a9
4 changed files with 1 additions and 56 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.29 2009/12/26 04:51:01 obache Exp $
$NetBSD: distinfo,v 1.30 2010/03/05 00:22:59 taca Exp $
SHA1 (httpd-2.2.14.tar.bz2) = eacd04c87b489231ae708c84a77dc8e9ee176fd2
RMD160 (httpd-2.2.14.tar.bz2) = ff5077e444ba995475202bb3b9be733384c809d1
@ -12,7 +12,4 @@ SHA1 (patch-ag) = 78dcb023f524ef65928b529320932c9664ec0d01
SHA1 (patch-ai) = 4ebc3bd580a298973928eb6d13d2ce745eac0312
SHA1 (patch-al) = 56b9f5c2f6fd01fe5067f9210e328cbf674c68f1
SHA1 (patch-am) = ab4a2f7e5a1a3064e908b61157e7fd349c0b0c08
SHA1 (patch-aq) = 27a0093fc75dcafc673abc25e9ebe80167f52ac1
SHA1 (patch-as) = 7880eae75b702563bff8bca833ca81fb3dc4444c
SHA1 (patch-au) = d4c623bb953ac45cb4c8d95fc1d3c2788452d9a1
SHA1 (patch-aw) = ca53d67beeb2c2c4d9adb04d3d79e24a8c427fd4

View file

@ -1,24 +0,0 @@
$NetBSD: patch-aq,v 1.1 2007/06/28 01:20:53 lkundrak Exp $
Part of fix for CVE-2007-3304 Denial of Service.
--- include/mpm_common.h.orig 2007-06-28 02:53:26.000000000 +0200
+++ include/mpm_common.h
@@ -145,6 +145,17 @@ int ap_unregister_extra_mpm_process(pid_
#endif
/**
+ * Safely signal an MPM child process, if the process is in the
+ * current process group. Otherwise fail.
+ * @param pid the process id of a child process to signal
+ * @param sig the signal number to send
+ * @return APR_SUCCESS if signal is sent, otherwise an error as per kill(3)
+ */
+#ifdef AP_MPM_WANT_RECLAIM_CHILD_PROCESSES
+apr_status_t ap_mpm_safe_kill(pid_t pid, int sig);
+#endif
+
+/**
* Determine if any child process has died. If no child process died, then
* this process sleeps for the amount of time specified by the MPM defined
* macro SCOREBOARD_MAINTENANCE_INTERVAL.

View file

@ -1,14 +0,0 @@
$NetBSD: patch-as,v 1.1 2007/06/28 01:20:53 lkundrak Exp $
Part of fix for CVE-2007-3304 Denial of Service.
--- server/mpm/prefork/mpm.h.orig 2007-06-28 02:53:26.000000000 +0200
+++ server/mpm/prefork/mpm.h
@@ -53,6 +53,7 @@
#define AP_MPM_USES_POD 1
#define MPM_CHILD_PID(i) (ap_scoreboard_image->parent[i].pid)
#define MPM_NOTE_CHILD_KILLED(i) (MPM_CHILD_PID(i) = 0)
+#define MPM_VALID_PID(p) (getpgid(p) == getpgrp())
#define MPM_ACCEPT_FUNC unixd_accept
extern int ap_threads_per_child;

View file

@ -1,14 +0,0 @@
$NetBSD: patch-au,v 1.1 2007/06/28 01:20:54 lkundrak Exp $
Part of fix for CVE-2007-3304 Denial of Service.
--- server/mpm/worker/mpm.h.orig 2007-06-28 02:53:26.000000000 +0200
+++ server/mpm/worker/mpm.h
@@ -52,6 +52,7 @@
#define MPM_CHILD_PID(i) (ap_scoreboard_image->parent[i].pid)
#define MPM_NOTE_CHILD_KILLED(i) (MPM_CHILD_PID(i) = 0)
#define MPM_ACCEPT_FUNC unixd_accept
+#define MPM_VALID_PID(p) (getpgid(p) == getpgrp())
extern int ap_threads_per_child;
extern int ap_max_daemons_limit;