py-cares: updated to 2.4.0

Version 2.4.0
- misc: fix building wheels for unavailable Python versions
- test: skip getaddrinfo6 test on Travis
- doc: add FreeBSD building instructions
- build: fix MinGW build
- ci, misc: add support for CPython 3.7
- ci: run on latest PyPy versions on TravisCI
- examples: extra examples
- ci: fix AppVeyor build
- test: fix TXT test
- core: fix repr for PTR results
This commit is contained in:
adam 2019-01-04 08:53:11 +00:00
parent 95afc235ac
commit adfedd5aa5
3 changed files with 13 additions and 13 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.3 2017/07/30 22:32:20 wiz Exp $
# $NetBSD: Makefile,v 1.4 2019/01/04 08:53:11 adam Exp $
DISTNAME= pycares-2.3.0
DISTNAME= pycares-2.4.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/^py//}
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_PYPI:=p/pycares/}
@ -12,8 +12,8 @@ LICENSE= mit
DEPENDS+= ${PYPKGPREFIX}-cffi>=1.5.0:../../devel/py-cffi
USE_LANGUAGES= c
MAKE_ENV+= PYCARES_CFFI=1
USE_LANGUAGES= c
MAKE_ENV+= PYCARES_CFFI=1
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.3 2018/10/22 15:50:28 jperkin Exp $
$NetBSD: distinfo,v 1.4 2019/01/04 08:53:11 adam Exp $
SHA1 (pycares-2.3.0.tar.gz) = 930e2bd12eec1229dac8e877e05437f0bbf99a25
RMD160 (pycares-2.3.0.tar.gz) = 9437a3e9b2e8c992f87f584ab63a1fd417a5e146
SHA512 (pycares-2.3.0.tar.gz) = dc707ab0320e03fb20e728e2e2e52e92ed3388afcf19e4553bc2a15c33a129abee39a9bc423edb7be7113d42989286ab8e8ad48699cc7433a6d8823460fd4678
Size (pycares-2.3.0.tar.gz) = 224941 bytes
SHA1 (patch-setup__cares.py) = 07c04f2ab55b65c2182572e1f0fe18fffbeaf138
SHA1 (pycares-2.4.0.tar.gz) = f9f74680411cbe00a68433e22ffb145ea150c4e9
RMD160 (pycares-2.4.0.tar.gz) = 94879b87d65f3c43ab25e960763b794ae3f79c4d
SHA512 (pycares-2.4.0.tar.gz) = 7770a2b1fd69bb800019a292e5c9fc1f737b044fb4ca5166ead197da3515f2edac55f947a68f3505c9b404745529287114667d742162c98f2ff84b2c330ef295
Size (pycares-2.4.0.tar.gz) = 214021 bytes
SHA1 (patch-setup__cares.py) = 05b36350b308b9e3efbfe02a04204f77fe511dac

View file

@ -1,8 +1,8 @@
$NetBSD: patch-setup__cares.py,v 1.1 2018/10/22 15:50:28 jperkin Exp $
$NetBSD: patch-setup__cares.py,v 1.2 2019/01/04 08:53:12 adam Exp $
Fix build on SunOS.
--- setup_cares.py.orig 2017-04-25 06:44:35.000000000 +0000
--- setup_cares.py.orig 2019-01-02 09:16:48.000000000 +0000
+++ setup_cares.py
@@ -85,9 +85,10 @@ class cares_build_ext(build_ext):
elif sys.platform.startswith('openbsd'):
@ -15,4 +15,4 @@ Fix build on SunOS.
+ self.compiler.add_library('kstat')
elif sys.platform == 'win32':
self.compiler.add_include_dir(os.path.join(self.cares_dir, 'src/config_win32'))
self.extensions[0].extra_link_args = ['/NODEFAULTLIB:libcmt']
if "mingw" not in self.compiler.compiler_type: