hs-regex-tdfa: update to 1.3.2.

### 1.3.2

_2022-07-18, Andreas Abel_

- Export `decodePatternSet` and `decodeCharacterClass` from `Text.Regex.TDFA.Pattern`
  ([#16](https://github.com/haskell-hvr/regex-tdfa/issues/16))
- Extend and correct docs for `Pattern` module
- Tested with GHC 7.4 - 9.4

### 1.3.1.5

_2022-07-18, Andreas Abel_

- Allow dash (`-`) as start of a range, e.g. `[--z]`
  ([#1](https://github.com/haskell-hvr/regex-tdfa/issues/1),
  [#45](https://github.com/haskell-hvr/regex-tdfa/pull/45))
- Tested with GHC 7.4 - 9.4

### 1.3.1.4

_2022-07-17, Andreas Abel_

- Fix parsing of dashes in bracket expressions, e.g. `[-a-z]` ([#1](https://github.com/haskell-hvr/regex-tdfa/issues/1))
- Fix a deprecation warning except for on GHC 8.2 ([#21](https://github.com/haskell-hvr/regex-tdfa/issues/21))
- Documentation: link `defaultComptOpt` to its definition  ([#13](https://github.com/haskell-hvr/regex-tdfa/issues/13))
- Verify documentation examples with new `doc-test` testsuite
- Tested with GHC 7.4 - 9.4

### 1.3.1.3

_2022-07-14, Andreas Abel_

- Fix an `undefined` in `Show PatternSet` ([#37](https://github.com/haskell-hvr/regex-tdfa/issues/37))
- Document POSIX character classes (e.g. `[[:digit:]]`) in README
- Tested with GHC 7.4 - 9.4

### 1.3.1.2 Revision 1

_2022-05-25, Andreas Abel_

- Allow `base >= 4.17` (GHC 9.4)

### 1.3.1.2

_2022-02-19, Andreas Abel_
- No longer rely on the `MonadFail` instance for `ST`
  (future `base` library change, see [#29](https://github.com/haskell-hvr/regex-tdfa/pull/29)).
- Silence warning `incomplete-uni-patterns` (GHC >= 9.2).
- Import from `Data.List` explicitly or qualified (warning `compat-unqualified-imports`).
- Import from `Control.Monad` to allow `mtl-2.3` in its `rc3` incarnation.
This commit is contained in:
wiz 2022-08-18 19:07:53 +00:00
parent 610338a122
commit ae41d39202
3 changed files with 6 additions and 23 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.7 2022/02/26 03:58:30 pho Exp $
# $NetBSD: Makefile,v 1.8 2022/08/18 19:07:53 wiz Exp $
DISTNAME= regex-tdfa-1.3.1.1
PKGREVISION= 2
DISTNAME= regex-tdfa-1.3.2
CATEGORIES= textproc
MAINTAINER= pho@cielonegro.org

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.5 2022/02/11 09:14:02 pho Exp $
$NetBSD: distinfo,v 1.6 2022/08/18 19:07:53 wiz Exp $
BLAKE2s (regex-tdfa-1.3.1.1.tar.gz) = 9fbcd789f9fe4694e3da92828e41a5efcad8b8dd9db6e1f3eb8b43bd1c706266
SHA512 (regex-tdfa-1.3.1.1.tar.gz) = d90461dd142602ee392e8861d6a44a15b59ffae9ed9aae150aa0f27245f04839da46ed3c8cb87e11f8c35ff017b0a596e2874b6a1ec653452a2fab3ee1f83b4e
Size (regex-tdfa-1.3.1.1.tar.gz) = 78057 bytes
SHA1 (patch-regex-tdfa.cabal) = 12fa52e782fc2019ce47bdb452805fbc078362b0
BLAKE2s (regex-tdfa-1.3.2.tar.gz) = 46376cc0cd6fa6def6670472e6a6d892e2fde0740b2093d134ead8d59a9a8e31
SHA512 (regex-tdfa-1.3.2.tar.gz) = 88bbf8f4d7ac15fb85c899bdeb8f8556c7a284075bf2b600051f529f0e2109dcda6ba74fc95969b824cfb03f00a9eb47e9c375c70b1b9e17096c95acbe517168
Size (regex-tdfa-1.3.2.tar.gz) = 82839 bytes

View file

@ -1,15 +0,0 @@
$NetBSD: patch-regex-tdfa.cabal,v 1.2 2022/02/11 09:14:02 pho Exp $
Compatibility with GHC 9.2
--- regex-tdfa.cabal.orig 2001-09-09 01:46:40.000000000 +0000
+++ regex-tdfa.cabal
@@ -97,7 +97,7 @@ library
build-depends: fail == 4.9.*
, semigroups == 0.18.* || == 0.19.*
build-depends: array >= 0.4 && < 0.6
- , base >= 4.5 && < 4.16
+ , base >= 4.5 && < 5
, bytestring >= 0.9.2 && < 0.12
, containers >= 0.4.2 && < 0.7
, mtl >= 2.1.3 && < 2.3