* fixes detection of ncurses.h

* let to exactly use system libpcap (fixes build with newer system libpcap).

Bump PKGREVISION.
This commit is contained in:
obache 2012-04-07 09:23:11 +00:00
parent 34c315e665
commit ae48394cb3
6 changed files with 57 additions and 17 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.32 2010/02/11 22:47:49 joerg Exp $
# $NetBSD: Makefile,v 1.33 2012/04/07 09:23:11 obache Exp $
#
DISTNAME= sniffit.0.3.5
PKGNAME= sniffit-0.3.5
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= net security
MASTER_SITES= http://reptile.rug.ac.be/~coder/sniffit/files/
@ -19,10 +19,17 @@ GNU_CONFIGURE= YES
BUILD_TARGET=
INSTALLATION_DIRS= ${PKGMANDIR}/man5 ${PKGMANDIR}/man8 sbin
CONFIGURE_ENV+= NCURSES_LOCATION=${BUILDLINK_DIR}/include/ncurses.h
post-extract:
${RM} -rf ${WRKSRC}/libpcap-0.3
${RM} -f ${WRKSRC}/pcap.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sniffit ${DESTDIR}${PREFIX}/sbin/sniffit
${INSTALL_MAN} ${WRKSRC}/sniffit.5 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man5
${INSTALL_MAN} ${WRKSRC}/sniffit.8 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man8
.include "../../devel/ncurses/buildlink3.mk"
.include "../../net/libpcap/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.11 2012/03/31 08:31:06 dholland Exp $
$NetBSD: distinfo,v 1.12 2012/04/07 09:23:11 obache Exp $
SHA1 (sniffit.0.3.5.tar.gz) = df9183fca2eec29a56bcfdc68a983c4e7d57bf9d
RMD160 (sniffit.0.3.5.tar.gz) = 9508f357c6fe74a9147a735fd0eb419b9a1124eb
Size (sniffit.0.3.5.tar.gz) = 197255 bytes
SHA1 (patch-ab) = c8a384acf35ff0e51c2851e8eec7ee36d53a09bd
SHA1 (patch-ab) = 146c4d57cb94aa66c9fee9075e141e8b1c4c6b32
SHA1 (patch-ac) = 05ab42b3499edd550de6f1bb667adce34e26a503
SHA1 (patch-ad) = 302391b40bbfe6f218136778738572109be3ce6b
SHA1 (patch-ad) = 9eadda884f4575f5e5facd66e3d5a39b65e686f7
SHA1 (patch-ae) = c430e434309135189de7b3e61e4d0a1e63e50426
SHA1 (patch-ah) = 50959ea602f9c31bd71a966b1c4b1903db2711d5
SHA1 (patch-ai) = d8e5641d1fd729feea93d3b0a8b4d24e12ce9954
@ -13,5 +13,6 @@ SHA1 (patch-aj) = db87dccf1c952e188aebb7bbb699c6257287c87d
SHA1 (patch-ak) = 6909bb66b1ce6f9a4a78b548d00c41b1b0845d56
SHA1 (patch-sn__cfgfile_c) = ae761ad7ec853d86a5dc458e47271125e8b75555
SHA1 (patch-sn__cfgfile_h) = 40dd73a556d0a48576baaa00b7ab8be5fbbf48eb
SHA1 (patch-sn__interface.h) = eaf9368a981ce18b579c26db0c574c7ff91f9b53
SHA1 (patch-sn__logfile_c) = 07248e3ebd524a4f4f10f1d9b6aee33c70c5457f
SHA1 (patch-sniffit_h) = 84166a2ab540a1ab9ab5b5940c9dbd57514fea24
SHA1 (patch-sniffit_h) = 7ccc919e4a2de6a23d5b04c6242a80d336baeb46

View file

@ -1,7 +1,16 @@
$NetBSD: patch-ab,v 1.4 2006/01/25 17:30:55 joerg Exp $
$NetBSD: patch-ab,v 1.5 2012/04/07 09:23:11 obache Exp $
--- configure.orig 1997-04-18 09:33:57.000000000 +0000
+++ configure
@@ -538,7 +538,7 @@ ac_config_guess=$ac_aux_dir/config.guess
ac_config_sub=$ac_aux_dir/config.sub
ac_configure=$ac_aux_dir/configure # This should be Cygnus configure.
-subdirs="libpcap-0.3"
+subdirs=
# Extract the first word of "gcc", so it can be a program name with args.
@@ -996,7 +996,7 @@ cat >> confdefs.h <<EOF
EOF

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ad,v 1.3 1999/07/25 00:36:32 hubertf Exp $
$NetBSD: patch-ad,v 1.4 2012/04/07 09:23:11 obache Exp $
--- Makefile.in.BAK Mon Mar 30 09:38:19 1998
+++ Makefile.in Mon Mar 30 09:38:50 1998
@@ -11,9 +11,9 @@
--- Makefile.in.orig 1997-04-18 09:33:57.000000000 +0000
+++ Makefile.in
@@ -11,17 +11,16 @@ LIBS = @LIBS@
DEFS = @DEFS@
OS_OPT = @OS_OPT@
OBJ_FLAG = -w -O2 -c
@ -13,8 +13,9 @@ $NetBSD: patch-ad,v 1.3 1999/07/25 00:36:32 hubertf Exp $
+EXE_OPT = -lpcap $(LDFLAGS)
EXE_OBJ = sn_packets.o sn_generation.o sn_interface.o sn_cfgfile.o \
sn_logfile.o
DEP_FILES = sn_config.h pcap.h sn_data.h sn_defines.h sn_plugins.h \
@@ -21,7 +21,6 @@
-DEP_FILES = sn_config.h pcap.h sn_data.h sn_defines.h sn_plugins.h \
+DEP_FILES = sn_config.h sn_data.h sn_defines.h sn_plugins.h \
sn_packets.o \
sn_generation.o sn_interface.o sn_cfgfile.o sn_logfile.o
sniffit: $(SNIFFIT) $(DEP_FILES)
@ -22,7 +23,7 @@ $NetBSD: patch-ad,v 1.3 1999/07/25 00:36:32 hubertf Exp $
$(CC) $(EXE_FLAG) $(SNIFFIT) $(EXE_OBJ) $(EXE_OPT) $(LIBS) $(DEFS) $(OS_OPT)
strip sniffit
@@ -44,11 +43,7 @@
@@ -44,11 +43,7 @@ sn_generation.o: sn_generation.h sn_gene
#Clean up everthing...
clean:

View file

@ -0,0 +1,15 @@
$NetBSD: patch-sn__interface.h,v 1.1 2012/04/07 09:23:11 obache Exp $
- make const declarations internally consistent
--- sn_interface.h.orig 1997-04-18 09:33:58.000000000 +0000
+++ sn_interface.h
@@ -29,7 +29,7 @@ void sig_blocking(char, int);
void stop_logging (void);
int check_mask (const struct packetheader *,const unsigned char *, char *,
char *, struct unwrap *);
-pcap_handler interactive_packethandler( char *, const struct packetheader *,
+pcap_handler interactive_packethandler(unsigned char *, const struct packetheader *,
const unsigned char *);
void stop_packet_info (void);
void packet_info_handler (int);

View file

@ -1,12 +1,19 @@
$NetBSD: patch-sniffit_h,v 1.1 2012/03/31 08:31:06 dholland Exp $
$NetBSD: patch-sniffit_h,v 1.2 2012/04/07 09:23:11 obache Exp $
- move strlower to sn_cfgfile.h to make it visible in the right places
- my_exit should be file-static
- update const to match changes to sniffit.0.3.5.c
--- sniffit.h~ 1997-04-18 09:33:58.000000000 +0000
--- sniffit.h.orig 1997-04-18 09:33:58.000000000 +0000
+++ sniffit.h
@@ -15,14 +15,12 @@ void print_iphead (struct IP_header *, c
@@ -9,20 +9,18 @@ pcap_handler packethandler(unsigned char
const unsigned char *);
int check_mask (const struct packetheader *,const unsigned char *, char *,
char *,struct unwrap *);
-pcap_handler interactive_packethandler( char *, const struct packetheader *,
+pcap_handler interactive_packethandler( unsigned char *, const struct packetheader *,
const unsigned char *);
void print_iphead (struct IP_header *, char);
unsigned long getaddrbyname(char *);
void quit (char *);
void reset_all (void);