Import "tidy" from FreeBSD ports collection:

Fixes and tidies up HTML files
This commit is contained in:
tron 2000-03-28 17:13:34 +00:00
parent e7a989ea4a
commit ae63d7d433
7 changed files with 94 additions and 0 deletions

34
www/tidy/Makefile Normal file
View file

@ -0,0 +1,34 @@
# New ports collection makefile for: tidy
# Version required: 0.10.99.1
# Date created: 27 Oct 1998
# Whom: Abel Chow <achow@transoft.net>
#
# $FreeBSD: ports/www/tidy/Makefile,v 1.15 2000/02/16 00:08:36 mharo Exp $
#
DISTNAME= tidy30nov99
PKGNAME= tidy-0.11.99.2
CATEGORIES= www
MASTER_SITES= http://www.w3.org/People/Raggett/
EXTRACT_SUFX= .tgz
MAINTAINER= saken@hotel.rmta.org
MAN1= tidy.1
ALL_TARGET= tidy
DOCFILES= Overview.html tidy.gif release-notes.html grid.gif
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/tidy ${PREFIX}/bin/tidy
@${INSTALL_MAN} ${WRKSRC}/man_page.txt ${PREFIX}/man/man1/tidy.1
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
@${MKDIR} ${PREFIX}/share/doc/tidy
.for docfile in ${DOCFILES}
@${INSTALL_MAN} ${WRKSRC}/${docfile} ${PREFIX}/share/doc/tidy
.endfor
.endif
.include <bsd.port.mk>

1
www/tidy/files/md5 Normal file
View file

@ -0,0 +1 @@
MD5 (tidy30nov99.tgz) = d527142aa7cb10eee1acc1c896c4e5ed

13
www/tidy/patches/patch-aa Normal file
View file

@ -0,0 +1,13 @@
--- Makefile.orig Sun Dec 20 13:43:23 1998
+++ Makefile Sun Dec 20 13:45:24 1998
@@ -1,8 +1,8 @@
# Makefile - for tidy
-CC= gcc
+#CC= gcc
-CFLAGS= -O
+CFLAGS+= -D__USE_MISC
OFILES= attrs.o istack.o parser.o tags.o \
entities.o lexer.o pprint.o clean.o \

22
www/tidy/patches/patch-ab Normal file
View file

@ -0,0 +1,22 @@
--- platform.h.orig Sat Nov 13 23:41:32 1999
+++ platform.h Sat Nov 13 23:42:40 1999
@@ -17,17 +17,17 @@
It enables tidy to find config files named ~/.tidyrc
and ~your/.tidyrc etc if the HTML_TIDY environment
variable is not set. Contributed by Todd Lewis.
+*/
#define SUPPORT_GETPWNAM
-*/
+#include <sys/types.h>
#include <ctype.h>
#include <stdio.h>
#include <setjmp.h> /* for longjmp on error exit */
#include <stdlib.h>
#include <stdarg.h> /* may need <varargs.h> for Unix V */
#include <string.h>
-#include <malloc.h>
#include <assert.h>
#ifdef SUPPORT_GETPWNAM

1
www/tidy/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
Fixes and tidies up HTML files

17
www/tidy/pkg/DESCR Normal file
View file

@ -0,0 +1,17 @@
When editing HTML it's easy to make mistakes. Wouldn't it be nice if
there was a simple way to fix these mistakes automatically and tidy up
sloppy editing into nicely layed out markup? Well now there is thanks
to Hewlett Packard's Dave Raggett. HTML TIDY is a free utility for
doing just that. It also works great on the attrociously hard to read
markup generated by specialized HTML editors and conversion tools, and
can help you identify where you need to pay further attention on
making your pages more accessible to people with disabilities.
Tidy is able to fix up a wide range of problems and to bring to your
attention things that you need to work on yourself. Each item found is
listed with the line number and column so that you can see where the
problem lies in your markup. Tidy won't generate a cleaned up version
when there are problems that it can't be sure of how to handle. These
are logged as "errors" rather than "warnings".
WWW: http://www.w3c.org/People/Raggett/tidy/

6
www/tidy/pkg/PLIST Normal file
View file

@ -0,0 +1,6 @@
bin/tidy
share/doc/tidy/Overview.html
share/doc/tidy/grid.gif
share/doc/tidy/release-notes.html
share/doc/tidy/tidy.gif
@dirrm share/doc/tidy