Remove unused patches after update to 1.8.11.
This commit is contained in:
parent
5e1af65bc0
commit
ae74e3dfcc
12 changed files with 0 additions and 218 deletions
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.4 2015/01/27 06:13:08 mef Exp $
|
||||
|
||||
Make build honor PKGSRC_CFLAGS
|
||||
|
||||
--- tmake/lib/netbsd-g++/tmake.conf.orig 2006-07-21 19:54:13.000000000 +0000
|
||||
+++ tmake/lib/netbsd-g++/tmake.conf
|
||||
@@ -11,7 +11,7 @@ TMAKE_CC = gcc
|
||||
TMAKE_CFLAGS =
|
||||
TMAKE_CFLAGS_WARN_ON = -Wall -W
|
||||
TMAKE_CFLAGS_WARN_OFF =
|
||||
-TMAKE_CFLAGS_RELEASE = -O2
|
||||
+TMAKE_CFLAGS_RELEASE = ${PKGSRC_CFLAGS}
|
||||
TMAKE_CFLAGS_DEBUG = -g
|
||||
TMAKE_CFLAGS_SHLIB = -fPIC
|
||||
TMAKE_CFLAGS_YACC = -Wno-unused -Wno-parentheses
|
|
@ -1,32 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.14 2014/01/02 18:26:36 wiz Exp $
|
||||
|
||||
Convert $(INSTTOOL) to pkgsrc style Variables
|
||||
|
||||
--- Makefile.in.orig 2013-10-21 18:09:13.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -81,19 +81,19 @@ DATE=$(shell date "+%B %Y")
|
||||
MAN1DIR = man/man1
|
||||
|
||||
install: doxywizard_install doxysearch_install
|
||||
- $(INSTTOOL) -d $(DESTDIR)$(INSTALL)/bin
|
||||
- $(INSTTOOL) -m 755 bin/doxygen $(DESTDIR)$(INSTALL)/bin
|
||||
- $(INSTTOOL) -d $(DESTDIR)$(INSTALL)/$(MAN1DIR)
|
||||
+ $(BSD_INSTALL_PROGRAM_DIR) $(DESTDIR)$(INSTALL)/bin
|
||||
+ $(BSD_INSTALL_PROGRAM) bin/doxygen $(DESTDIR)$(INSTALL)/bin
|
||||
+ $(BSD_INSTALL_MAN_DIR) $(DESTDIR)$(INSTALL)/$(MAN1DIR)
|
||||
cat doc/doxygen.1 | sed -e "s/DATE/$(DATE)/g" -e "s/VERSION/$(VERSION)/g" > doxygen.1
|
||||
- $(INSTTOOL) -m 644 doxygen.1 $(DESTDIR)$(INSTALL)/$(MAN1DIR)/doxygen.1
|
||||
+ $(BSD_INSTALL_MAN) doxygen.1 $(DESTDIR)$(INSTALL)/$(MAN1DIR)/doxygen.1
|
||||
rm doxygen.1
|
||||
|
||||
install_docs:
|
||||
- $(INSTTOOL) -d $(DESTDIR)$(DOCDIR)
|
||||
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(DOCDIR)
|
||||
$(MAKE) -C examples
|
||||
$(MAKE) -C doc
|
||||
$(MAKE) -C latex
|
||||
- $(INSTTOOL) -m 644 latex/doxygen_manual.pdf $(DESTDIR)$(DOCDIR)
|
||||
+ $(BSD_INSTALL_DATA) latex/doxygen_manual.pdf $(DESTDIR)$(DOCDIR)
|
||||
cp -r examples $(DESTDIR)$(DOCDIR)
|
||||
cp -r html $(DESTDIR)$(DOCDIR)
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.7 2015/01/27 06:13:08 mef Exp $
|
||||
|
||||
Make epstopdf configurable
|
||||
|
||||
--- doc/Makefile.in.orig 2013-10-07 19:20:02.000000000 +0000
|
||||
+++ doc/Makefile.in
|
||||
@@ -23,7 +23,7 @@ all: language config.doc FORCE
|
||||
@cp Makefile.latex ../latex/Makefile
|
||||
@sed -e "s/\$$VERSION/$(VERSION)/g" doxygen_manual.tex >../latex/doxygen_manual.tex
|
||||
@sed -e "s/\$$VERSION/$(VERSION)/g" doxygen.sty >../latex/doxygen.sty
|
||||
- @epstopdf doxygen_logo.eps --outfile=../latex/doxygen_logo.pdf
|
||||
+ @@EPSTOPDF@ doxygen_logo.eps --outfile=../latex/doxygen_logo.pdf
|
||||
|
||||
clean:
|
||||
rm -rf ../html ../latex *.bak
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-aj,v 1.5 2014/09/09 00:44:56 mef Exp $
|
||||
|
||||
make build honor LDFLAGS
|
||||
|
||||
--- src/doxygen.pro.in.orig 2013-07-28 13:28:16.000000000 +0000
|
||||
+++ src/doxygen.pro.in
|
||||
@@ -19,6 +19,7 @@ CONFIG = console warn_on $extraopt
|
||||
HEADERS = doxygen.h
|
||||
SOURCES = main.cpp
|
||||
unix:LIBS += -L../lib -ldoxygen -lvhdlparser -ldoxycfg -lqtools -lmd5 -lpthread %%SQLITE3_LIBS%% %%LIBCLANG_LIBS%%
|
||||
+unix:TMAKE_LFLAGS += $(LDFLAGS)
|
||||
win32:INCLUDEPATH += .
|
||||
win32-mingw:LIBS += -L../lib -ldoxygen -ldoxycfg -lvhdlparser -lqtools -lmd5 -lpthread -llibiconv -lole32 %%SQLITE3_LIBS%% %%LIBCLANG_LIBS%%
|
||||
win32-msvc:LIBS += qtools.lib md5.lib doxygen.lib doxycfg.lib vhdlparser.lib shell32.lib iconv.lib
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-src_code.l,v 1.1 2016/01/15 18:04:06 tron Exp $
|
||||
|
||||
Remove bogus flex version check that breaks the build with flex 2.6.0.
|
||||
|
||||
--- src/code.l.orig 2015-01-03 22:38:57.000000000 +0000
|
||||
+++ src/code.l 2016-01-15 14:04:12.810214262 +0000
|
||||
@@ -3695,7 +3695,5 @@
|
||||
extern "C" { // some bogus code to keep the compiler happy
|
||||
void codeYYdummy() { yy_flex_realloc(0,0); }
|
||||
}
|
||||
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||
-#error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
|
||||
#endif
|
||||
|
|
@ -1,30 +0,0 @@
|
|||
$NetBSD: patch-src_commentscan.l,v 1.1 2016/01/15 18:04:06 tron Exp $
|
||||
|
||||
Fix build with flex 2.6.0.
|
||||
|
||||
--- src/commentscan.l.orig 2014-12-22 14:01:20.000000000 +0000
|
||||
+++ src/commentscan.l 2016-01-15 14:17:37.661978862 +0000
|
||||
@@ -1098,11 +1098,7 @@
|
||||
// but we need to know the position in the input buffer where this
|
||||
// rule matched.
|
||||
// for flex 2.5.33+ we should use YY_CURRENT_BUFFER_LVALUE
|
||||
-#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
|
||||
inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf);
|
||||
-#else
|
||||
- inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf);
|
||||
-#endif
|
||||
yyterminate();
|
||||
}
|
||||
else if (cmdPtr->func==0)
|
||||
@@ -1160,11 +1156,7 @@
|
||||
g_memberGroupHeader.resize(0);
|
||||
parseMore=TRUE;
|
||||
needNewEntry = TRUE;
|
||||
-#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
|
||||
inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf) + strlen(yytext);
|
||||
-#else
|
||||
- inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf) + strlen(yytext);
|
||||
-#endif
|
||||
yyterminate();
|
||||
}
|
||||
<Comment>{B}*{CMD}[$@\\&~<>#%] { // escaped character
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-src_fortrancode.l,v 1.1 2016/01/15 18:04:06 tron Exp $
|
||||
|
||||
Remove bogus flex version check that breaks the build with flex 2.6.0.
|
||||
|
||||
--- src/fortrancode.l.orig 2015-01-03 22:38:57.000000000 +0000
|
||||
+++ src/fortrancode.l 2016-01-15 14:05:04.598856168 +0000
|
||||
@@ -1289,11 +1289,5 @@
|
||||
extern "C" { // some bogus code to keep the compiler happy
|
||||
void fortrancodeYYdummy() { yy_flex_realloc(0,0); }
|
||||
}
|
||||
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||
-#error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
|
||||
-#else
|
||||
-extern "C" { // some bogus code to keep the compiler happy
|
||||
- void fortrancodeYYdummy() { yy_top_state(); }
|
||||
-}
|
||||
#endif
|
||||
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-src_latexgen.cpp,v 1.1 2015/02/19 11:53:59 joerg Exp $
|
||||
|
||||
--- src/latexgen.cpp.orig 2015-02-18 21:15:46.000000000 +0000
|
||||
+++ src/latexgen.cpp
|
||||
@@ -540,9 +540,10 @@ static void writeDefaultFooter(FTextStre
|
||||
unit = "section";
|
||||
else
|
||||
unit = "chapter";
|
||||
- t << "% Index\n"
|
||||
- "\\backmatter\n"
|
||||
- "\\newpage\n"
|
||||
+ t << "% Index\n";
|
||||
+ if (!Config_getBool("COMPACT_LATEX"))
|
||||
+ t << "\\backmatter\n";
|
||||
+ t << "\\newpage\n"
|
||||
"\\phantomsection\n"
|
||||
"\\clearemptydoublepage\n"
|
||||
"\\addcontentsline{toc}{" << unit << "}{" << theTranslator->trRTFGeneralIndex() << "}\n"
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-src_portable__c.c,v 1.1 2015/01/26 13:35:37 pho Exp $
|
||||
|
||||
Remove kludge for MacPorts bug, otherwise linking against pkgsrc
|
||||
libiconv will fail due to symbol name mismatch.
|
||||
|
||||
--- src/portable_c.c.orig 2014-08-19 12:22:20.000000000 +0000
|
||||
+++ src/portable_c.c
|
||||
@@ -1,9 +1,3 @@
|
||||
-#if (defined(__APPLE__) || defined(macintosh)) && !defined(DMG_BUILD)
|
||||
-// define this before including iconv.h to avoid a mapping of
|
||||
-// iconv_open and friends to libicon_open (done by mac ports),
|
||||
-// while the symbols without 'lib' are linked from /usr/lib/libiconv
|
||||
-#define LIBICONV_PLUG
|
||||
-#endif
|
||||
#include <iconv.h>
|
||||
|
||||
// These functions are implemented in a C file, because there are different
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-src_pycode.l,v 1.1 2016/01/15 18:04:06 tron Exp $
|
||||
|
||||
Remove bogus flex version check that breaks the build with flex 2.6.0.
|
||||
|
||||
--- src/pycode.l.orig 2015-01-03 22:38:57.000000000 +0000
|
||||
+++ src/pycode.l 2016-01-15 14:05:15.828019703 +0000
|
||||
@@ -1503,7 +1503,5 @@
|
||||
extern "C" { // some bogus code to keep the compiler happy
|
||||
void pycodeYYdummy() { yy_flex_realloc(0,0); }
|
||||
}
|
||||
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||
-#error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)."
|
||||
#endif
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-src_vhdlcode.l,v 1.1 2016/01/15 18:04:06 tron Exp $
|
||||
|
||||
Remove bogus flex version check that breaks the build with flex 2.6.0.
|
||||
|
||||
--- src/vhdlcode.l.orig 2015-01-03 22:38:57.000000000 +0000
|
||||
+++ src/vhdlcode.l 2016-01-15 14:00:14.774796788 +0000
|
||||
@@ -1613,8 +1613,6 @@
|
||||
extern "C" { // some bogus code to keep the compiler happy
|
||||
void vhdlcodeYYdummy() { yy_flex_realloc(0,0); }
|
||||
}
|
||||
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||
-#error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
|
||||
#endif
|
||||
|
||||
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-tmake_lib_macosx-c++_tmake.conf,v 1.4 2015/01/27 06:13:08 mef Exp $
|
||||
|
||||
Make build honor PKGSRC_CFLAGS, otherwise linking against pkgsrc
|
||||
libiconv will fail due to header/library mismatch.
|
||||
|
||||
--- tmake/lib/macosx-c++/tmake.conf.orig 2014-10-24 18:51:54.000000000 +0900
|
||||
+++ tmake/lib/macosx-c++/tmake.conf 2015-01-27 13:48:44.000000000 +0900
|
||||
@@ -11,7 +11,7 @@ TMAKE_CC = cc
|
||||
TMAKE_CFLAGS = -pipe
|
||||
TMAKE_CFLAGS_WARN_ON = -Wall -W -Wno-deprecated-declarations
|
||||
TMAKE_CFLAGS_WARN_OFF =
|
||||
-TMAKE_CFLAGS_RELEASE = -O3
|
||||
+TMAKE_CFLAGS_RELEASE = ${PKGSRC_CFLAGS}
|
||||
TMAKE_CFLAGS_DEBUG = -g -fstack-protector
|
||||
TMAKE_CFLAGS_SHLIB = -fPIC
|
||||
TMAKE_CFLAGS_YACC = -Wno-unused -Wno-parentheses
|
Loading…
Reference in a new issue