Bump PKGREVISION.

Fix another _res multi-thread error.
Patch is provided by Dave Tyson on pkgsrc-users@.
This commit is contained in:
ryoon 2012-12-12 08:35:58 +00:00
parent b601d13800
commit ae799650bf
3 changed files with 19 additions and 8 deletions

View file

@ -1,10 +1,11 @@
# $NetBSD: Makefile,v 1.104 2012/11/23 07:17:53 ryoon Exp $
# $NetBSD: Makefile,v 1.105 2012/12/12 08:35:58 ryoon Exp $
#
DISTNAME= # empty
PKGNAME= thunderbird-${TB_VER}
TB_VER= 17.0
LIGHTNINGVER= 1.9
PKGREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_MOZILLA_ESR:=thunderbird/releases/${TB_VER}esr/source/} \
${MASTER_SITE_MOZILLA_ALL:=thunderbird/releases/${TB_VER}esr/source/}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.108 2012/11/23 11:08:05 ryoon Exp $
$NetBSD: distinfo,v 1.109 2012/12/12 08:35:58 ryoon Exp $
SHA1 (enigmail-1.4.5.tar.gz) = 16d0450a9f5fb4de0e9cc5b9f8091dce4b070aaf
RMD160 (enigmail-1.4.5.tar.gz) = 860a1ca813fd2ccae69ac0afe07affd39611e56a
@ -10,7 +10,7 @@ SHA1 (thunderbird-17.0esr.source.tar.bz2) = d1bb6a5a7d6ad55029f5104561c1394a452e
RMD160 (thunderbird-17.0esr.source.tar.bz2) = 6b61aa7acdbfeee1455c8d1540443f5f447e7923
Size (thunderbird-17.0esr.source.tar.bz2) = 113291870 bytes
SHA1 (patch-aa) = 5217684e8e6d587b1cfa65066bd9440b9a313cf3
SHA1 (patch-aa-toplevel) = 3e46b3ef5e15883c882995f4de41704890605d1d
SHA1 (patch-aa-toplevel) = b18a348a10efbf0caad1e3e58de2ecb1120ddaf3
SHA1 (patch-ab) = 7432f73e9771260849d99e14008164bd3d564bf8
SHA1 (patch-ac) = 3d54eef3657bf39b73e2851a33b8ee1aa9408131
SHA1 (patch-ad) = 5f225b1db28a7217d9225ffc03fe3a40b453d7f7

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa-toplevel,v 1.8 2012/09/02 06:43:39 ryoon Exp $
$NetBSD: patch-aa-toplevel,v 1.9 2012/12/12 08:35:59 ryoon Exp $
--- configure.in.orig 2012-08-25 00:24:32.000000000 +0000
--- configure.in.orig 2012-11-19 22:35:28.000000000 +0000
+++ configure.in
@@ -1865,7 +1865,7 @@ ld.])
@@ -1797,7 +1797,7 @@ ld.])
MOZ_FIX_LINK_PATHS='-Wl,-executable_path,$(LIBXUL_DIST)/bin'
;;
@ -11,7 +11,7 @@ $NetBSD: patch-aa-toplevel,v 1.8 2012/09/02 06:43:39 ryoon Exp $
if test `test -x /usr/bin/objformat && /usr/bin/objformat || echo elf` != "elf"; then
DLL_SUFFIX=".so.1.0"
DSO_LDOPTS="-shared"
@@ -1873,6 +1873,9 @@ ld.])
@@ -1805,6 +1805,9 @@ ld.])
if test ! "$GNU_CC"; then
DSO_LDOPTS="-Bshareable $DSO_LDOPTS"
fi
@ -21,7 +21,7 @@ $NetBSD: patch-aa-toplevel,v 1.8 2012/09/02 06:43:39 ryoon Exp $
;;
ia64*-hpux*)
@@ -3106,6 +3109,9 @@ dnl ====================================
@@ -3019,6 +3022,9 @@ dnl ====================================
case $target in
*-hpux11.*)
;;
@ -31,3 +31,13 @@ $NetBSD: patch-aa-toplevel,v 1.8 2012/09/02 06:43:39 ryoon Exp $
*)
AC_CHECK_LIB(c_r, gethostbyname_r)
;;
@@ -3339,6 +3345,9 @@ AC_CACHE_CHECK(
#ifdef linux
#define _BSD_SOURCE 1
#endif
+ #ifdef __NetBSD__
+ #error use of global _res variable in threaded programs is not portable
+ #endif
#include <resolv.h>
],
[int foo = res_ninit(&_res);],