Update to 2.4.63:
Libdrm 2.4.63 has been released. It contains the new libdrm_amdgpu library. Alan Coopersmith (1): include <sys/types.h> & <sys/mkdev.h> directly for major() and minor() Alex Deucher (10): drm: consolidate common list implementations (v2) drm: add util_math.h drm: add libdrm_amdgpu (v7) drm: add tests/amdgpu (v3) amdgpu: update to the latest kernel header fix configuration when amdgpu is disabled fix amdgpu cunit configure test harder move up cunit workaround for ubuntu/debian add a note about which version of cunit is fixed for debian/ubuntu radeon: add new OLAND pci id Alexandr Akulich (1): libdrm/amdgpu: Fixed drm.h include. Anuj Phogat (2): i965/gen9: Pass alignment as function parameter in drm_intel_gem_bo_alloc_internal() Set alignment value in drm_intel_add_validate_buffer() Chris Wilson (1): drm: Detect no-op drmModeAtomicRequest and return early Christian König (16): amdgpu: cleanup public interface v2 amdgpu: add public bo list interface v3 amdgpu: compare the primary device names instead amdgpu: remove bo_vas hash table v2 amdgpu: add helper for VM mapping v2 amdgpu: stop checking flag masks amdgpu: explicitly unmap GPU mapping on BO destruction amdgpu: remove flink export workaround v2 amdgpu: cleanup VA IOCTL handling amdgpu: remove pointer arithmetic from command submission amdgpu: add CS dependencies v2 gitignore: add some generated amdgpu files amdgpu: cleanup public interface style amdgpu: remove reference to AMD specific error codes amdgpu: use common fence structure for dependencies as well. amdgpu: fix bs buffer size for vce test Emil Velikov (15): configure: default --enable-valgrind to auto freedreno: zero is a valid fd number, treat it as such omap: zero is a valid fd number, treat it as such xf86drm: fix incorrect fd comparison in drmOpenOnce{,WithType} Consistently check the fd value man: remove .man_fixup workaround Force enable amdgpu for the dist build/check. amdgpu/util_hash: hide private symbols from global namespace amdgpu/util_hash_table: hide private symbols from global namespace amdgpu: add a bunch of missing config.h includes amdgpu: cosmetic chances in license boilerplate amdgpu: squash trivial documentation typo amdgpu/amdgpu_vamgr: hide private symbols from global namespace amdgpu: hide the final internal functions from global namespace amdgpu: add symbols check test Jack Xiao (2): amdgpu: fix round down/up page size error amdgpu: add zero timeout check in amdgpu_cs_query_fence_status Jammy Zhou (24): amdgpu: remove active_rb_pipes from amdgpu_gpu_info amdgpu: remove AMDGPU_GEM_CREATE_CPU_GTT_UC amdgpu: fix 32-on-64 support (v2) amdgpu: add ctx_id for wait_cs amdgpu: reuse the kernel IB flags v2 amdgpu: validate the upper limit of virtual address v2 amdgpu: fix the number of IB size enums amdgpu: remove unused AMDGPU_IB_RESOURCE_PRIORITY amdgpu: replace alloca with calloc v2 amdgpu: add amdgpu_bo_list_update interface v2 amdgpu: add IB sharing support v2 tests/amdgpu: add shared IB submission test v2 amdgpu: get rid of IB pool management v3 tests/amdgpu: manage IB in client side amdgpu: add amdgpu_query_gds_info amdgpu: cleanup gds specific alloc/free functions amdgpu: merge amdgpu_drm.h from kernel amdgpu: do NULL check for bo handle in amdgpu_bo_query_info amdgpu: improve the amdgpu_cs_query_fence_status interface drm: fix the ALIGN macro to avoid value clamp tests/amdgpu: remove the duplicate IB allocation for VCE test amdgpu: add flags parameter for amdgpu_va_range_alloc amdgpu: add amdgpu_bo_va_op for va map/unmap support v3 amdgpu: expose the PCI revision ID Jonathan Gray (3): xf86drmMode: Implement drmCheckModesettingSupported() for OpenBSD xf86drm: correct the OpenBSD DRM_MAJOR define xf86drm: use the correct device minor names on OpenBSD Joonyoung Shim (1): Build vbltest irrespective of the presence of libudev. Julien Cristau (1): Fix headers inclusion in xf86drmMode.c Ken Wang (8): amdgpu: make vamgr global amdgpu: add max_memory_clock for interface query amdgpu: add vram_type and vram_bit_width for interface query amdgpu: add ce_ram_size for interface query amdgpu: add ib_start_alignment and ib_size_alignment for interface query amdgpu: add base_preferred parameter to amdgpu_vamgr_find_va amdgpu : move management of user fence from libdrm to UMD test/amdgpu : fix a bug in VCE/UVD test introduced by previous change Kristian Høgsberg Kristensen (1): intel: Drop aub dumping functionality Leo Liu (2): tests/amdgpu: implement VCE unit tests amdgpu: add VCE harvesting instance query Marek Olšák (15): amdgpu: implement amdgpu_cs_query_reset_state amdgpu: fix a valgrind warning amdgpu: add new AMDGPU_TILING flags amdgpu: rename GEM_OP_SET_INITIAL_DOMAIN -> GEM_OP_SET_PLACEMENT amdgpu: don't use amdgpu_cs_create_ib for allocation of the fence BO amdgpu: remove amdgpu_ib amdgpu: remove amdgpu_ib helpers amdgpu: remove bo_handle from amdgpu_cs_ib_info, IBs should be in buffer list amdgpu: allow exporting KMS handles with render nodes amdgpu: use alloca and malloc in critical codepaths (v2) amdgpu: fix valgrind warnings amdgpu: fix double mutex_unlock in amdgpu_bo_import drm/amdgpu: allow passing absolute timeouts to amdgpu_cs_query_fence_status amdgpu: check the user fence only if the IP supports user fences Bump version for release Mario Kleiner (1): libdrm/amdgpu: Use private fd for amdgpu_device and winsys hash table to fix ZaphodHeads. (v2) Michel Dänzer (4): amdgpu: Use drmIoctl in amdgpu_ioctl_wait_cs amdgpu/tests: Use buf_handle in amdgpu_bo_alloc_and_map() error paths amdgpu/tests: Cast CPU map argument of amdgpu_bo_alloc_and_map to void** amdgpu: Remove unused local variables bo_size/offset from amdgpu_cs_submit Sabre Shao (2): amdgpu: add va allocation intefaces amdgpu: add va range query interface Tapani Pälli (3): remove usage of 'c_plusplus' preprocessor macro intel: wrap intel_bufmgr.h C code for C++ compilation/linking modeprint: cleanup, remove compile warnings monk.liu (7): amdgpu: support non-page-aligned userptr amdgpu: add missing mutex lock/unlock pair amdgpu: fix an error of bo_list handler amdgpu: do not call BO_LIST ioctl when no resource referred amdgpu: fix segfault when resources are NULL amdgpu: fix code alignment amdgpu: fix vamgr_free_va logic
This commit is contained in:
parent
bce60fb922
commit
ae9a13fdd5
5 changed files with 16 additions and 29 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.56 2015/06/30 09:06:56 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.57 2015/08/14 17:12:35 wiz Exp $
|
||||
|
||||
DISTNAME= libdrm-2.4.62
|
||||
DISTNAME= libdrm-2.4.63
|
||||
CATEGORIES= x11 graphics
|
||||
MASTER_SITES= http://dri.freedesktop.org/libdrm/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,6 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.13 2015/02/14 05:34:13 riastradh Exp $
|
||||
@comment $NetBSD: PLIST,v 1.14 2015/08/14 17:12:35 wiz Exp $
|
||||
${PLIST.arm}include/freedreno/freedreno_drmif.h
|
||||
${PLIST.arm}include/freedreno/freedreno_ringbuffer.h
|
||||
include/libdrm/amdgpu.h
|
||||
include/libdrm/amdgpu_drm.h
|
||||
include/libdrm/drm.h
|
||||
include/libdrm/drm_fourcc.h
|
||||
include/libdrm/drm_mode.h
|
||||
|
@ -32,11 +34,13 @@ include/libdrm/vmwgfx_drm.h
|
|||
include/xf86drm.h
|
||||
include/xf86drmMode.h
|
||||
lib/libdrm.la
|
||||
lib/libdrm_amdgpu.la
|
||||
${PLIST.arm}lib/libdrm_freedreno.la
|
||||
${PLIST.intel}lib/libdrm_intel.la
|
||||
lib/libdrm_nouveau.la
|
||||
lib/libdrm_radeon.la
|
||||
lib/pkgconfig/libdrm.pc
|
||||
lib/pkgconfig/libdrm_amdgpu.pc
|
||||
${PLIST.arm}lib/pkgconfig/libdrm_freedreno.pc
|
||||
${PLIST.intel}lib/pkgconfig/libdrm_intel.pc
|
||||
lib/pkgconfig/libdrm_nouveau.pc
|
||||
|
|
|
@ -1,13 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.54 2015/06/30 09:06:56 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.55 2015/08/14 17:12:35 wiz Exp $
|
||||
|
||||
SHA1 (libdrm-2.4.62.tar.bz2) = 882b59a372508a301aabd6ba8f8bd124f3a69a16
|
||||
RMD160 (libdrm-2.4.62.tar.bz2) = c3700ad5915255cef08cab75ab8c844103655967
|
||||
Size (libdrm-2.4.62.tar.bz2) = 637472 bytes
|
||||
SHA1 (patch-ab) = e28070e56924a68ecc3c4e27d479a5e8edc70913
|
||||
SHA1 (libdrm-2.4.63.tar.bz2) = 996fb06859ef56bcecbdd43963d8258095caa2cc
|
||||
RMD160 (libdrm-2.4.63.tar.bz2) = 699d7efbcb1b642a7d25035176931a0aa6b56c3c
|
||||
Size (libdrm-2.4.63.tar.bz2) = 677288 bytes
|
||||
SHA1 (patch-ab) = ebc345d7f1aeb583b3ebb883fb3b27abc5b8133c
|
||||
SHA1 (patch-ac) = 67c998df7dfc0dabc86320ea6d015cede3e464ea
|
||||
SHA1 (patch-include_drm_drm.h) = 1cb10685b54a1c0ad71aef92edecbb0318fe4c99
|
||||
SHA1 (patch-intel_intel__bufmgr__gem.c) = bab22f43ba85c48fd063b6ac667369d1223f908f
|
||||
SHA1 (patch-libkms_linux.c) = 1ceed0691fb8d2c1066fb4dc8bfefec6ca0de3a4
|
||||
SHA1 (patch-libkms_vmwgfx.c) = d2204c0b79098c6c36b7f282b486c58c6354bd1d
|
||||
SHA1 (patch-radeon_radeon__bo__gem.c) = 4924fde172b2a2a713d47bf7b60a6b52851d7a8f
|
||||
SHA1 (patch-radeon_radeon__cs__gem.c) = 516b5dd6408c10a4f33f2815b3719e34a16d863a
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.7 2015/01/03 10:01:40 wiz Exp $
|
||||
$NetBSD: patch-ab,v 1.8 2015/08/14 17:12:35 wiz Exp $
|
||||
|
||||
--- xf86drm.c.orig 2014-09-28 16:19:54.000000000 +0000
|
||||
--- xf86drm.c.orig 2015-08-13 22:27:03.000000000 +0000
|
||||
+++ xf86drm.c
|
||||
@@ -64,7 +64,7 @@
|
||||
@@ -79,7 +79,7 @@
|
||||
#endif
|
||||
|
||||
#ifdef __NetBSD__
|
||||
|
@ -10,4 +10,4 @@ $NetBSD: patch-ab,v 1.7 2015/01/03 10:01:40 wiz Exp $
|
|||
+#define DRM_MAJOR 180
|
||||
#endif
|
||||
|
||||
# ifdef __OpenBSD__
|
||||
#ifdef __OpenBSD__
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-libkms_linux.c,v 1.2 2015/05/07 06:31:06 wiz Exp $
|
||||
|
||||
--- libkms/linux.c.orig 2015-05-06 23:04:31.000000000 +0000
|
||||
+++ libkms/linux.c
|
||||
@@ -40,6 +40,11 @@
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
#include <sys/stat.h>
|
||||
+#ifdef __sun
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/mkdev.h>
|
||||
+#endif
|
||||
+
|
||||
|
||||
#include "libdrm_macros.h"
|
||||
#include "internal.h"
|
Loading…
Reference in a new issue