Update cdplayer to 0.5 -- notable changes include:

- Added the service 'Play CD' that takes the name of a device
  with an inserted CD to play.
- Added a local cache for CDDB data. All data loaded from the net
  is stored automatically to disk and displayed again when a CD is
  detected.
- Make this compliant with gnustep-make-2.0.8
- Allow unprivileged DESTDIR installs.
This commit is contained in:
rh 2009-04-19 11:43:16 +00:00
parent 3372380af6
commit aea6da900c
4 changed files with 138 additions and 117 deletions

View file

@ -1,29 +1,33 @@
# $NetBSD: Makefile,v 1.15 2008/09/30 15:50:24 joerg Exp $
# $NetBSD: Makefile,v 1.16 2009/04/19 11:43:16 rh Exp $
#
DISTNAME= cdplayer-0.4.2
PKGREVISION= 7
DISTNAME= cdplayer-0.5
CATEGORIES= audio gnustep
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gsburn/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://gsburn.sourceforge.net/
COMMENT= GNUstep CD player with CDDB support
WRKSRC= ${WRKDIR}/${PKGBASE}
LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir
WRKSRC= ${WRKDIR}/CDPlayer-${PKGVERSION_NOREV}
USE_LANGUAGES= objc
USE_TOOLS+= gmake
NO_CONFIGURE= yes
MAKE_JOBS_SAFE= no
MAKE_FILE= GNUmakefile
MAKE_ENV+= ADDITIONAL_CPPFLAGS="-Wno-import"
MAKE_ENV+= GNUSTEP_INSTALLATION_DIR=${PREFIX}/share/GNUstep/Local/
MAKE_ENV+= GNUSTEP_LIB_DIR=${GNUSTEP_LIB_DIR:Q}
do-configure:
${LN} -s ${BUILDLINK_DIR}/${GNUSTEP_SUBDIR}/Local/Library/Frameworks/PrefsModule.framework/Versions/0/Headers ${WRKSRC}/AudioCD/AudioCDPrefs/PrefsModule
INSTALLATION_DIRS+=include/CDPlayer
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/include/CDPlayer
${INSTALL_DATA} ${WRKSRC}/CDPlayer/AudioCDProtocol.h \
${PREFIX}/include/CDPlayer
${DESTDIR}${PREFIX}/include/CDPlayer
.include "../../audio/libcdaudio/buildlink3.mk"
.include "../../audio/cddb-bundle/buildlink3.mk"

View file

@ -1,106 +1,110 @@
@comment $NetBSD: PLIST,v 1.4 2008/09/30 15:50:24 joerg Exp $
@comment $NetBSD: PLIST,v 1.5 2009/04/19 11:43:16 rh Exp $
bin/CDPlayer
include/CDPlayer/AudioCDProtocol.h
share/GNUstep/Local/Applications/CDPlayer.app/CDPlayer
share/GNUstep/Local/Applications/CDPlayer.app/Resources/CDPlayer.desktop
share/GNUstep/Local/Applications/CDPlayer.app/Resources/CDPlayer.help/Config.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/CDPlayer.help/Configuration.xlp
share/GNUstep/Local/Applications/CDPlayer.app/Resources/CDPlayer.help/HowItWorks.xlp
share/GNUstep/Local/Applications/CDPlayer.app/Resources/CDPlayer.help/Logo.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/CDPlayer.help/Main.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/CDPlayer.help/MainEmpty.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/CDPlayer.help/ToDo.xlp
share/GNUstep/Local/Applications/CDPlayer.app/Resources/CDPlayer.help/TrackList.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/CDPlayer.help/main.xlp
share/GNUstep/Local/Applications/CDPlayer.app/Resources/English.lproj/FreeDB.gorm/data.classes
share/GNUstep/Local/Applications/CDPlayer.app/Resources/English.lproj/FreeDB.gorm/objects.gorm
share/GNUstep/Local/Applications/CDPlayer.app/Resources/English.lproj/General.gorm/data.classes
share/GNUstep/Local/Applications/CDPlayer.app/Resources/English.lproj/General.gorm/objects.gorm
share/GNUstep/Local/Applications/CDPlayer.app/Resources/English.lproj/Localizable.strings
share/GNUstep/Local/Applications/CDPlayer.app/Resources/English.lproj/TrackList.gorm/data.classes
share/GNUstep/Local/Applications/CDPlayer.app/Resources/English.lproj/TrackList.gorm/objects.gorm
share/GNUstep/Local/Applications/CDPlayer.app/Resources/French.lproj/FreeDB.gorm/data.classes
share/GNUstep/Local/Applications/CDPlayer.app/Resources/French.lproj/FreeDB.gorm/objects.gorm
share/GNUstep/Local/Applications/CDPlayer.app/Resources/French.lproj/General.gorm/data.classes
share/GNUstep/Local/Applications/CDPlayer.app/Resources/French.lproj/General.gorm/objects.gorm
share/GNUstep/Local/Applications/CDPlayer.app/Resources/French.lproj/Localizable.strings
share/GNUstep/Local/Applications/CDPlayer.app/Resources/French.lproj/TrackList.gorm/data.classes
share/GNUstep/Local/Applications/CDPlayer.app/Resources/French.lproj/TrackList.gorm/objects.gorm
share/GNUstep/Local/Applications/CDPlayer.app/Resources/German.lproj/FreeDB.gorm/data.classes
share/GNUstep/Local/Applications/CDPlayer.app/Resources/German.lproj/FreeDB.gorm/objects.gorm
share/GNUstep/Local/Applications/CDPlayer.app/Resources/German.lproj/General.gorm/data.classes
share/GNUstep/Local/Applications/CDPlayer.app/Resources/German.lproj/General.gorm/objects.gorm
share/GNUstep/Local/Applications/CDPlayer.app/Resources/German.lproj/Localizable.strings
share/GNUstep/Local/Applications/CDPlayer.app/Resources/German.lproj/TrackList.gorm/data.classes
share/GNUstep/Local/Applications/CDPlayer.app/Resources/German.lproj/TrackList.gorm/objects.gorm
share/GNUstep/Local/Applications/CDPlayer.app/Resources/Info-gnustep.plist
share/GNUstep/Local/Applications/CDPlayer.app/Resources/app.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/ffwd.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/iconDnDAudio.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/iconDnDAudioMulti.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/info.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/led0.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/led1.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/led10.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/led11.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/led12.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/led2.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/led3.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/led4.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/led5.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/led6.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/led7.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/led8.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/led9.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/next.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/pause.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/play.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/prev.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/rwd.tiff
share/GNUstep/Local/Applications/CDPlayer.app/Resources/stop.tiff
share/GNUstep/Local/Applications/CDPlayer.app/stamp.make
share/GNUstep/Local/Library/Bundles/AudioCD.bundle/AudioCD
share/GNUstep/Local/Library/Bundles/AudioCD.bundle/Resources/Info-gnustep.plist
share/GNUstep/Local/Library/Bundles/AudioCD.bundle/stamp.make
share/GNUstep/Local/Library/Preferences/AudioCD.prefs/AudioCD
share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/AudioCD.tiff
share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/English.lproj/AudioCD.gorm/data.classes
share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/English.lproj/AudioCD.gorm/objects.gorm
share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/English.lproj/Localizable.strings
share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/French.lproj/AudioCD.gorm/data.classes
share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/French.lproj/AudioCD.gorm/objects.gorm
share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/French.lproj/Localizable.strings
share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/German.lproj/AudioCD.gorm/data.classes
share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/German.lproj/AudioCD.gorm/objects.gorm
share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/German.lproj/Localizable.strings
share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/Info-gnustep.plist
share/GNUstep/Local/Library/Preferences/AudioCD.prefs/stamp.make
share/GNUstep/Local/Tools/CDPlayer
@dirrm share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/German.lproj/AudioCD.gorm
@dirrm share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/German.lproj
@dirrm share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/French.lproj/AudioCD.gorm
@dirrm share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/French.lproj
@dirrm share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/English.lproj/AudioCD.gorm
@dirrm share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources/English.lproj
@dirrm share/GNUstep/Local/Library/Preferences/AudioCD.prefs/Resources
@dirrm share/GNUstep/Local/Library/Preferences/AudioCD.prefs
@dirrm share/GNUstep/Local/Library/Preferences
@dirrm share/GNUstep/Local/Library/Bundles/AudioCD.bundle/Resources
@dirrm share/GNUstep/Local/Library/Bundles/AudioCD.bundle
@comment in devel/gnustep-make: @dirrm share/GNUstep/Local/Library/Bundles
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources/German.lproj/TrackList.gorm
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources/German.lproj/General.gorm
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources/German.lproj/FreeDB.gorm
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources/German.lproj
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources/French.lproj/TrackList.gorm
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources/French.lproj/General.gorm
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources/French.lproj/FreeDB.gorm
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources/French.lproj
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources/English.lproj/TrackList.gorm
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources/English.lproj/General.gorm
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources/English.lproj/FreeDB.gorm
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources/English.lproj
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources/CDPlayer.help
@dirrm share/GNUstep/Local/Applications/CDPlayer.app/Resources
@dirrm share/GNUstep/Local/Applications/CDPlayer.app
@comment in devel/gnustep-make: @dirrm share/GNUstep/Local/Applications
lib/GNUstep/Applications/CDPlayer.app/CDPlayer
lib/GNUstep/Applications/CDPlayer.app/Resources/CDPlayer.desktop
lib/GNUstep/Applications/CDPlayer.app/Resources/CDPlayer.help/Config.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/CDPlayer.help/Configuration.xlp
lib/GNUstep/Applications/CDPlayer.app/Resources/CDPlayer.help/HowItWorks.xlp
lib/GNUstep/Applications/CDPlayer.app/Resources/CDPlayer.help/Logo.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/CDPlayer.help/Main.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/CDPlayer.help/MainEmpty.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/CDPlayer.help/ToDo.xlp
lib/GNUstep/Applications/CDPlayer.app/Resources/CDPlayer.help/TrackList.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/CDPlayer.help/main.xlp
lib/GNUstep/Applications/CDPlayer.app/Resources/English.lproj/FreeDB.gorm/data.classes
lib/GNUstep/Applications/CDPlayer.app/Resources/English.lproj/FreeDB.gorm/objects.gorm
lib/GNUstep/Applications/CDPlayer.app/Resources/English.lproj/General.gorm/data.classes
lib/GNUstep/Applications/CDPlayer.app/Resources/English.lproj/General.gorm/objects.gorm
lib/GNUstep/Applications/CDPlayer.app/Resources/English.lproj/Localizable.strings
lib/GNUstep/Applications/CDPlayer.app/Resources/English.lproj/TrackList.gorm/data.classes
lib/GNUstep/Applications/CDPlayer.app/Resources/English.lproj/TrackList.gorm/objects.gorm
lib/GNUstep/Applications/CDPlayer.app/Resources/French.lproj/FreeDB.gorm/data.classes
lib/GNUstep/Applications/CDPlayer.app/Resources/French.lproj/FreeDB.gorm/objects.gorm
lib/GNUstep/Applications/CDPlayer.app/Resources/French.lproj/General.gorm/data.classes
lib/GNUstep/Applications/CDPlayer.app/Resources/French.lproj/General.gorm/objects.gorm
lib/GNUstep/Applications/CDPlayer.app/Resources/French.lproj/Localizable.strings
lib/GNUstep/Applications/CDPlayer.app/Resources/French.lproj/TrackList.gorm/data.classes
lib/GNUstep/Applications/CDPlayer.app/Resources/French.lproj/TrackList.gorm/objects.gorm
lib/GNUstep/Applications/CDPlayer.app/Resources/German.lproj/FreeDB.gorm/data.classes
lib/GNUstep/Applications/CDPlayer.app/Resources/German.lproj/FreeDB.gorm/objects.gorm
lib/GNUstep/Applications/CDPlayer.app/Resources/German.lproj/General.gorm/data.classes
lib/GNUstep/Applications/CDPlayer.app/Resources/German.lproj/General.gorm/objects.gorm
lib/GNUstep/Applications/CDPlayer.app/Resources/German.lproj/Localizable.strings
lib/GNUstep/Applications/CDPlayer.app/Resources/German.lproj/TrackList.gorm/data.classes
lib/GNUstep/Applications/CDPlayer.app/Resources/German.lproj/TrackList.gorm/objects.gorm
lib/GNUstep/Applications/CDPlayer.app/Resources/Info-gnustep.plist
lib/GNUstep/Applications/CDPlayer.app/Resources/app.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/ffwd.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/iconDnDAudio.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/iconDnDAudioMulti.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/info.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/led0.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/led1.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/led10.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/led11.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/led12.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/led2.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/led3.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/led4.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/led5.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/led6.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/led7.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/led8.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/led9.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/next.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/pause.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/play.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/prev.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/rwd.tiff
lib/GNUstep/Applications/CDPlayer.app/Resources/stop.tiff
lib/GNUstep/Applications/CDPlayer.app/stamp.make
lib/GNUstep/Bundles/AudioCD.bundle/AudioCD
lib/GNUstep/Bundles/AudioCD.bundle/Resources/Info-gnustep.plist
lib/GNUstep/Bundles/AudioCD.bundle/stamp.make
lib/GNUstep/Preferences/AudioCD.prefs/AudioCD
lib/GNUstep/Preferences/AudioCD.prefs/Resources/AudioCD.tiff
lib/GNUstep/Preferences/AudioCD.prefs/Resources/English.lproj/AudioCD.gorm/data.classes
lib/GNUstep/Preferences/AudioCD.prefs/Resources/English.lproj/AudioCD.gorm/data.info
lib/GNUstep/Preferences/AudioCD.prefs/Resources/English.lproj/AudioCD.gorm/objects.gorm
lib/GNUstep/Preferences/AudioCD.prefs/Resources/English.lproj/Localizable.strings
lib/GNUstep/Preferences/AudioCD.prefs/Resources/French.lproj/AudioCD.gorm/data.classes
lib/GNUstep/Preferences/AudioCD.prefs/Resources/French.lproj/AudioCD.gorm/data.info
lib/GNUstep/Preferences/AudioCD.prefs/Resources/French.lproj/AudioCD.gorm/objects.gorm
lib/GNUstep/Preferences/AudioCD.prefs/Resources/French.lproj/Localizable.strings
lib/GNUstep/Preferences/AudioCD.prefs/Resources/German.lproj/AudioCD.gorm/data.classes
lib/GNUstep/Preferences/AudioCD.prefs/Resources/German.lproj/AudioCD.gorm/data.info
lib/GNUstep/Preferences/AudioCD.prefs/Resources/German.lproj/AudioCD.gorm/objects.gorm
lib/GNUstep/Preferences/AudioCD.prefs/Resources/German.lproj/Localizable.strings
lib/GNUstep/Preferences/AudioCD.prefs/Resources/Info-gnustep.plist
lib/GNUstep/Preferences/AudioCD.prefs/stamp.make
@dirrm lib/GNUstep/Preferences/AudioCD.prefs/Resources/German.lproj/AudioCD.gorm
@dirrm lib/GNUstep/Preferences/AudioCD.prefs/Resources/German.lproj
@dirrm lib/GNUstep/Preferences/AudioCD.prefs/Resources/French.lproj/AudioCD.gorm
@dirrm lib/GNUstep/Preferences/AudioCD.prefs/Resources/French.lproj
@dirrm lib/GNUstep/Preferences/AudioCD.prefs/Resources/English.lproj/AudioCD.gorm
@dirrm lib/GNUstep/Preferences/AudioCD.prefs/Resources/English.lproj
@dirrm lib/GNUstep/Preferences/AudioCD.prefs/Resources
@dirrm lib/GNUstep/Preferences/AudioCD.prefs
@comment in x11/gnustep-preferences: @dirrm lib/GNUstep/Preferences
@dirrm lib/GNUstep/Bundles/AudioCD.bundle/Resources
@dirrm lib/GNUstep/Bundles/AudioCD.bundle
@comment in x11/gnustep-base: @dirrm lib/GNUstep/Bundles
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources/German.lproj/TrackList.gorm
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources/German.lproj/General.gorm
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources/German.lproj/FreeDB.gorm
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources/German.lproj
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources/French.lproj/TrackList.gorm
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources/French.lproj/General.gorm
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources/French.lproj/FreeDB.gorm
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources/French.lproj
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources/English.lproj/TrackList.gorm
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources/English.lproj/General.gorm
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources/English.lproj/FreeDB.gorm
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources/English.lproj
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources/CDPlayer.help
@dirrm lib/GNUstep/Applications/CDPlayer.app/Resources
@dirrm lib/GNUstep/Applications/CDPlayer.app
@comment in x11/gnustep-gui: @dirrm lib/GNUstep/Applications
@comment in devel/gnustep-base: @dirrm lib/GNUstep
@dirrm include/CDPlayer

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2005/05/16 09:55:04 rh Exp $
$NetBSD: distinfo,v 1.2 2009/04/19 11:43:16 rh Exp $
SHA1 (cdplayer-0.4.2.tar.gz) = 0d16c0adc02a9884f8ef01e6fe028b72711c898a
RMD160 (cdplayer-0.4.2.tar.gz) = 7d955295cfde801ae3cf1a6e03fdda994504544d
Size (cdplayer-0.4.2.tar.gz) = 171280 bytes
SHA1 (cdplayer-0.5.tar.bz2) = a8a0efdde4bb0bb8f1b7f22b0f4473a611101881
RMD160 (cdplayer-0.5.tar.bz2) = 7a34be771c6b633a1e63953367379e69390b4245
Size (cdplayer-0.5.tar.bz2) = 164389 bytes
SHA1 (patch-aa) = ebd48949eb75b21420e04911dfa964bf6b8e58cf

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.1 2009/04/19 11:43:16 rh Exp $
--- AudioCD/AudioCDPrefs/GNUmakefile.orig 2009-04-19 14:37:41.000000000 +1000
+++ AudioCD/AudioCDPrefs/GNUmakefile
@@ -13,6 +13,7 @@ ifeq ($(prefs), sysprefs)
ADDITIONAL_CPPFLAGS += -DSYSPREFS=1
else
BUNDLE_EXTENSION = .prefs
+ BUNDLE_INSTALL_DIR = ${DESTDIR}${GNUSTEP_LIB_DIR}/Preferences
ADDITIONAL_CPPFLAGS += -DSYSPREFS=0
endif