Update to 0.3.1:
Changes since 0.2.0 - Arguments are now properly passed to child process. - Fixed login shell, also applies to new tabs. - Renamed tabs can now be reset, fixed '--title'. - Improved GTK3 and VTE support. - Added palette customization. - Added terminal zoom feature. - Added tab activity notification (bold). - Added --no_remote to spawn a separate teminal process. - Optional confirmation when closing multiple tabs.
This commit is contained in:
parent
68c9dda80b
commit
aeacc7a6d0
4 changed files with 9 additions and 26 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.11 2018/04/16 14:35:23 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2018/05/22 16:05:18 youri Exp $
|
||||
|
||||
DISTNAME= lxterminal-0.2.0
|
||||
PKGREVISION= 5
|
||||
DISTNAME= lxterminal-0.3.1
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=lxde/}
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
|
||||
MAINTAINER= youri@NetBSD.org
|
||||
HOMEPAGE= https://www.lxde.org/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2016/06/19 19:10:49 youri Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2018/05/22 16:05:18 youri Exp $
|
||||
bin/lxterminal
|
||||
man/man1/lxterminal.1
|
||||
share/applications/lxterminal.desktop
|
||||
|
@ -17,7 +17,6 @@ share/locale/el/LC_MESSAGES/lxterminal.mo
|
|||
share/locale/en_GB/LC_MESSAGES/lxterminal.mo
|
||||
share/locale/eo/LC_MESSAGES/lxterminal.mo
|
||||
share/locale/es/LC_MESSAGES/lxterminal.mo
|
||||
share/locale/es_VE/LC_MESSAGES/lxterminal.mo
|
||||
share/locale/et/LC_MESSAGES/lxterminal.mo
|
||||
share/locale/eu/LC_MESSAGES/lxterminal.mo
|
||||
share/locale/fa/LC_MESSAGES/lxterminal.mo
|
||||
|
|
|
@ -1,8 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.3 2016/06/06 13:44:25 youri Exp $
|
||||
$NetBSD: distinfo,v 1.4 2018/05/22 16:05:18 youri Exp $
|
||||
|
||||
SHA1 (lxterminal-0.2.0.tar.gz) = 0c2269c43aa463e5dbf869d935745226b3c9943a
|
||||
RMD160 (lxterminal-0.2.0.tar.gz) = 3398b90578a1e319c9474c1bd3862698177b657d
|
||||
SHA512 (lxterminal-0.2.0.tar.gz) = 5bec0e16fa4d929203e4c206fb59fb0c88e02f29adbf527c31fa2a0007d3dddbdf12f2219e204360b5dd95a68a89410fcf937325f3a7eb1229b568c9c10c0e78
|
||||
Size (lxterminal-0.2.0.tar.gz) = 248698 bytes
|
||||
SHA1 (patch-src_setting.c) = d7bda3827ea714ccfd508e45737f49847249e16a
|
||||
SHA1 (lxterminal-0.3.1.tar.xz) = 51554be19cbe4ebbc8e3710935fa54c31338fabf
|
||||
RMD160 (lxterminal-0.3.1.tar.xz) = 24d77769d9296bb3c26f48b86bebe3ad1b893bf8
|
||||
SHA512 (lxterminal-0.3.1.tar.xz) = 3063eb7bc7426293d35dc1d9c32d5841e4c3f0b417f3cfa3e5a7bf4d9b71df9c9d375d53d6dd6694b318085ba07167bd8403b2caea9c6e9197aef4b7802877fc
|
||||
Size (lxterminal-0.3.1.tar.xz) = 197628 bytes
|
||||
SHA1 (patch-src_unixsocket.c) = eda2fef63cb83b0f1c64c44ad65b6245a98a0241
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-src_setting.c,v 1.2 2016/06/06 13:35:35 youri Exp $
|
||||
|
||||
Fix glib function, patch accepted upstream.
|
||||
|
||||
--- src/setting.c.orig 2014-10-21 15:29:18.000000000 +0000
|
||||
+++ src/setting.c
|
||||
@@ -162,7 +162,7 @@ void save_setting()
|
||||
/* Deep copy settings. */
|
||||
Setting * copy_setting(Setting * setting)
|
||||
{
|
||||
- g_return_if_fail (setting != NULL);
|
||||
+ g_return_val_if_fail (setting != NULL, NULL);
|
||||
|
||||
/* Allocate structure. */
|
||||
Setting * new_setting = g_slice_new0(Setting);
|
Loading…
Reference in a new issue