pkgtools/pkg: Upgrade version 1.8.7 => 1.9.99.3
This is a development version, but it contains many fixes for NetBSD and Linux. It's better than the release version here.
This commit is contained in:
parent
4e96081593
commit
aec68ef18b
7 changed files with 8 additions and 265 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.17 2016/11/18 14:10:18 marino Exp $
|
||||
# $NetBSD: Makefile,v 1.18 2016/11/20 01:18:46 marino Exp $
|
||||
|
||||
DISTNAME= pkg-1.8.7
|
||||
PKGREVISION= 8
|
||||
DISTNAME= pkg-1.9.99.3
|
||||
CATEGORIES= pkgtools
|
||||
MASTER_SITES= http://files.etoilebsd.net/pkg/
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
|
@ -19,6 +18,7 @@ USE_LANGUAGES= c
|
|||
CPPFLAGS+= -D_LOCALBASE="\"${PREFIX}\""
|
||||
CPPFLAGS+= -DPORTSDIR="\"${PKG.portsdir}\""
|
||||
CPPFLAGS+= -DDEFAULT_VULNXML_URL="\"http://muscles.dragonflybsd.org/pkgsrc-vuxml/vuln.xml.bz2\""
|
||||
CFLAGS+= -DSYSCONFDIR=\"${PKG_SYSCONFDIR}\"
|
||||
|
||||
.if defined(DEBUG_PKGNG)
|
||||
CFLAGS:= ${CFLAGS:N-O2} -ggdb -O0
|
||||
|
@ -92,13 +92,6 @@ SUBST_FILES.vuxml= libpkg/pkg_audit.c
|
|||
SUBST_SED.vuxml= -e "s|https://vuxml.FreeBSD.org/freebsd|http://muscles.dragonflybsd.org/pkgsrc-vuxml/reports|"
|
||||
SUBST_MESSAGE.vuxml= Direct audit reports to Pkgsrc vuxml
|
||||
|
||||
SUBST_CLASSES+= ldhints
|
||||
SUBST_STAGE.ldhints= post-patch
|
||||
SUBST_FILES.ldhints= libpkg/private/ldconfig.h libpkg/elfhints.c
|
||||
SUBST_SED.ldhints= -e "s|/var/run/ld-elf.so.hints|/var/run/ld.so.hints|" \
|
||||
-e 's,ifndef __linux__,if defined __FreeBSD__ || defined __DragonFly__,'
|
||||
SUBST_MESSAGE.ldhints= Disable ldconfig hints for NetBSD
|
||||
|
||||
.if defined(PACKAGE_BUILDING) # set by Synth which has custom location, so use default path
|
||||
PKG.portsdir?= /usr/pkgsrc
|
||||
.else
|
||||
|
@ -112,9 +105,6 @@ BUILDLINK_PASSTHRU_RPATHDIRS= /lib/priv
|
|||
.endif
|
||||
|
||||
post-patch:
|
||||
${CP} ${FILESDIR}/readpassphrase_compat.h \
|
||||
${WRKSRC}/src/
|
||||
|
||||
# DragonFly SSL libraries are private.
|
||||
.if exists(/usr/lib/priv/libprivate_ssl.so)
|
||||
${SED} -i.bak \
|
||||
|
|
|
@ -1,11 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.8 2016/11/15 17:48:56 marino Exp $
|
||||
$NetBSD: distinfo,v 1.9 2016/11/20 01:18:46 marino Exp $
|
||||
|
||||
SHA1 (pkg-1.8.7.tar.xz) = 4727c25b0e4c34df1bf7a00df0e9c6370e855416
|
||||
RMD160 (pkg-1.8.7.tar.xz) = f0087c0e88ef890300a46a28d0644926fa7a7acb
|
||||
SHA512 (pkg-1.8.7.tar.xz) = 61b1553cb444ba30bcf1c9a5da204ff29b08ad87641c3f49fb7e7efd9f5396742e6812bf96a0228d3e76916648511faa086d197cc41c2ced9979615e23a3bc43
|
||||
Size (pkg-1.8.7.tar.xz) = 1950148 bytes
|
||||
SHA1 (pkg-1.9.99.3.tar.xz) = 89a75e19cccda903ca74e1f44c5bbd03ae32fee3
|
||||
RMD160 (pkg-1.9.99.3.tar.xz) = 9bab612c3def26b4b9e1124f5c04fbd3762a584c
|
||||
SHA512 (pkg-1.9.99.3.tar.xz) = 602b5d8cbe1e55a1539cfb68045c061c17c20f8cf1705ba14dfac9b889840be48b21d5e452ab69c51636f1708df89b16636c5f807812f28e739f76caa2fc93d7
|
||||
Size (pkg-1.9.99.3.tar.xz) = 1918096 bytes
|
||||
SHA1 (patch-docs_Makefile.am) = aa6d5c9310c644d13d55c3176cd186c37cccc7c2
|
||||
SHA1 (patch-external_libfetch_ftp.c) = f0080c4bd59386ab2a4ee015f6b22d4d228d7869
|
||||
SHA1 (patch-external_libfetch_http.c) = 9e618f80d6d72af7011351a8903b83f73130cdba
|
||||
SHA1 (patch-libpkg_pkg.h.in) = e74a96513c1e74ddea8a5b05b080cef57976d68b
|
||||
SHA1 (patch-libpkg_pkg__elf.c) = 07174f421e162fc74f1c2b306f60da1273b8b6ec
|
||||
|
|
|
@ -1,192 +0,0 @@
|
|||
/* $OpenBSD: readpassphrase.c,v 1.24 2013/11/24 23:51:29 deraadt Exp $ */
|
||||
|
||||
/*
|
||||
* Copyright (c) 2000-2002, 2007, 2010
|
||||
* Todd C. Miller <Todd.Miller@courtesan.com>
|
||||
*
|
||||
* Permission to use, copy, modify, and distribute this software for any
|
||||
* purpose with or without fee is hereby granted, provided that the above
|
||||
* copyright notice and this permission notice appear in all copies.
|
||||
*
|
||||
* THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
|
||||
* WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
|
||||
* MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
|
||||
* ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
|
||||
* WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
|
||||
* ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
|
||||
* OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
||||
*
|
||||
* Sponsored in part by the Defense Advanced Research Projects
|
||||
* Agency (DARPA) and Air Force Research Laboratory, Air Force
|
||||
* Materiel Command, USAF, under agreement number F39502-99-1-0512.
|
||||
*/
|
||||
|
||||
#ifndef READPASSPHRASE_COMPAT_H
|
||||
#define READPASSPHRASE_COMPAT_H
|
||||
|
||||
#include <ctype.h>
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
#include <paths.h>
|
||||
#include <pwd.h>
|
||||
#include <signal.h>
|
||||
#include <string.h>
|
||||
#include <termios.h>
|
||||
#include <unistd.h>
|
||||
|
||||
#define RPP_ECHO_OFF 0x00 /* Turn off echo (default). */
|
||||
#define RPP_ECHO_ON 0x01 /* Leave echo on. */
|
||||
#define RPP_REQUIRE_TTY 0x02 /* Fail if there is no tty. */
|
||||
#define RPP_FORCELOWER 0x04 /* Force input to lower case. */
|
||||
#define RPP_FORCEUPPER 0x08 /* Force input to upper case. */
|
||||
#define RPP_SEVENBIT 0x10 /* Strip the high bit from input. */
|
||||
#define RPP_STDIN 0x20 /* Read from stdin, not /dev/tty */
|
||||
|
||||
#ifndef _NSIG
|
||||
#define _NSIG 32
|
||||
#endif
|
||||
|
||||
static volatile sig_atomic_t signo[_NSIG];
|
||||
static void handler(int);
|
||||
|
||||
static char *
|
||||
readpassphrase(const char *prompt, char *buf, size_t bufsiz, int flags)
|
||||
{
|
||||
ssize_t nr;
|
||||
int input, output, save_errno, i, need_restart;
|
||||
char ch, *p, *end;
|
||||
struct termios term, oterm;
|
||||
struct sigaction sa, savealrm, saveint, savehup, savequit, saveterm;
|
||||
struct sigaction savetstp, savettin, savettou, savepipe;
|
||||
|
||||
/* I suppose we could alloc on demand in this case (XXX). */
|
||||
if (bufsiz == 0) {
|
||||
errno = EINVAL;
|
||||
return(NULL);
|
||||
}
|
||||
|
||||
restart:
|
||||
for (i = 0; i < _NSIG; i++)
|
||||
signo[i] = 0;
|
||||
nr = -1;
|
||||
save_errno = 0;
|
||||
need_restart = 0;
|
||||
/*
|
||||
* Read and write to /dev/tty if available. If not, read from
|
||||
* stdin and write to stderr unless a tty is required.
|
||||
*/
|
||||
if ((flags & RPP_STDIN) ||
|
||||
(input = output = open("/dev/tty", O_RDWR)) == -1) {
|
||||
if (flags & RPP_REQUIRE_TTY) {
|
||||
errno = ENOTTY;
|
||||
return(NULL);
|
||||
}
|
||||
input = STDIN_FILENO;
|
||||
output = STDERR_FILENO;
|
||||
}
|
||||
|
||||
/*
|
||||
* Turn off echo if possible.
|
||||
* If we are using a tty but are not the foreground pgrp this will
|
||||
* generate SIGTTOU, so do it *before* installing the signal handlers.
|
||||
*/
|
||||
if (input != STDIN_FILENO && tcgetattr(input, &oterm) == 0) {
|
||||
memcpy(&term, &oterm, sizeof(term));
|
||||
if (!(flags & RPP_ECHO_ON))
|
||||
term.c_lflag &= ~(ECHO | ECHONL);
|
||||
(void)tcsetattr(input, TCSAFLUSH, &term);
|
||||
} else {
|
||||
memset(&term, 0, sizeof(term));
|
||||
term.c_lflag |= ECHO;
|
||||
memset(&oterm, 0, sizeof(oterm));
|
||||
oterm.c_lflag |= ECHO;
|
||||
}
|
||||
|
||||
/*
|
||||
* Catch signals that would otherwise cause the user to end
|
||||
* up with echo turned off in the shell. Don't worry about
|
||||
* things like SIGXCPU and SIGVTALRM for now.
|
||||
*/
|
||||
sigemptyset(&sa.sa_mask);
|
||||
sa.sa_flags = 0; /* don't restart system calls */
|
||||
sa.sa_handler = handler;
|
||||
(void)sigaction(SIGALRM, &sa, &savealrm);
|
||||
(void)sigaction(SIGHUP, &sa, &savehup);
|
||||
(void)sigaction(SIGINT, &sa, &saveint);
|
||||
(void)sigaction(SIGPIPE, &sa, &savepipe);
|
||||
(void)sigaction(SIGQUIT, &sa, &savequit);
|
||||
(void)sigaction(SIGTERM, &sa, &saveterm);
|
||||
(void)sigaction(SIGTSTP, &sa, &savetstp);
|
||||
(void)sigaction(SIGTTIN, &sa, &savettin);
|
||||
(void)sigaction(SIGTTOU, &sa, &savettou);
|
||||
|
||||
if (!(flags & RPP_STDIN))
|
||||
(void)write(output, prompt, strlen(prompt));
|
||||
end = buf + bufsiz - 1;
|
||||
p = buf;
|
||||
while ((nr = read(input, &ch, 1)) == 1 && ch != '\n' && ch != '\r') {
|
||||
if (p < end) {
|
||||
if ((flags & RPP_SEVENBIT))
|
||||
ch &= 0x7f;
|
||||
if (isalpha((unsigned char)ch)) {
|
||||
if ((flags & RPP_FORCELOWER))
|
||||
ch = (char)tolower((unsigned char)ch);
|
||||
if ((flags & RPP_FORCEUPPER))
|
||||
ch = (char)toupper((unsigned char)ch);
|
||||
}
|
||||
*p++ = ch;
|
||||
}
|
||||
}
|
||||
*p = '\0';
|
||||
save_errno = errno;
|
||||
if (!(term.c_lflag & ECHO))
|
||||
(void)write(output, "\n", 1);
|
||||
|
||||
/* Restore old terminal settings and signals. */
|
||||
if (memcmp(&term, &oterm, sizeof(term)) != 0) {
|
||||
while (tcsetattr(input, TCSAFLUSH, &oterm) == -1 &&
|
||||
errno == EINTR && !signo[SIGTTOU])
|
||||
continue;
|
||||
}
|
||||
(void)sigaction(SIGALRM, &savealrm, NULL);
|
||||
(void)sigaction(SIGHUP, &savehup, NULL);
|
||||
(void)sigaction(SIGINT, &saveint, NULL);
|
||||
(void)sigaction(SIGQUIT, &savequit, NULL);
|
||||
(void)sigaction(SIGPIPE, &savepipe, NULL);
|
||||
(void)sigaction(SIGTERM, &saveterm, NULL);
|
||||
(void)sigaction(SIGTSTP, &savetstp, NULL);
|
||||
(void)sigaction(SIGTTIN, &savettin, NULL);
|
||||
(void)sigaction(SIGTTOU, &savettou, NULL);
|
||||
if (input != STDIN_FILENO)
|
||||
(void)close(input);
|
||||
|
||||
/*
|
||||
* If we were interrupted by a signal, resend it to ourselves
|
||||
* now that we have restored the signal handlers.
|
||||
*/
|
||||
for (i = 0; i < _NSIG; i++) {
|
||||
if (signo[i]) {
|
||||
kill(getpid(), i);
|
||||
switch (i) {
|
||||
case SIGTSTP:
|
||||
case SIGTTIN:
|
||||
case SIGTTOU:
|
||||
need_restart = 1;
|
||||
}
|
||||
}
|
||||
}
|
||||
if (need_restart)
|
||||
goto restart;
|
||||
|
||||
if (save_errno)
|
||||
errno = save_errno;
|
||||
return(nr == -1 ? NULL : buf);
|
||||
}
|
||||
|
||||
static void handler(int s)
|
||||
{
|
||||
|
||||
signo[s] = 1;
|
||||
}
|
||||
|
||||
#endif
|
|
@ -1,13 +0,0 @@
|
|||
--- external/libfetch/ftp.c.orig 2015-08-12 08:48:13 UTC
|
||||
+++ external/libfetch/ftp.c
|
||||
@@ -55,6 +55,10 @@
|
||||
*
|
||||
*/
|
||||
|
||||
+#ifdef __NetBSD__
|
||||
+#define _NETBSD_SOURCE
|
||||
+#endif
|
||||
+
|
||||
#include <sys/param.h>
|
||||
#include <sys/socket.h>
|
||||
#include <netinet/in.h>
|
|
@ -1,12 +0,0 @@
|
|||
--- external/libfetch/http.c.orig 2016-02-10 23:09:08 UTC
|
||||
+++ external/libfetch/http.c
|
||||
@@ -60,6 +60,9 @@
|
||||
* SUCH DAMAGE.
|
||||
*/
|
||||
#define _XOPEN_SOURCE
|
||||
+#ifdef __NetBSD__
|
||||
+#define _NETBSD_SOURCE
|
||||
+#endif
|
||||
#include <sys/param.h>
|
||||
#include <sys/socket.h>
|
||||
#include <sys/time.h>
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-libpkg_pkg.h.in,v 1.1 2016/10/25 11:51:40 khorben Exp $
|
||||
|
||||
--- libpkg/pkg.h.in.orig 2016-07-05 15:06:13.000000000 +0000
|
||||
+++ libpkg/pkg.h.in
|
||||
@@ -74,7 +74,7 @@ extern "C" {
|
||||
#endif
|
||||
|
||||
#ifdef __NetBSD_Version__
|
||||
-#define OSMAJOR __NetBSD_Version__
|
||||
+#define OSMAJOR ((__NetBSD_Version__ + 1000000) / 100000000)
|
||||
#endif
|
||||
|
||||
#ifndef __DECONST
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-libpkg_pkg__elf.c,v 1.1 2016/10/25 11:51:40 khorben Exp $
|
||||
|
||||
--- libpkg/pkg_elf.c.orig 2016-07-05 15:06:13.000000000 +0000
|
||||
+++ libpkg/pkg_elf.c
|
||||
@@ -787,6 +787,8 @@ pkg_get_myarch_elfparse(char *dest, size
|
||||
#if defined(__DragonFly__)
|
||||
snprintf(dest, sz, "%s:%d.%d",
|
||||
osname, version / 100000, (((version / 100 % 1000)+1)/2)*2);
|
||||
+#elif defined(__NetBSD__)
|
||||
+ snprintf(dest, sz, "%s:%d", osname, (version + 1000000) / 100000000);
|
||||
#else
|
||||
snprintf(dest, sz, "%s:%d", osname, version / 100000);
|
||||
#endif
|
Loading…
Reference in a new issue