Avoid zero-sized structs, fixes Sun Studio build.

This commit is contained in:
sketch 2009-09-23 09:35:47 +00:00
parent 926626a200
commit aee74ee024
2 changed files with 29 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2008/12/26 20:05:56 hasso Exp $
$NetBSD: distinfo,v 1.7 2009/09/23 09:35:47 sketch Exp $
SHA1 (ConsoleKit-0.3.0.tar.bz2) = e3b6156622cc14ebca7382a55b8ed15f2f2bad98
RMD160 (ConsoleKit-0.3.0.tar.bz2) = 7a1ebd2f4bfb65690e70138c9923c3fd2fcaf671
@ -11,3 +11,4 @@ SHA1 (patch-ae) = 8a9612cd35d1ec86240fd17dfa6963c20edc0ad0
SHA1 (patch-af) = e86c63147798d61f7560cfe7547b0d06d18d5583
SHA1 (patch-ag) = 724e2eb95f7ca78c5659fde1eec2f2c5c6bc5002
SHA1 (patch-ah) = f62d8c661732a4ea47e29b99f883b539fb5c7468
SHA1 (patch-ai) = 1cdec78f885adc26ab21deff165ffdf366eaf883

View file

@ -0,0 +1,27 @@
$NetBSD: patch-ai,v 1.1 2009/09/23 09:35:48 sketch Exp $
--- src/ck-log-event.h.orig Wed Sep 23 10:29:34 2009
+++ src/ck-log-event.h Wed Sep 23 10:33:19 2009
@@ -45,18 +45,22 @@
typedef struct
{
+ int dummy;
} CkLogNoneEvent;
typedef struct
{
+ int dummy;
} CkLogSystemStopEvent;
typedef struct
{
+ int dummy;
} CkLogSystemRestartEvent;
typedef struct
{
+ int dummy;
} CkLogSystemStartEvent;
typedef struct