New "imaze" package created by Tim Rightnour:
a multiplayer, networked, action,x 3D maze game.
This commit is contained in:
parent
59229d13b9
commit
aeeab8b1c8
8 changed files with 276 additions and 0 deletions
25
games/imaze/Makefile
Normal file
25
games/imaze/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# $NetBSD: Makefile,v 1.1 1998/07/30 21:40:33 tron Exp $
|
||||
|
||||
DISTNAME= imaze1.3
|
||||
PKGNAME= imaze-1.3
|
||||
CATEGORIES= games x11
|
||||
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
|
||||
MASTER_SITE_SUBDIR= games
|
||||
DISTFILES= imaze-sounds.tar imaze1.3.tar.Z
|
||||
|
||||
MAINTAINER= root@garbled.net
|
||||
|
||||
EXTRACT_ONLY= imaze1.3.tar.Z
|
||||
WRKSRC= ${WRKDIR}/imaze
|
||||
|
||||
USE_MOTIF= yes
|
||||
USE_X11= yes
|
||||
|
||||
post-build:
|
||||
${EXTRACT_CMD} -xmf ${DISTDIR}/imaze-sounds.tar -C ${WRKSRC}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
.if (${OBJECT_FMT} == "ELF")
|
||||
RPATH= -Wl,-rpath,${PREFIX}/lib
|
||||
.endif
|
||||
MAKE_ENV+= RPATH=${RPATH}
|
2
games/imaze/files/md5
Normal file
2
games/imaze/files/md5
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (imaze-sounds.tar) = 6c042fe0afcc3399b31b25ce16d9fb3b
|
||||
MD5 (imaze1.3.tar.Z) = 1cfac4f65653dbd2ed43f8e842a9a374
|
35
games/imaze/patches/patch-aa
Normal file
35
games/imaze/patches/patch-aa
Normal file
|
@ -0,0 +1,35 @@
|
|||
--- source/Makefile.orig Thu Feb 22 15:01:18 1996
|
||||
+++ source/Makefile Wed Jul 29 23:33:30 1998
|
||||
@@ -12,3 +12,3 @@
|
||||
#DEFINES=
|
||||
-BINDIR=..
|
||||
+BINDIR=$(PREFIX)/bin
|
||||
COPT=-O
|
||||
@@ -121,2 +121,10 @@
|
||||
|
||||
+netbsd:
|
||||
+ $(MAKE) \
|
||||
+ GRAF=MOTIF \
|
||||
+ GRAFLIBS='$$(MOTIFLIBS)' \
|
||||
+ GRAFINCLUDES='$$(MOTIFINCLUDES)' \
|
||||
+ SYSDEFS='-DDONT_DECLARE_ERRLIST -DSOUND -DJOYSTICK -DDEFAULT_SOUND_DIR="$$(PREFIX)/share/imaze/sound"' \
|
||||
+ all
|
||||
+
|
||||
irix:
|
||||
@@ -140,3 +148,3 @@
|
||||
LD=$(CC)
|
||||
-INSTALL=install -s -m 755
|
||||
+INSTALL=install -s -o bin -g bin -m 0755
|
||||
|
||||
@@ -145,4 +153,4 @@
|
||||
|
||||
-MOTIFLIBS=-lXm -lXt -lX11
|
||||
-MOTIFINCLUDES=
|
||||
+MOTIFLIBS=-L$(PREFIX)/lib -lXm -lXt -lX11
|
||||
+MOTIFINCLUDES=-I$(PREFIX)/include
|
||||
|
||||
@@ -154,3 +162,3 @@
|
||||
|
||||
-LDFLAGS=
|
||||
+LDFLAGS=$(RPATH)
|
||||
CFLAGS=$(GRAFINCLUDES) $(COPT) $(DEFINES) $(SYSDEFS)
|
14
games/imaze/patches/patch-ab
Normal file
14
games/imaze/patches/patch-ab
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- /dev/null Thu Jul 30 00:12:10 1998
|
||||
+++ Makefile Thu Jul 30 00:24:00 1998
|
||||
@@ -0,0 +1,11 @@
|
||||
+INSTALL= /usr/bin/install -c -g bin -o bin -m 0644
|
||||
+all:
|
||||
+ cd source && make netbsd
|
||||
+install:
|
||||
+ $(INSTALL) man6/* $(PREFIX)/man/man6
|
||||
+ mkdir -p $(PREFIX)/share/imaze/sound
|
||||
+ mkdir -p $(PREFIX)/share/imaze/labs
|
||||
+ $(INSTALL) labs/* $(PREFIX)/share/imaze/labs
|
||||
+ $(INSTALL) sounds/* $(PREFIX)/share/imaze/sound
|
||||
+ $(INSTALL) IMaze.ad $(PREFIX)/lib/X11/app-defaults/IMaze
|
||||
+ cd source && make install
|
148
games/imaze/patches/patch-ac
Normal file
148
games/imaze/patches/patch-ac
Normal file
|
@ -0,0 +1,148 @@
|
|||
--- /dev/null Thu Jul 30 00:12:10 1998
|
||||
+++ IMaze.ad Thu Jul 30 00:21:28 1998
|
||||
@@ -0,0 +1,145 @@
|
||||
+IMaze.dialog.mwmDecorations: 10
|
||||
+IMaze.dialog.title: iMaze: Notice
|
||||
+IMaze.dialog.iconName: iMaze: Notice
|
||||
+IMaze*XmBulletinBoard.dialogStyle: Dialog_Full_Application_Modal
|
||||
+IMaze*XmBulletinBoard*XmLabel.leftAttachment: Attach_Form
|
||||
+IMaze*XmBulletinBoard*XmLabel.rightAttachment: Attach_Form
|
||||
+IMaze*XmBulletinBoard*separator.height: 20
|
||||
+IMaze*XmBulletinBoard*separator.leftAttachment: Attach_Form
|
||||
+IMaze*XmBulletinBoard*separator.rightAttachment: Attach_Form
|
||||
+IMaze*XmBulletinBoard*XmPushButton.defaultButtonShadowThickness: 1
|
||||
+IMaze*question*default.labelString: Continue
|
||||
+IMaze*error*default.labelString: Bad Luck
|
||||
+IMaze*error*default.leftAttachment: Attach_Form
|
||||
+IMaze*XmBulletinBoard*default.showAsDefault: 1
|
||||
+IMaze*XmBulletinBoard*default.topAttachment: Attach_Widget
|
||||
+IMaze*XmBulletinBoard*default.topWidget: separator
|
||||
+IMaze*question*cancel.labelString: Quit
|
||||
+IMaze*question*cancel.topAttachment: Attach_Widget
|
||||
+IMaze*question*cancel.topWidget: separator
|
||||
+IMaze*question*cancel.rightAttachment: Attach_Form
|
||||
+IMaze*question*space.width: 16
|
||||
+IMaze*question*space.traversalOn: False
|
||||
+IMaze*question*space.topAttachment: Attach_Widget
|
||||
+IMaze*question*space.topWidget: separator
|
||||
+IMaze*question*space.leftAttachment: Attach_Widget
|
||||
+IMaze*question*space.leftWidget: default
|
||||
+IMaze*question*space.rightAttachment: Attach_Widget
|
||||
+IMaze*question*space.rightWidget: cancel
|
||||
+!
|
||||
+IMaze*foreground: black
|
||||
+IMaze*background: grey75
|
||||
+IMaze*topShadowColor: grey90
|
||||
+IMaze*bottomShadowColor: grey40
|
||||
+IMaze*highlightColor: black
|
||||
+!
|
||||
+IMaze*FontList: -*-lucida-medium-r-*-*-12-*-*-*-p-*-*-*; -*-helvetica-medium-r-*-*-12-*-*-*-p-*-*-*:
|
||||
+IMaze.form.XmForm.label.FontList: -*-lucida-bold-r-*-*-12-*-*-*-p-*-*-*; -*-helvetica-bold-r-*-*-12-*-*-*-p-*-*-*:
|
||||
+!
|
||||
+IMaze.form.horizontalSpacing: 8
|
||||
+IMaze.form.verticalSpacing: 8
|
||||
+!
|
||||
+IMaze.form.XmForm.leftAttachment: Attach_Form
|
||||
+IMaze.form.XmForm.rightAttachment: Attach_Form
|
||||
+IMaze.form.XmForm.leftOffset: 8
|
||||
+IMaze.form.XmForm.rightOffset: 8
|
||||
+!
|
||||
+IMaze.form.XmForm.input.topAttachment: Attach_Widget
|
||||
+IMaze.form.XmForm.input.topWidget: label
|
||||
+IMaze.form.XmForm.input.leftAttachment: Attach_Form
|
||||
+IMaze.form.XmForm.input.rightAttachment: Attach_Form
|
||||
+!
|
||||
+IMaze*fileMenu.labelString: File
|
||||
+IMaze*fileMenu.mnemonic: F
|
||||
+IMaze*menuBar*exit.labelString: Exit
|
||||
+IMaze*menuBar*exit.mnemonic: x
|
||||
+!
|
||||
+IMaze*toggleMenu.labelString: Window
|
||||
+IMaze*toggleMenu.mnemonic: W
|
||||
+IMaze*menuBar*frontView.labelString: Front View
|
||||
+IMaze*menuBar*frontView.mnemonic: F
|
||||
+IMaze*menuBar*rearView.labelString: Rear View
|
||||
+IMaze*menuBar*rearView.mnemonic: R
|
||||
+IMaze*menuBar*map.labelString: Map
|
||||
+IMaze*menuBar*map.mnemonic: M
|
||||
+IMaze*menuBar*compass.labelString: Compass
|
||||
+IMaze*menuBar*compass.mnemonic: C
|
||||
+IMaze*menuBar*score.labelString: Score
|
||||
+IMaze*menuBar*score.mnemonic: S
|
||||
+!
|
||||
+IMaze*serverMenu.labelString: Server
|
||||
+IMaze*serverMenu.mnemonic: S
|
||||
+IMaze*menuBar*connect.labelString: Connect
|
||||
+IMaze*menuBar*connect.mnemonic: C
|
||||
+IMaze*menuBar*disconnect.labelString: Disconnect
|
||||
+IMaze*menuBar*disconnect.mnemonic: D
|
||||
+!
|
||||
+IMaze*gameMenu.labelString: Game
|
||||
+IMaze*gameMenu.mnemonic: G
|
||||
+IMaze*menuBar*pause.labelString: Pause
|
||||
+IMaze*menuBar*pause.mnemonic: P
|
||||
+IMaze*menuBar*resume.labelString: Resume
|
||||
+IMaze*menuBar*resume.mnemonic: R
|
||||
+!
|
||||
+IMaze*menuBar.leftAttachment: Attach_Form
|
||||
+IMaze*menuBar.leftOffset: 8
|
||||
+IMaze*menuBar.rightAttachment: Attach_Form
|
||||
+IMaze*menuBar.rightOffset: 8
|
||||
+IMaze*menuBar.topAttachment: Attach_Form
|
||||
+IMaze*menuBar.topOffset: 4
|
||||
+!
|
||||
+IMaze*server.topAttachment: Attach_Widget
|
||||
+IMaze*server.topWidget: menuBar
|
||||
+IMaze*server.label.labelString: Server:
|
||||
+!
|
||||
+IMaze*message.topAttachment: Attach_Widget
|
||||
+IMaze*message.topWidget: server
|
||||
+IMaze*message.label.labelString: Message:
|
||||
+!
|
||||
+IMaze*status.leftAttachment: Attach_Form
|
||||
+IMaze*status.leftOffset: 8
|
||||
+IMaze*status.topAttachment: Attach_Widget
|
||||
+IMaze*status.topWidget: message
|
||||
+IMaze*status.bottomAttachment: Attach_Form
|
||||
+IMaze*status.bottomOffset: 4
|
||||
+!
|
||||
+IMaze.title: iMaze - Version 1.3
|
||||
+IMaze.iconName: iMaze
|
||||
+IMaze.x: 8
|
||||
+IMaze.y: 408
|
||||
+IMaze.width: 336
|
||||
+!
|
||||
+IMaze.frontView.title: iMaze: Front View
|
||||
+IMaze.frontView.iconName: iMaze: Front View
|
||||
+IMaze.frontView.x: 360
|
||||
+IMaze.frontView.y: 304
|
||||
+IMaze.frontView.width: 420
|
||||
+IMaze.frontView.height: 280
|
||||
+!
|
||||
+IMaze.rearView.title: iMaze: Rear View
|
||||
+IMaze.rearView.iconName: iMaze: Rear View
|
||||
+IMaze.rearView.x: 360
|
||||
+IMaze.rearView.y: 32
|
||||
+IMaze.rearView.width: 210
|
||||
+IMaze.rearView.height: 140
|
||||
+!
|
||||
+IMaze.map.title: iMaze: Map
|
||||
+IMaze.map.iconName: iMaze: Map
|
||||
+IMaze.map.x: 8
|
||||
+IMaze.map.y: 32
|
||||
+IMaze.map.width: 336
|
||||
+IMaze.map.height: 336
|
||||
+!
|
||||
+IMaze.compass.title: iMaze: Compass
|
||||
+IMaze.compass.iconName: iMaze: Compass
|
||||
+IMaze.compass.x: 586
|
||||
+IMaze.compass.y: 32
|
||||
+IMaze.compass.width: 114
|
||||
+IMaze.compass.height: 114
|
||||
+!
|
||||
+IMaze.score.title: iMaze: Score
|
||||
+IMaze.score.iconName: iMaze: Score
|
||||
+IMaze.score.x: 796
|
||||
+IMaze.score.y: 304
|
||||
+IMaze.score.width: 96
|
||||
+IMaze.score.height: 302
|
1
games/imaze/pkg/COMMENT
Normal file
1
games/imaze/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
a multiplayer, networked, action,x 3D maze game.
|
18
games/imaze/pkg/DESCR
Normal file
18
games/imaze/pkg/DESCR
Normal file
|
@ -0,0 +1,18 @@
|
|||
iMaze is a multi-player network action game for TCP/IP with 3D graphics
|
||||
under X11/XView and Motif.
|
||||
|
||||
It has successfully broken down the local FORTRAN lessons.
|
||||
|
||||
Other features include:
|
||||
- sophisticated, reliable network protocol, works even with SLIP connections
|
||||
via modem
|
||||
- windows can be freely scaled to avoid speed drawbacks due to poor display
|
||||
performance
|
||||
- modular, portable source code
|
||||
- scores
|
||||
- extensive documentation (german)
|
||||
|
||||
After hours of testing, dueling and enjoying MidiMaze 2 on the Atari ST we
|
||||
decided that it wouldn't be such a bad idea to write something similar for
|
||||
Unix. "iMaze" means "Internet Maze" and by a strange coincidence it is also
|
||||
a substring of "MidiMaze".
|
33
games/imaze/pkg/PLIST
Normal file
33
games/imaze/pkg/PLIST
Normal file
|
@ -0,0 +1,33 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 1998/07/30 21:40:34 tron Exp $
|
||||
bin/genlab
|
||||
bin/imaze
|
||||
bin/imazesrv
|
||||
bin/ninja
|
||||
man/man6/genlab.6
|
||||
man/man6/imaze.6
|
||||
man/man6/imazesrv.6
|
||||
man/man6/ninja.6
|
||||
share/imaze/sound/awake.au
|
||||
share/imaze/sound/dead.au
|
||||
share/imaze/sound/kill.au
|
||||
share/imaze/sound/miss.au
|
||||
share/imaze/sound/pause.au
|
||||
share/imaze/sound/shoot.au
|
||||
share/imaze/sound/title.au
|
||||
lib/X11/app-defaults/IMaze
|
||||
share/imaze/labs/10x10.lab
|
||||
share/imaze/labs/15x15.lab
|
||||
share/imaze/labs/25x25.lab
|
||||
share/imaze/labs/12x12.lab
|
||||
share/imaze/labs/20x20.lab
|
||||
share/imaze/labs/april.lab
|
||||
share/imaze/labs/demolab.lab
|
||||
share/imaze/labs/doors.lab
|
||||
share/imaze/labs/longest.lab
|
||||
share/imaze/labs/no1.lab
|
||||
share/imaze/labs/november.lab
|
||||
share/imaze/labs/october.lab
|
||||
@dirrm share/imaze/labs
|
||||
@dirrm share/imaze/sound
|
||||
@dirrm share/imaze
|
||||
|
Loading…
Reference in a new issue