Uses xgettext. Make it work with an older pod2man.

This commit is contained in:
hans 2012-02-16 20:19:56 +00:00
parent d637f84b85
commit aef745adeb
3 changed files with 13 additions and 3 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.3 2012/02/06 12:42:26 wiz Exp $
# $NetBSD: Makefile,v 1.4 2012/02/16 20:19:56 hans Exp $
#
DISTNAME= sakura-2.4.2
@ -16,7 +16,7 @@ LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir
USE_LANGUAGES= c c++
USE_TOOLS+= pkg-config pod2man
USE_TOOLS+= pkg-config pod2man xgettext
USE_CMAKE= yes
SUBST_CLASSES+= fix-man-path

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2011/10/14 16:29:42 ryoon Exp $
$NetBSD: distinfo,v 1.2 2012/02/16 20:19:56 hans Exp $
SHA1 (sakura-2.4.2.tar.bz2) = 24b98c42c057da39f57c281a4726901952774641
RMD160 (sakura-2.4.2.tar.bz2) = 487c148b9ebd0da74908e4241004acc2e8db40f1
Size (sakura-2.4.2.tar.bz2) = 42082 bytes
SHA1 (patch-CMakeLists.txt) = 297c578eef8d021895b0795396667cfe0f9567cf

View file

@ -0,0 +1,9 @@
--- CMakeLists.txt.orig 2012-01-27 11:52:46.987517960 +0100
+++ CMakeLists.txt 2012-01-27 11:55:28.028774190 +0100
@@ -70,5 +70,5 @@ ADD_CUSTOM_TARGET (distclean
IF (POD2MAN)
ADD_CUSTOM_TARGET(man ALL
- COMMAND ${POD2MAN} -u --section=1 --release=${VERSION} --center '' ${sakura_SOURCE_DIR}/sakura.pod sakura.1)
+ COMMAND ${POD2MAN} --section=1 --release=${VERSION} --center '' ${sakura_SOURCE_DIR}/sakura.pod sakura.1)
ENDIF (POD2MAN)