Added editors/edt version 1.9
Edt text editor emulator. This text-editor emulates the VAX VMS text editor known as Edt, and to some extent, later versions called TPU/Eve.
This commit is contained in:
parent
3e73a2ebcc
commit
af07272824
5 changed files with 56 additions and 0 deletions
3
editors/edt/DESCR
Normal file
3
editors/edt/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
Edt text editor emulator. This text-editor emulates the VAX VMS
|
||||
text editor known as Edt, and to some extent, later versions called
|
||||
TPU/Eve.
|
25
editors/edt/Makefile
Normal file
25
editors/edt/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2012/05/23 12:51:27 abs Exp $
|
||||
|
||||
DISTNAME= edt_1.9
|
||||
PKGNAME= ${DISTNAME:C:_:-:}
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=edt-text-editor/}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://edt-text-editor.sourceforge.net/
|
||||
COMMENT= Text editor which emulates the VAX VMS EDT editor
|
||||
LICENSE= gnu-lgpl-v2.1
|
||||
|
||||
MAKE_FILE= makefile
|
||||
INSTALLATION_DIRS= bin share/doc/edt share/examples/edt
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/edt ${DESTDIR}${PREFIX}/bin/edt
|
||||
${INSTALL_DATA} ${WRKSRC}/Readme.txt ${DESTDIR}${PREFIX}/share/doc/edt
|
||||
${INSTALL_DATA} ${WRKSRC}/Readme.txt ${DESTDIR}${PREFIX}/share/doc/edt
|
||||
${INSTALL_DATA} ${WRKSRC}/edt_keypad_*.xml ${DESTDIR}${PREFIX}/share/examples/edt
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
7
editors/edt/PLIST
Normal file
7
editors/edt/PLIST
Normal file
|
@ -0,0 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2012/05/23 12:51:27 abs Exp $
|
||||
bin/edt
|
||||
share/doc/edt/Readme.txt
|
||||
share/examples/edt/edt_keypad_cygwin_laptop.xml
|
||||
share/examples/edt/edt_keypad_linux_laptop.xml
|
||||
share/examples/edt/edt_keypad_linux_pc.xml
|
||||
share/examples/edt/edt_keypad_sun.xml
|
6
editors/edt/distinfo
Normal file
6
editors/edt/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2012/05/23 12:51:27 abs Exp $
|
||||
|
||||
SHA1 (edt_1.9.tgz) = c9cffb91a4c933c719a2f49095f1621a31cb733a
|
||||
RMD160 (edt_1.9.tgz) = dc16f53c2b4928c7dad3e75e99f1b361348cba90
|
||||
Size (edt_1.9.tgz) = 45510 bytes
|
||||
SHA1 (patch-edt__1.9.c) = b618ce48fc4cf193a6f7b578649fb95458ed2751
|
15
editors/edt/patches/patch-edt__1.9.c
Normal file
15
editors/edt/patches/patch-edt__1.9.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-edt__1.9.c,v 1.1.1.1 2012/05/23 12:51:27 abs Exp $
|
||||
|
||||
Typo in call to 'less'
|
||||
|
||||
--- edt_1.9.c.orig 2012-01-01 12:24:03.000000000 +0000
|
||||
+++ edt_1.9.c
|
||||
@@ -4064,7 +4064,7 @@ void help_long()
|
||||
fprintf(fz,"\n");
|
||||
|
||||
fclose(fz);
|
||||
- sprintf(tcline,"lrss %s",tname);
|
||||
+ sprintf(tcline,"less %s",tname);
|
||||
system(tcline);
|
||||
remove(tname);
|
||||
}
|
Loading…
Reference in a new issue