Add missing header. Patch up Python interpreter. Regen distinfo.

This commit is contained in:
joerg 2015-05-20 21:57:10 +00:00
parent 12edd0357c
commit af0fee4c1c
3 changed files with 17 additions and 6 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 2015/05/14 18:39:24 joerg Exp $
# $NetBSD: Makefile,v 1.9 2015/05/20 21:57:10 joerg Exp $
DISTNAME= Botan-1.11.16
PKGNAME= ${DISTNAME:tl}
@ -20,6 +20,8 @@ CONFIG_SHELL= ${PYTHONBIN}
CONFIGURE_SCRIPT= ./configure.py
CONFIGURE_ARGS+= --prefix=${PREFIX} --with-zlib --with-boost --destdir=${DESTDIR}${PREFIX}
REPLACE_PYTHON+= *.py src/scripts/*.py
.include "../../mk/compiler.mk"
.if !empty(PKGSRC_COMPILER:Mclang)
CONFIGURE_ARGS+= --cc-bin=${CXX} --cc=clang

View file

@ -1,10 +1,7 @@
$NetBSD: distinfo,v 1.4 2015/05/14 18:39:24 joerg Exp $
$NetBSD: distinfo,v 1.5 2015/05/20 21:57:10 joerg Exp $
SHA1 (Botan-1.11.16.tgz) = 7214da75a638a7b4a233aca4eccd94d8c688fd52
RMD160 (Botan-1.11.16.tgz) = 7b82dd41243b7bb53d3d667db58afd7e2f948871
Size (Botan-1.11.16.tgz) = 2843785 bytes
SHA1 (patch-src_build-data_arch_arm.txt) = 977a5917ee94e1bafb50f467e99d0f6e1e561ec9
SHA1 (patch-src_build-data_cc_clang.txt) = e36a85e036765d103c06eedac2d9f553a9202173
SHA1 (patch-src_build-data_makefile_header.in) = 9ef8fba7f7a4d665d95478cdd87d58839d438f80
SHA1 (patch-src_lib_alloc_locking__allocator_locking__allocator.cpp) = c4df20faf13b902c9fce21a0ff806b0d83c08780
SHA1 (patch-src_lib_kdf_kdf.h) = 018dcfca7821b64b94175809aaad3fa3d578648c
SHA1 (patch-src_lib_alloc_locking__allocator_locking__allocator.cpp) = dd051c7707d99bef32dd0f822cac0926a9f61141

View file

@ -0,0 +1,12 @@
$NetBSD: patch-src_lib_alloc_locking__allocator_locking__allocator.cpp,v 1.3 2015/05/20 21:57:10 joerg Exp $
--- src/lib/alloc/locking_allocator/locking_allocator.cpp.orig 2015-05-19 20:33:25.000000000 +0000
+++ src/lib/alloc/locking_allocator/locking_allocator.cpp
@@ -8,6 +8,7 @@
#include <botan/locking_allocator.h>
#include <botan/mem_ops.h>
#include <algorithm>
+#include <cstdlib>
#include <string>
#include <sys/mman.h>