grantlee-qt5: fix build with Qt 5.13
This commit is contained in:
parent
7a7f41b24c
commit
af28d56b6c
4 changed files with 46 additions and 3 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.21 2019/04/03 00:32:35 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.22 2019/08/27 06:26:19 markd Exp $
|
||||
#
|
||||
|
||||
DISTNAME= grantlee-5.1.0
|
||||
PKGNAME= ${DISTNAME:S/-/-qt5-/}
|
||||
PKGREVISION= 20
|
||||
PKGREVISION= 21
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://downloads.grantlee.org/
|
||||
|
||||
|
|
|
@ -1,6 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1 2016/05/08 11:21:40 markd Exp $
|
||||
$NetBSD: distinfo,v 1.2 2019/08/27 06:26:19 markd Exp $
|
||||
|
||||
SHA1 (grantlee-5.1.0.tar.gz) = 98429f252d850ac3ad673a1c49a0e833bafe5d3c
|
||||
RMD160 (grantlee-5.1.0.tar.gz) = 7ebd801276dd2aa257f2fd5717ddf4537551d810
|
||||
SHA512 (grantlee-5.1.0.tar.gz) = 2b806a0770b9c6d02f207d5b4939ae8cae325de4fa01901320ffef5c8442ef0f1c10dd799966d0bf0d223e6541f93db8568aaf922ea1b334bcb2f85f6373a936
|
||||
Size (grantlee-5.1.0.tar.gz) = 1175380 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = 22dab41e1a0c62bdf578efd2c44b80b8b4737e72
|
||||
SHA1 (patch-templates_lib_lexer_p.h) = 72ba688ce9ad33016cadfbb022ce90a17b926a6a
|
||||
|
|
20
devel/grantlee-qt5/patches/patch-CMakeLists.txt
Normal file
20
devel/grantlee-qt5/patches/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-CMakeLists.txt,v 1.1 2019/08/27 06:26:19 markd Exp $
|
||||
|
||||
From: Albert Astals Cid <aacid@kde.org>
|
||||
Date: Sat, 20 Jul 2019 17:35:30 +0200
|
||||
Subject: [PATCH] Fix compile with newer Qt/cmake combination
|
||||
|
||||
Without this i get huge errors about Qt needing C++11 support
|
||||
|
||||
--- CMakeLists.txt.orig 2019-08-25 11:37:40.489318446 +0000
|
||||
+++ CMakeLists.txt
|
||||
@@ -7,6 +7,9 @@ endif()
|
||||
|
||||
project(Grantlee)
|
||||
|
||||
+set (CMAKE_CXX_STANDARD 11)
|
||||
+set (CMAKE_CXX_EXTENSIONS OFF)
|
||||
+
|
||||
# Workaround for http://public.kitware.com/Bug/view.php?id=12301
|
||||
if (MINGW)
|
||||
if(NOT CMAKE_BUILD_TYPE)
|
21
devel/grantlee-qt5/patches/patch-templates_lib_lexer_p.h
Normal file
21
devel/grantlee-qt5/patches/patch-templates_lib_lexer_p.h
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-templates_lib_lexer_p.h,v 1.1 2019/08/27 06:26:19 markd Exp $
|
||||
|
||||
From: Michael Pyne <mpyne@kde.org>
|
||||
Date: Tue, 18 Dec 2018 17:47:21 -0500
|
||||
Subject: [PATCH] Fix build with Qt 5.13 / GCC 8.2.
|
||||
|
||||
At this point Grantlee doesn't build for me because QList is an
|
||||
incomplete type. I think the compiler is right to complain, so I fix by
|
||||
including the appropriate header.
|
||||
|
||||
--- templates/lib/lexer_p.h.orig 2019-08-25 11:37:32.228371777 +0000
|
||||
+++ templates/lib/lexer_p.h
|
||||
@@ -24,7 +24,7 @@
|
||||
#include "textprocessingmachine_p.h"
|
||||
#include "token.h"
|
||||
|
||||
-template <typename T> class QList;
|
||||
+#include <QList>
|
||||
|
||||
namespace Grantlee
|
||||
{
|
Loading…
Reference in a new issue