Update to 1.4.8:

Changes for APR 1.4.8

  *) Fix compiltation with FreeBSD on ARM.  [Olli Hauer <ohauer gmx.de>]

  *) Fix 1.4.7 regression in apr_mcast_hops() and apr_mcast_loopback()
     for AF_INET (IPv4) sockets on most Unix platforms.  [Joe Orton]

  *) Fix the return value of apr_threadattr_detach_get() on some
     platforms like OS X and Solaris. [Rainer Jung, <dusanv gmail com>]

Changes for APR 1.4.7

  *) Fix apr_sockaddr_info_get() not returning an error in some cases.
     PR 54779. [Jan Kaluža <jkaluza redhat com>]

  *) Fix amd64 assembler version of apr_atomic_xchgptr(). PR 51851. [Mattias
     Engdegård <mattiase acm org>]

  *) Fix PPC atomics to work with gcc 4.0. PR 54840. [Mattias Engdegård
     <mattiase acm org>]

  *) configure: Fix detection of O_NONBLOCK inheritance on busy
     systems.  [Rainer Jung]

  *) Remove unused code, fix strict C compliance bug in SHA-256
     implementation.  [Jan Kaluza <jkaluza redhat.com>]

  *) Fix apr_ipsubnet_test() false positives when comparing IPv4
     subnet representation against an IPv6 address.  PR 54047.  [Joe Orton]

  *) apr_socket_accept_filter: Return success when trying to again set
     the filter to the same value as before, avoiding an unhelpful
     APR_EINVAL.  PR 37863.  [Jeff Trawick]

  *) configure: Fix Linux 3.x detection. PR 54001. [Gilles Espinasse
     <g esp free fr>]

  *) apr_time_exp_*() on Windows: Fix error in the tm_yday field of
     apr_time_exp_t for times within leap years.  PR 53175.
     [Jeff Trawick]

  *) Improve platform detection by updating config.guess and config.sub.
     [Rainer Jung]

  *) Add support for OSX Mountain Lion (10.8) [Jim Jagielski]

  *) Add various gcc function attributes. [Stefan Fritsch]

  *) Fix some problems in apr_sockaddr_info_get() when trying to resolve
     the loopback addresses of a protocol family that is not otherwise
     configured on the system. PR 52709. [Nirgal Vourgère
     <jmv_deb nirgal com>, Stefan Fritsch]

  *) Fix file not being unlocked if truncate call on a file fails.
     [Mladen Turk]

  *) apr_mcast_hops: Fix EINVAL for IPv6 sockets caused by using byte
     instead integer for setsockopt. [Mladen Turk]

  *) Windows: Fix compile-time checks for 64-bit builds, resolving a
     crash in httpd's mod_rewrite.  PR 49155.  [<anindyabaruah gmail.com>]
This commit is contained in:
wiz 2013-07-04 16:24:02 +00:00
parent e4d3442875
commit af483d54c2
4 changed files with 6 additions and 42 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.70 2012/10/31 11:16:36 asau Exp $
# $NetBSD: Makefile,v 1.71 2013/07/04 16:24:02 wiz Exp $
DISTNAME= apr-1.4.6
DISTNAME= apr-1.4.8
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_APACHE:=apr/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.35 2012/03/11 12:17:46 ryoon Exp $
$NetBSD: distinfo,v 1.36 2013/07/04 16:24:02 wiz Exp $
SHA1 (apr-1.4.6.tar.bz2) = 1a72fc9d89a378590ef243399396169426d1f6cf
RMD160 (apr-1.4.6.tar.bz2) = ca496323a921f71ed28695ede94ff4fc00df9b0d
Size (apr-1.4.6.tar.bz2) = 785724 bytes
SHA1 (patch-atomic_unix_ia32.c) = c51d5810ceb8438b04d7945a476fef96ea57a76a
SHA1 (patch-test_testatomic.c) = 0905b0001e0d06b9c96beb1c32ee9ce9382f233f
SHA1 (apr-1.4.8.tar.bz2) = 2dce90291b6d4072a6e47d096f5c81ae1ce76f9f
RMD160 (apr-1.4.8.tar.bz2) = 081406aa06854c04fb029069b0299e00c3f51ae6
Size (apr-1.4.8.tar.bz2) = 772927 bytes

View file

@ -1,14 +0,0 @@
$NetBSD: patch-atomic_unix_ia32.c,v 1.1 2011/11/19 21:16:22 alnsn Exp $
https://issues.apache.org/bugzilla/show_bug.cgi?id=51851
--- atomic/unix/ia32.c.orig 2007-08-26 19:50:26.000000000 +0000
+++ atomic/unix/ia32.c
@@ -117,7 +117,7 @@ APR_DECLARE(void*) apr_atomic_xchgptr(vo
#elif APR_SIZEOF_VOIDP == 8
asm volatile ("xchgq %q2, %1"
: "=a" (prev), "+m" (*mem)
- : "r" ((unsigned long)with));
+ : "0" ((unsigned long)with));
#else
#error APR_SIZEOF_VOIDP value not supported
#endif

View file

@ -1,20 +0,0 @@
$NetBSD: patch-test_testatomic.c,v 1.1 2011/11/19 21:16:22 alnsn Exp $
https://issues.apache.org/bugzilla/show_bug.cgi?id=51851
--- test/testatomic.c.orig 2007-11-18 00:35:57.000000000 +0000
+++ test/testatomic.c
@@ -84,11 +84,12 @@ static void test_xchg32(abts_case *tc, v
static void test_xchgptr(abts_case *tc, void *data)
{
int a;
- volatile void *target_ptr = NULL;
+ void *ref = "little piggy";
+ volatile void *target_ptr = ref;
void *old_ptr;
old_ptr = apr_atomic_xchgptr(&target_ptr, &a);
- ABTS_PTR_EQUAL(tc, NULL, old_ptr);
+ ABTS_PTR_EQUAL(tc, ref, old_ptr);
ABTS_PTR_EQUAL(tc, &a, (void *) target_ptr);
}