Use POSIX types for int32/uint32 to fix build on AMD64.

Add DESTDIR support.
This commit is contained in:
joerg 2008-10-03 17:42:28 +00:00
parent 40ae1f06a1
commit afa791e368
4 changed files with 38 additions and 27 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.29 2008/08/04 08:37:06 obache Exp $
# $NetBSD: Makefile,v 1.30 2008/10/03 17:42:28 joerg Exp $
#
DISTNAME= tripwire-1.2
@ -6,6 +6,8 @@ PKGREVISION= 3
CATEGORIES= security
MASTER_SITES= http://www.mirrors.wiretapped.net/security/host-intrusion-detection/tripwire/old/
PKG_DESTDIR_SUPPORT= user-destdir
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.cerias.purdue.edu/about/history/coast/coast-library.html
COMMENT= File and directory integrity checker
@ -35,8 +37,8 @@ pre-configure:
PRE_ROOT_CMD= ${CHMOD} -R go+rwx ${WRKSRC}
post-install:
${INSTALL_DATA} ${WRKSRC}/docs/designdoc.ps ${PREFIX}/share/doc/tripwire
${INSTALL_DATA} ${WRKSRC}/docs/designdoc.ps ${DESTDIR}${PREFIX}/share/doc/tripwire
${SED} -e 's|@localbase@|${LOCALBASE}|g' -e 's|@x11base@|${X11BASE}|g' \
${FILESDIR}/tw.conf.${LOWER_OPSYS} > ${EGDIR}/tripwire.conf
${FILESDIR}/tw.conf.${LOWER_OPSYS} > ${DESTDIR}${EGDIR}/tripwire.conf
.include "../../mk/bsd.pkg.mk"

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.11 2005/12/05 20:50:58 rillig Exp $
$NetBSD: distinfo,v 1.12 2008/10/03 17:42:29 joerg Exp $
SHA1 (tripwire-1.2.tar.gz) = 6fc91e25b3e1af3881fd5b6acf240ab6c1133e38
RMD160 (tripwire-1.2.tar.gz) = f745db5973f14b1abbc0c2e7030f90e6fdac3257
Size (tripwire-1.2.tar.gz) = 299831 bytes
SHA1 (patch-aa) = 2a03c5970becef18d0b655cc5e91a1db070111f8
SHA1 (patch-ab) = 186edaa504e6e1a7edadb2168982b9b8a2482bac
SHA1 (patch-aa) = 718860c41de3ad86161f3c87176ace43121b271a
SHA1 (patch-ab) = 78a8e7050b51c05f94273581ffed8f56c89387ad
SHA1 (patch-ac) = 35b3fe52f497e6cbbf7edfeaee398f0d24aff219
SHA1 (patch-ad) = 4b8ad8d0cd7c17a8f3a655c5a574856670533ea5
SHA1 (patch-ae) = 6eb1767af3d881ed4181ab83bd02c960edd0a84e

View file

@ -1,20 +1,7 @@
$NetBSD: patch-aa,v 1.4 2004/02/08 13:36:20 grant Exp $
$NetBSD: patch-aa,v 1.5 2008/10/03 17:42:29 joerg Exp $
--- Makefile.orig 1994-07-26 01:59:41.000000000 +1000
--- Makefile.orig 1994-07-25 17:59:41.000000000 +0200
+++ Makefile
@@ -12,10 +12,10 @@
###
# destination directory for final executables
-DESTDIR = /secureplace/bin
+DESTDIR = ${PREFIX}/sbin
# destination for man pages
-MANDIR = /usr/man
+MANDIR = ${PREFIX}/man
# system utilities
LEX = lex
@@ -32,11 +32,11 @@ SHELL = /bin/sh
#SHELL = /bin/bash # For the GNU fanatics
@ -56,3 +43,14 @@ $NetBSD: patch-aa,v 1.4 2004/02/08 13:36:20 grant Exp $
#INSTALL= /usr/ucb/install # Pyramid DC/OSx (SVR4)
#INSTALL= /etc/install # Pyramid OSx
#INSTALL= /bin/cp # no install
@@ -103,8 +103,8 @@ all:
YACC="$(YACC)" LEX="$(LEX)" all)
install: all
- (cd src; make INSTALL=$(INSTALL) DESTDIR=$(DESTDIR) install)
- (cd man; make INSTALL=$(INSTALL) MANDIR=$(MANDIR) install)
+ (cd src; make INSTALL=$(INSTALL) DESTDIR=$(DESTDIR)${PREFIX}/sbin install)
+ (cd man; make INSTALL=$(INSTALL) MANDIR=$(DESTDIR)$(PREFIX)/${PKGMANDIR} install)
test: all
(cd tests; make HOSTNAME=$(HOSTNAME) DIST=$(DIST) SHELL=$(SHELL) \

View file

@ -1,19 +1,30 @@
$NetBSD: patch-ab,v 1.4 2003/05/01 21:47:43 jmmv Exp $
$NetBSD: patch-ab,v 1.5 2008/10/03 17:42:29 joerg Exp $
NetBSD and Solaris specific paths for tripwire.
--- include/config.h 1994/07/15 11:02:52 1.5
+++ include/config.h 1998/11/17 14:40:02
@@ -17,7 +17,7 @@
@@ -17,15 +17,11 @@
*** file that corresponds with your operating system.
***/
-#include "../configs/conf-svr4.h"
+#include "../configs/conf-@LOWER_OPSYS@.h"
#ifdef TW_TYPE32
typedef TW_TYPE32 int32;
@@ -102,9 +102,8 @@
-#ifdef TW_TYPE32
-typedef TW_TYPE32 int32;
-typedef unsigned TW_TYPE32 uint32;
-#else
-typedef long int32;
-typedef unsigned long uint32;
-#endif
+#include <inttypes.h>
+typedef int32_t int32;
+typedef uint32_t uint32;
/***
*** SYSTEM SPECIFIC Tripwire Configuration
@@ -102,9 +98,8 @@ typedef unsigned long uint32;
# define DATABASE_PATH "/usr/local/adm/tcheck/databases"
#endif
*/
@ -25,7 +36,7 @@ NetBSD and Solaris specific paths for tripwire.
/******* name of Tripwire files **************************************
*
@@ -121,7 +120,7 @@
@@ -121,7 +116,7 @@ typedef unsigned long uint32;
*
*********************************************************************/