filezilla: update to 3.43.0.

3.43.0 (2019-06-27)

! Filenames containing double-quotation marks were not escaped correctly when selected for opening/editing. Depending on the associated program, parts of the filename could be interpreted as commands.
- Added a second layer of authentication to the update mechanism

3.43.0-rc2 (2019-06-21)

- Rebuilt against libfilezilla 0.17.1

3.43.0-rc1 (2019-06-19)

- macOS: Minimum required macOS version has been increased to 10.11 (El Capitan)
- *nix: Official Linux binaries are now built for Debian 10 (Buster)
- Building FileZilla now requires a C++17 compiler
- Building and running FileZilla now depends on libfilezilla >= 0.17.0 (https://lib.filezilla-project.org/)
- When using SFTP, fix fallback to password authentication on a server refusing a password-protected key
- Fix HTTP proxy support
- *nix: Improve resolution of program icon
This commit is contained in:
wiz 2019-07-20 21:22:35 +00:00
parent 9f7198444a
commit afc078d050
3 changed files with 9 additions and 22 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.113 2019/06/12 00:50:05 gutteridge Exp $
# $NetBSD: Makefile,v 1.114 2019/07/20 21:22:35 wiz Exp $
VERSION= 3.42.1
VERSION= 3.43.0
DISTNAME= FileZilla_${VERSION}_src
PKGNAME= filezilla-${VERSION}
CATEGORIES= net x11
@ -21,6 +21,7 @@ CONFIGURE_ARGS+= --disable-autoupdatecheck
# avoid xdg-utils dependency
CONFIGURE_ENV+= ac_cv_path_xdgopen=firefox
# TODO: update GCC_REQD, as of 3.43.0 this requires C++17
# GCC 4.9 is required to support C++14.
GCC_REQD+= 4.9
@ -34,7 +35,7 @@ CXXFLAGS+= -march=i586
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../devel/libidn/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
BUILDLINK_API_DEPENDS.libfilezilla+= libfilezilla>=0.16
BUILDLINK_API_DEPENDS.libfilezilla+= libfilezilla>=0.17.1
.include "../../net/libfilezilla/buildlink3.mk"
BUILDLINK_API_DEPENDS.gnutls+= gnutls>=3.4.0
.include "../../security/gnutls/buildlink3.mk"

View file

@ -1,9 +1,8 @@
$NetBSD: distinfo,v 1.51 2019/05/25 07:45:50 wiz Exp $
$NetBSD: distinfo,v 1.52 2019/07/20 21:22:35 wiz Exp $
SHA1 (FileZilla_3.42.1_src.tar.bz2) = 9f8f08df4672c559646e6d9e9523440bd57f3dd5
RMD160 (FileZilla_3.42.1_src.tar.bz2) = e939da6e7f2414d43844747a51abe3442eb820e3
SHA512 (FileZilla_3.42.1_src.tar.bz2) = 0dc9b3a6347803f60a71c56bb759700fb2b1b019dc29794aa639ce892ccd1ae53041112987f9d5e8e75ec7e07702a5aac8e1c131796bbc5f210d75d286276deb
Size (FileZilla_3.42.1_src.tar.bz2) = 4987250 bytes
SHA1 (FileZilla_3.43.0_src.tar.bz2) = 9f071e81695a9b55d2392832bc4ca5e5def0634f
RMD160 (FileZilla_3.43.0_src.tar.bz2) = 613832fc9bd7e8b198ffff0d208e2b7fa723d541
SHA512 (FileZilla_3.43.0_src.tar.bz2) = 12c518616508e1cbd7ab60f1b94f8c876c885bc4399674c4b2df34235141fde1297a1edc686078c0f93b040ea6e42984c22ace00c4da201c7f99b4c9b71f5bc1
Size (FileZilla_3.43.0_src.tar.bz2) = 4544635 bytes
SHA1 (patch-configure) = 8bf5736d17ed78fe0a1d4f910194bba9f03c854e
SHA1 (patch-src_interface_Makefile.in) = 684a9847bdc6b9fad98e5346c54a11d8ae10cbd4
SHA1 (patch-src_putty_unix_uxshare.c) = 0c3102c10b742c461fe032f081d1a642c6fd6a59

View file

@ -1,13 +0,0 @@
$NetBSD: patch-src_interface_Makefile.in,v 1.1 2019/05/25 07:45:50 wiz Exp $
--- src/interface/Makefile.in.orig 2019-05-08 16:34:47.000000000 +0000
+++ src/interface/Makefile.in
@@ -310,7 +310,7 @@ am__v_lt_ = $(am__v_lt_@AM_DEFAULT_V@)
am__v_lt_0 = --silent
am__v_lt_1 =
filezilla_LINK = $(LIBTOOL) $(AM_V_lt) $(filezilla_LIBTOOLFLAGS) \
- $(LIBTOOLFLAGS) --mode=link $(OBJCXXLD) \
+ $(LIBTOOLFLAGS) --mode=link --tag=CXX $(OBJCXXLD) \
$(filezilla_OBJCXXFLAGS) $(OBJCXXFLAGS) $(filezilla_LDFLAGS) \
$(LDFLAGS) -o $@
AM_V_P = $(am__v_P_@AM_V@)