Update to 0.29

Changelog:
Notmuch 0.29 (2019-06-07)
=========================

General
-------

Add "body:" field to allow searching for terms that occur only in the
message body. Users will need to reindex their mail to take advantage
of this feature.

Add support for indexing user specified headers (e.g. List-Id). See
notmuch-config(1) for details. This requires reindexing after changing
the set of headers to be indexed.

Fix bug for searching in some headers for Xapian keywords in quoted
strings.

Add support for gzip compressed mail messages (/not/ multi-message
mboxes); e.g. `gzip -9 $MAIL/archive/giant-message && notmuch new`
should work. Note that maildir flag syncing for gzipped messages is
currently untested.

Notmuch is now capable of indexing, searching and rendering
cryptographically-protected Subject: headers of the form produced by
Enigmail and K-9 mail in encrypted messages.

Command Line Interface
----------------------

`notmuch show` now supports --body=false and --include-html with
--format=text

Fix several performance problems with `notmuch reindex`.

`notmuch show` and `notmuch reply` now emit per-message cryptographic
status in their json and sexp output formats.  See devel/schemata for
more details about what is included there.  This status includes
information about cryptographic protections for the Subject header.

Emacs
-----

Optionally check for missing attachements in outgoing messages (see
function `notmuch-mua-attachment-check`).

Bind `B` to browse URLs in current message.

Bind `g` to refresh the current notmuch buffer.

Editing a message as new now includes an FCC header.

Forwarded messages are now tagged as +forwarded (customizable).

Add references header to link forwarded message to thread of original
message.

The minimum supported major version of Emacs is now 24.

Support for GNU Emacs older than 25.1 is deprecated with this release,
and may be removed in a future release.

Notmuch-emacs documentation is somewhat expanded. More contributions
are very welcome.

Build System
------------

Notmuch release tarballs are now compressed with `xz`.

We now provide conventional detached signatures of the release
tarballs in addition to the signed `sha256sum` files.

Dependencies
------------

Support for GMime 2.6 is removed. The minimum supported version of
GMime is now 3.0.3.  GMime also needs to have been compiled with
cryptography support.

Test Suite
----------

If either GNU parallel or moreutils parallel is installed, the tests
in the test suite will now be run in parallel (one per available
core).  This can be disabled with NOTMUCH_TEST_SERIALIZE=1.
This commit is contained in:
ryoon 2019-06-07 13:42:50 +00:00
parent 2a99d42ed9
commit b0066c7c70
3 changed files with 36 additions and 7 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.50 2019/05/12 10:45:54 ryoon Exp $
# $NetBSD: Makefile,v 1.51 2019/06/07 13:42:50 ryoon Exp $
DISTNAME= notmuch-0.28.4
DISTNAME= notmuch-0.29
CATEGORIES= mail
MASTER_SITES= https://notmuchmail.org/releases/
EXTRACT_SUFX= .tar.xz
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://notmuchmail.org/
@ -36,6 +37,18 @@ SUBST_FILES.sphinx+= bindings/python/docs/Makefile configure doc/Makefile.local
SUBST_STAGE.sphinx= pre-configure
SUBST_MESSAGE.sphinx= Fix sphinx command names.
.if !empty(PKG_BUILD_OPTIONS.gpgme:Mgnupg2)
GPG= gpg2
.else
GPG= gpg
.endif
SUBST_CLASSES+= gpg
SUBST_STAGE.gpg= pre-configure
SUBST_MESSAGE.gpg= Select GnuPG command
SUBST_FILES.gpg+= configure
SUBST_VARS.gpg= GPG
LDFLAGS.SunOS+= -lnsl
post-extract:

View file

@ -1,10 +1,11 @@
$NetBSD: distinfo,v 1.39 2019/05/12 10:45:54 ryoon Exp $
$NetBSD: distinfo,v 1.40 2019/06/07 13:42:50 ryoon Exp $
SHA1 (notmuch-0.28.4.tar.gz) = 0e96aa8c28dfa33ad3ff4177bf72cad8c1d06c30
RMD160 (notmuch-0.28.4.tar.gz) = 7b15b0ba3d1cda8f90b9b1083e14fd39b7040aae
SHA512 (notmuch-0.28.4.tar.gz) = 77d7ad81e1f7dc93ae6392346da434f6dc74c21d19be728c2a6ca283c429f36e7081387d223af58eb5f63f5d2a8ad8367f0103f0bb9d052890c07fe419abbee7
Size (notmuch-0.28.4.tar.gz) = 922364 bytes
SHA1 (notmuch-0.29.tar.xz) = b64613b58d7a308b291d34154fbbd54e3707867a
RMD160 (notmuch-0.29.tar.xz) = 34ef5e9333bbf7f12128a1e044cf9eab0ff4e3ca
SHA512 (notmuch-0.29.tar.xz) = 88f8bbd143b4027742900eb304704265d1e3bfa683034fa0290da19840e69ce79bd7d89054d585f426935cdd0742d5846a266803fef2ee487b09fd4d8bbf1b20
Size (notmuch-0.29.tar.xz) = 660284 bytes
SHA1 (patch-Makefile.global) = f436bdb163e3110a8d097f3c88198aefb126eafc
SHA1 (patch-Makefile.local) = d0a83ff130de36164f1667236860aa31d481d025
SHA1 (patch-configure) = afbc37cdf886c6b73be4c34903d495cf0589963a
SHA1 (patch-doc_conf.py) = 7492c878c96da68df16827aa0d6407c2e9808701
SHA1 (patch-emacs_Makefile.local) = 4a36a2c165852a098a45c8b99c8372d65d33b07c

View file

@ -0,0 +1,15 @@
$NetBSD: patch-configure,v 1.1 2019/06/07 13:42:50 ryoon Exp $
* Select GnuPG binary
--- configure.orig 2019-06-07 09:46:30.000000000 +0000
+++ configure
@@ -533,7 +533,7 @@ EOF
printf 'No.\nCould not make tempdir for testing session-key support.\n'
errors=$((errors + 1))
elif ${CC} ${CFLAGS} ${gmime_cflags} _check_session_keys.c ${gmime_ldflags} -o _check_session_keys \
- && GNUPGHOME=${TEMP_GPG} gpg --batch --quiet --import < test/gnupg-secret-key.asc \
+ && GNUPGHOME=${TEMP_GPG} @GPG@ --batch --quiet --import < test/gnupg-secret-key.asc \
&& SESSION_KEY=$(GNUPGHOME=${TEMP_GPG} ./_check_session_keys) \
&& [ $SESSION_KEY = 9:0BACD64099D1468AB07C796F0C0AC4851948A658A15B34E803865E9FC635F2F5 ]
then