Fix build with gcc-4.5.
Set LICENSE. Fix a pkglint warning.
This commit is contained in:
parent
ed2283146a
commit
b021662d07
4 changed files with 106 additions and 7 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.38 2010/11/13 21:08:55 shattered Exp $
|
||||
# $NetBSD: Makefile,v 1.39 2011/08/22 08:51:46 wiz Exp $
|
||||
|
||||
DISTNAME= binutils-2.17
|
||||
PKGREVISION= 1
|
||||
|
@ -8,6 +8,7 @@ MASTER_SITES= ${MASTER_SITE_GNU:=binutils/}
|
|||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://directory.fsf.org/project/binutils/
|
||||
COMMENT= GNU binary utilities
|
||||
LICENSE= gnu-gpl-v2 AND gnu-lgpl-v2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
|
@ -33,7 +34,7 @@ BINUTILS_PREFIX= ${PREFIX}/${MACHINE_GNU_PLATFORM}
|
|||
PLIST_SRC= ${PKGDIR}/PLIST.common
|
||||
PLIST_SRC+= ${WRKDIR}/PLIST_DYNAMIC
|
||||
|
||||
INFO_FILES= # PLIST
|
||||
INFO_FILES= yes
|
||||
|
||||
# gprof (XXX: and others?) cannot be built on all platforms
|
||||
#
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.9 2007/08/14 09:08:07 rillig Exp $
|
||||
$NetBSD: distinfo,v 1.10 2011/08/22 08:51:46 wiz Exp $
|
||||
|
||||
SHA1 (binutils-2.17.tar.gz) = a9ac9ac4e918568b297033cdc44a38beef8f9f6a
|
||||
RMD160 (binutils-2.17.tar.gz) = bc5e8b23457f0e2e91f70b93eff00134e2d50434
|
||||
|
@ -8,4 +8,5 @@ SHA1 (patch-ab) = 9d8a52de59f73cce90a1e8fff5d20849724ceb26
|
|||
SHA1 (patch-ac) = 8165e2adb19eca4ec9b6e7fd3b52c6614910fa65
|
||||
SHA1 (patch-ad) = 4aa005a473d1c4af052eaee84b98b1c0aff90bf1
|
||||
SHA1 (patch-ae) = 8aa22782397a59c17801c791dddaefdf757d824e
|
||||
SHA1 (patch-af) = ca9171203123d2563e0c49bd8fed4d1366d35691
|
||||
SHA1 (patch-af) = f4566c63dd8e7267d96ea65527fd2593b210c241
|
||||
SHA1 (patch-gas_app.c) = c7fb59d4c2d9450618818d7e9f5d6e7e8efdbda3
|
||||
|
|
|
@ -1,7 +1,16 @@
|
|||
$NetBSD: patch-af,v 1.1 2007/08/14 09:08:07 rillig Exp $
|
||||
$NetBSD: patch-af,v 1.2 2011/08/22 08:51:46 wiz Exp $
|
||||
|
||||
--- gas/read.c.orig 2005-11-17 08:29:28.000000000 +0100
|
||||
+++ gas/read.c 2007-08-14 11:03:42.000000000 +0200
|
||||
--- gas/read.c.orig 2005-11-17 07:29:28.000000000 +0000
|
||||
+++ gas/read.c
|
||||
@@ -1279,7 +1279,7 @@ s_align (int arg, int bytes_p)
|
||||
unsigned int align_limit = ALIGN_LIMIT;
|
||||
unsigned int align;
|
||||
char *stop = NULL;
|
||||
- char stopc;
|
||||
+ char stopc = '\0';
|
||||
offsetT fill = 0;
|
||||
int max;
|
||||
int fill_p;
|
||||
@@ -1423,7 +1423,7 @@ s_comm_internal (int param,
|
||||
offsetT temp, size;
|
||||
symbolS *symbolP = NULL;
|
||||
|
@ -11,3 +20,75 @@ $NetBSD: patch-af,v 1.1 2007/08/14 09:08:07 rillig Exp $
|
|||
expressionS exp;
|
||||
|
||||
if (flag_mri)
|
||||
@@ -1538,7 +1538,7 @@ s_mri_common (int small ATTRIBUTE_UNUSED
|
||||
symbolS *sym;
|
||||
offsetT align;
|
||||
char *stop = NULL;
|
||||
- char stopc;
|
||||
+ char stopc = '\0';
|
||||
|
||||
if (!flag_mri)
|
||||
{
|
||||
@@ -1807,7 +1807,7 @@ s_fail (int ignore ATTRIBUTE_UNUSED)
|
||||
{
|
||||
offsetT temp;
|
||||
char *stop = NULL;
|
||||
- char stopc;
|
||||
+ char stopc = '\0';
|
||||
|
||||
if (flag_mri)
|
||||
stop = mri_comment_field (&stopc);
|
||||
@@ -1929,7 +1929,7 @@ s_globl (int ignore ATTRIBUTE_UNUSED)
|
||||
int c;
|
||||
symbolS *symbolP;
|
||||
char *stop = NULL;
|
||||
- char stopc;
|
||||
+ char stopc = '\0';
|
||||
|
||||
if (flag_mri)
|
||||
stop = mri_comment_field (&stopc);
|
||||
@@ -2881,7 +2881,7 @@ s_space (int mult)
|
||||
expressionS val;
|
||||
char *p = 0;
|
||||
char *stop = NULL;
|
||||
- char stopc;
|
||||
+ char stopc = '\0';
|
||||
int bytes;
|
||||
|
||||
#ifdef md_flush_pending_output
|
||||
@@ -3057,7 +3057,7 @@ s_float_space (int float_type)
|
||||
int flen;
|
||||
char temp[MAXIMUM_NUMBER_OF_CHARS_FOR_FLOAT];
|
||||
char *stop = NULL;
|
||||
- char stopc;
|
||||
+ char stopc = '\0';
|
||||
|
||||
if (flag_mri)
|
||||
stop = mri_comment_field (&stopc);
|
||||
@@ -3134,7 +3134,7 @@ void
|
||||
s_struct (int ignore ATTRIBUTE_UNUSED)
|
||||
{
|
||||
char *stop = NULL;
|
||||
- char stopc;
|
||||
+ char stopc = '\0';
|
||||
|
||||
if (flag_mri)
|
||||
stop = mri_comment_field (&stopc);
|
||||
@@ -3514,7 +3514,7 @@ cons_worker (register int nbytes, /* 1=.
|
||||
int c;
|
||||
expressionS exp;
|
||||
char *stop = NULL;
|
||||
- char stopc;
|
||||
+ char stopc = '\0';
|
||||
|
||||
#ifdef md_flush_pending_output
|
||||
md_flush_pending_output ();
|
||||
@@ -5010,7 +5010,7 @@ void
|
||||
equals (char *sym_name, int reassign)
|
||||
{
|
||||
char *stop = NULL;
|
||||
- char stopc;
|
||||
+ char stopc = '\0';
|
||||
|
||||
input_line_pointer++;
|
||||
if (*input_line_pointer == '=')
|
||||
|
|
16
devel/binutils/patches/patch-gas_app.c
Normal file
16
devel/binutils/patches/patch-gas_app.c
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-gas_app.c,v 1.1 2011/08/22 08:51:46 wiz Exp $
|
||||
|
||||
Fix build with gcc-4.5.
|
||||
|
||||
--- gas/app.c.orig 2006-03-10 10:57:18.000000000 +0000
|
||||
+++ gas/app.c
|
||||
@@ -563,7 +563,8 @@ do_scrub_chars (int (*get) (char *, int)
|
||||
{
|
||||
as_warn (_("end of file in string; '%c' inserted"), quotechar);
|
||||
state = old_state;
|
||||
- UNGET ('\n');
|
||||
+ if (from > input_buffer)
|
||||
+ UNGET ('\n');
|
||||
PUT (quotechar);
|
||||
}
|
||||
else if (ch == quotechar)
|
Loading…
Reference in a new issue