size_t -> socklen_t

This commit is contained in:
is 2005-03-02 14:23:35 +00:00
parent a7bc256d52
commit b023f8f607
2 changed files with 15 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.11 2005/03/02 14:11:27 is Exp $
$NetBSD: distinfo,v 1.12 2005/03/02 14:23:35 is Exp $
SHA1 (sr233.tar.Z) = 0354987527ed1e84c32d3b1fc6bacb65d647f337
Size (sr233.tar.Z) = 1424566 bytes
@ -15,3 +15,4 @@ SHA1 (patch-ax) = a834a65f2574be388bb420fdf883a9ac74f00ec9
SHA1 (patch-ay) = ea10d5daf877ca129efdfdbc544159a75f70f395
SHA1 (patch-az) = 1560c8ea0b760e2fb97385e565d87a49a879c6a2
SHA1 (patch-ba) = a29a664d693585ff39bc1f8d2c4b165981cde72a
SHA1 (patch-bb) = 6214584bde5a05386d0f31690b30a9c0a8c299af

13
lang/sr/patches/patch-bb Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-bb,v 1.1 2005/03/02 14:23:35 is Exp $
--- rts/socket.c.orig 2005-03-02 14:17:00.000000000 +0000
+++ rts/socket.c
@@ -278,7 +278,7 @@ Pach ph;
int n, result, my_currfd;
static struct sockaddr sockbuff;
- static size_t buffsize;
+ static socklen_t buffsize;
static fd_set readyset; /* fd's with input available. Fortunately,
* the only place this is assigned to is
* already protected. */