Update to 3.161. Extract of changes, excluding bug fixes
and portability stuff: Added -z option. This is to be used with the -a option. It provides more complete testing for small record sizes when the file sizes are very large. Added -y and -q to set record size range Added command line to output Put auto cross over back to 16 Meg Add labels to the latency/offset output files. Prevent mixed modes. Auto and throughput. Added support for the Plus extended options. Added support for -+u option. Cpu utilization. Added network testing mode. -+m (Experimental) Tested: Linux, HP-UX Added -xflag support for distributed mode. Handle interrupts when in distributed mode. Disable CPU utilization in distributed mode. Add -+m cluster option to the help list and the list of options. Enable more options in Cluster mode. Add protocol version checking for distributed messages. Add -+d file I/O diagnostic mode. Fix some compiler warnings and implement the -+x option for setting the multiplier used for file and record size incrementing. Reduce the message traffic due to master's distribution of STOP. Only one STOP distribution is needed. More can lead to socket buffer overflows. Add -+p percentage read option. Improve the mixed mode distribution algorithm. Introduce -+r for O_RSYNC. Add speed check code. Increase maximum threads/procs to 256 Add contribs and -+t to help splash screen. Disable fread and fwrite testing if mmap or async is in use. Add pread/pwrite throughput testing Permit smaller values for -n and -g Make initial write in initfile() a page size request. Stop test if file can not be written.
This commit is contained in:
parent
a14962e7c6
commit
b037acec31
5 changed files with 43 additions and 155 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.15 2001/07/16 22:04:54 garbled Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2003/03/10 11:06:49 wiz Exp $
|
||||
|
||||
DISTNAME= iozone3_56
|
||||
PKGNAME= iozone-3.56
|
||||
DISTNAME= iozone3_161
|
||||
PKGNAME= iozone-3.161
|
||||
CATEGORIES= benchmarks
|
||||
MASTER_SITES= http://www.iozone.org/src/current/
|
||||
EXTRACT_SUFX= .tar
|
||||
|
@ -27,7 +27,7 @@ do-install:
|
|||
${INSTALL_PROGRAM} ${WRKSRC}/iozone ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKDIR}/docs/iozone.1 ${PREFIX}/man/man1
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/IOzone
|
||||
${INSTALL_DATA} ${WRKDIR}/docs/IOzone_ps.gz ${PREFIX}/share/doc/IOzone
|
||||
${INSTALL_DATA} ${WRKDIR}/docs/Iozone_ps.gz ${PREFIX}/share/doc/IOzone
|
||||
|
||||
benchmark:
|
||||
@(cd ${WRKSRC}; ./iozone -Ea | tee iozone.out)
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2001/10/31 23:45:25 zuntum Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2003/03/10 11:06:50 wiz Exp $
|
||||
bin/iozone
|
||||
man/man1/iozone.1
|
||||
share/doc/IOzone/IOzone_ps.gz
|
||||
share/doc/IOzone/Iozone_ps.gz
|
||||
@dirrm share/doc/IOzone
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.3 2001/07/16 22:04:55 garbled Exp $
|
||||
$NetBSD: distinfo,v 1.4 2003/03/10 11:06:50 wiz Exp $
|
||||
|
||||
SHA1 (iozone3_56.tar) = 360485a61c7477332414e77f1b989128d9eab075
|
||||
Size (iozone3_56.tar) = 1013760 bytes
|
||||
SHA1 (patch-aa) = 5075a54d837e084a5eebec7df768943160e3da0e
|
||||
SHA1 (patch-ab) = a0c468b83751c4bde2aea6b0dd5e0ff6a2376dc0
|
||||
SHA1 (iozone3_161.tar) = 9920b4b06761800783ad2b795c157f9249852e34
|
||||
Size (iozone3_161.tar) = 1372160 bytes
|
||||
SHA1 (patch-aa) = 1ddc60958a4017dc6bdf546215d2970e336aa604
|
||||
|
|
|
@ -1,126 +1,37 @@
|
|||
$NetBSD: patch-aa,v 1.2 2001/07/16 22:04:55 garbled Exp $
|
||||
--- iozone.c.orig Wed Jul 4 03:21:12 2001
|
||||
+++ iozone.c Mon Jul 16 11:58:10 2001
|
||||
@@ -307,9 +307,17 @@
|
||||
#endif
|
||||
|
||||
#ifdef HAVE_PREAD
|
||||
+#ifndef __NetBSD__
|
||||
#include <sys/puio.h>
|
||||
#define PVECMAX 16
|
||||
struct piovec piov[PVECMAX];
|
||||
+#else
|
||||
+#include <sys/uio.h>
|
||||
+#define piov_base iov_base
|
||||
+#define piov_len iov_len
|
||||
+#define PVECMAX 16
|
||||
+struct iovec piov[PVECMAX];
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
struct child_stats {
|
||||
@@ -393,7 +401,11 @@
|
||||
#ifdef HAVE_PREAD
|
||||
#include <sys/times.h>
|
||||
#define CONTROL_STRING1 "%16lld%8ld%8ld%8ld%8ld%8ld%8ld%8ld%8ld%8ld%8ld%8ld%8ld%9ld%9ld%8ld%10ld%9ld%10ld%9ld%10ld%10ld%9ld\n"
|
||||
+#ifdef HAVE_PREADV
|
||||
#define CONTROL_STRING2 "%16s%8s%8s%8s%8s%10s%8s%8s%8s%8s%8s%9s%9s%8s%9s%8s%9s%7s%10s%10s%10s%9s%9s\n"
|
||||
+#else
|
||||
+#define CONTROL_STRING2 "%16s%8s%8s%8s%8s%10s%8s%8s%8s%8s%8s%9s%9s%8s%9s%8s%9s%7s%10s\n"
|
||||
+#endif
|
||||
#define CONTROL_STRING3 "%16s%8s%8s%8s%8s%10s%8s%8s%8s%8s%8s%9s%9s%8s%9s\n"
|
||||
#define CONTROL_STRING4 "%16s%8s%8s%8s%8s%10s\n"
|
||||
$NetBSD: patch-aa,v 1.3 2003/03/10 11:06:50 wiz Exp $
|
||||
|
||||
--- iozone.c.orig Mon Mar 3 20:44:39 2003
|
||||
+++ iozone.c
|
||||
@@ -831,7 +831,7 @@ void purgeit(); /* Purge on chip cache
|
||||
void throughput_test(); /* Multi process throughput */
|
||||
void multi_throughput_test(); /* Multi process throughput */
|
||||
void prepage(); /* Pre-fault user buffer */
|
||||
-#if defined(linux) || defined(solaris) || defined(__AIX__) || defined(OSFV5) || defined(UWIN) || defined(Windows) || defined(__APPLE__) || defined(OSFV4) || defined(IRIX) || defined(IRIX64) || defined(__FreeBSD__)
|
||||
+#ifdef HAVE_ANSIC_C
|
||||
float do_compute(float); /* compute cycle simulation */
|
||||
#else
|
||||
@@ -452,9 +464,11 @@
|
||||
void read_stride_perf_test(); /* read with stride test */
|
||||
#ifdef HAVE_PREAD
|
||||
void pread_perf_test(); /* pread/re-pread test */
|
||||
-void preadv_perf_test(); /* preadv/re-preadv test */
|
||||
void pwrite_perf_test(); /* pwrite/re-pwrite test */
|
||||
+#ifdef HAVE_PREADV
|
||||
+void preadv_perf_test(); /* preadv/re-preadv test */
|
||||
void pwritev_perf_test(); /* pwritev/re-pwritev test */
|
||||
+#endif
|
||||
#endif /* HAVE_PREAD */
|
||||
void store_dvalue(); /* Store doubles array */
|
||||
void dump_excel();
|
||||
@@ -538,9 +552,12 @@
|
||||
#ifdef HAVE_PREAD
|
||||
,
|
||||
pwrite_perf_test,
|
||||
- pread_perf_test,
|
||||
+ pread_perf_test
|
||||
+#ifdef HAVE_PREADV
|
||||
+ ,
|
||||
pwritev_perf_test,
|
||||
preadv_perf_test
|
||||
+#endif
|
||||
#endif /* HAVE_PREAD */
|
||||
};
|
||||
|
||||
@@ -5949,6 +5966,7 @@
|
||||
#endif
|
||||
}
|
||||
|
||||
+#ifdef HAVE_PREADV
|
||||
/************************************************************************/
|
||||
/* pwritev_perf_test */
|
||||
/* pwritev and re-pwritev test */
|
||||
@@ -5965,7 +5983,11 @@
|
||||
double starttime1;
|
||||
double pwritevtime[2];
|
||||
double compute_val = (double)0;
|
||||
+#ifndef __NetBSD__
|
||||
long long list_off[PVECMAX];
|
||||
+#else
|
||||
+ off_t list_off[PVECMAX];
|
||||
+#endif
|
||||
long long numvecs,j,xx;
|
||||
unsigned long long pwritevrate[2];
|
||||
off64_t filebytes64,i;
|
||||
@@ -6091,8 +6113,8 @@
|
||||
(caddr_t)(buffer+(xx * reclen));
|
||||
if(verify)
|
||||
fill_buffer(piov[xx].piov_base,reclen,(long long)pattern,sverify);
|
||||
- piov[xx].piov_len = reclen;
|
||||
piov[xx].piov_offset = list_off[xx];
|
||||
+ piov[xx].piov_len = reclen;
|
||||
if(purge)
|
||||
purgeit(piov[xx].piov_base,reclen);
|
||||
float do_compute(); /* compute cycle simulation */
|
||||
@@ -15024,6 +15024,7 @@ int flag, prot;
|
||||
* a file that is opened with O_DIRECT
|
||||
*/
|
||||
file_flags=fcntl(fd,F_GETFL);
|
||||
+#if 0
|
||||
if((file_flags & O_DIRECT) !=0)
|
||||
{
|
||||
recs=filebytes/reclen;
|
||||
@@ -15038,6 +15039,7 @@ int flag, prot;
|
||||
}
|
||||
@@ -6361,6 +6383,7 @@
|
||||
fflush(stdout);
|
||||
#endif
|
||||
}
|
||||
+#endif /* PREADV */
|
||||
|
||||
/************************************************************************/
|
||||
/* print_header() */
|
||||
@@ -6419,11 +6442,14 @@
|
||||
"pwrite",
|
||||
"repwrite",
|
||||
"pread",
|
||||
- "repread",
|
||||
+ "repread"
|
||||
+#ifdef HAVE_PREADV
|
||||
+ ,
|
||||
"pwritev",
|
||||
"repwritev",
|
||||
"preadv",
|
||||
"repreadv"
|
||||
+#endif
|
||||
);
|
||||
}else
|
||||
if(RWONLYflag){ /*kcollins 8-21-96*/
|
||||
@@ -6779,7 +6805,11 @@
|
||||
#endif
|
||||
exit(119);
|
||||
}
|
||||
+#ifndef __NetBSD__
|
||||
addr = (char *)shmat(shmid, 0, SHM_W);
|
||||
}
|
||||
else
|
||||
+#else
|
||||
+ addr = (char *)shmat(shmid, 0, 0);
|
||||
{
|
||||
/* Save time, just seek out and touch at the end */
|
||||
I_LSEEK(fd,(filebytes-reclen),SEEK_SET);
|
||||
@@ -15048,6 +15050,7 @@ int flag, prot;
|
||||
exit(181);
|
||||
}
|
||||
}
|
||||
+#endif
|
||||
#ifdef __LP64__
|
||||
if((long long)addr == (long long)-1)
|
||||
#else
|
||||
free(stmp);
|
||||
I_LSEEK(fd,0,SEEK_SET);
|
||||
#endif
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2001/07/16 22:04:55 garbled Exp $
|
||||
--- makefile.orig Mon Jul 16 02:00:14 2001
|
||||
+++ makefile Mon Jul 16 02:01:06 2001
|
||||
@@ -320,7 +320,7 @@
|
||||
|
||||
netbsd: iozone_netbsd.o libbif.o
|
||||
cc -O -Dunix -Dbsd4_4 -DHAVE_ANSIC_C -DNO_THREADS -DSHARED_MEM \
|
||||
- iozone_netbsd.o libbif.o -o iozone
|
||||
+ -DHAVE_PREAD iozone_netbsd.o libbif.o -o iozone
|
||||
|
||||
#
|
||||
#
|
||||
@@ -656,7 +656,7 @@
|
||||
@echo ""
|
||||
@echo "Building iozone NetBSD "
|
||||
@echo ""
|
||||
- cc -c -O -Dunix -Dbsd4_4 -DHAVE_ANSIC_C -DNO_THREADS \
|
||||
+ cc -c -O -Dunix -Dbsd4_4 -DHAVE_ANSIC_C -DNO_THREADS -DHAVE_PREAD \
|
||||
-DSHARED_MEM iozone.c -o iozone_netbsd.o
|
||||
- cc -c -O -Dunix -Dbsd4_4 -DHAVE_ANSIC_C -DNO_THREADS \
|
||||
+ cc -c -O -Dunix -Dbsd4_4 -DHAVE_ANSIC_C -DNO_THREADS -DHAVE_PREAD \
|
||||
-DSHARED_MEM libbif.c -o libbif.o
|
Loading…
Reference in a new issue