Ensure that len does not shadow a parameter of the same name.

Don't use __sighandler_t at all, it is not standard and at least on
DrgaonFly means something completely different.  Also change the typedef
to match what signal actually expects. Fix some more minor glitches
for DragonFly.
This commit is contained in:
joerg 2006-06-14 14:34:10 +00:00
parent 58aeedf614
commit b0505dab46
4 changed files with 73 additions and 21 deletions

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.3 2006/06/14 09:07:45 rillig Exp $
$NetBSD: distinfo,v 1.4 2006/06/14 14:34:10 joerg Exp $
SHA1 (xfrac310.zip) = 420de4ca20623b4fe6b6367a269e5525b6bff3af
RMD160 (xfrac310.zip) = ede481d77f8f5b71a6cef9d7ec4b2e09d9662f5b
Size (xfrac310.zip) = 1074760 bytes
SHA1 (patch-aa) = e5aa3ca9908871fbf59a7b0eee6be5c53c4b1a2e
SHA1 (patch-aa) = 43815e2af79a7b438992169fa5f0b9afe30d9b2e
SHA1 (patch-af) = d95099b13cdef7421fd09be09627e4db5646e948
SHA1 (patch-ag) = db99fc9b6753bd5a4256a6275a4493bc67cd09a1
SHA1 (patch-ag) = bf0ce10e27b29022890bc292daf72a09974a3aa0
SHA1 (patch-ah) = f0599bb9f59921938784a866d27205abaef6a964
SHA1 (patch-ai) = e6b4ef5637cc8d05d6dd9b0f1e098d51bc692310
SHA1 (patch-aj) = 578a8a0dcff9021f65bd5368ae8232c89a325081
@ -13,6 +13,6 @@ SHA1 (patch-ak) = 2d128d7575070d3452702f219aa51c468928f38a
SHA1 (patch-al) = 1954f3243be20ceb03c0e9d6dba86c2fd101ce89
SHA1 (patch-am) = ae214e36ff64009d18724e80638f1fa55544d19e
SHA1 (patch-an) = 5c4728b4d4ffa4ddd1ff904943af1484d75308f1
SHA1 (patch-ao) = a432f9dbea726fe91c84ea77b246a3985e58108d
SHA1 (patch-ao) = c4c7f6d73f04a8a31503d84ca4ab4a2a64b7a9cd
SHA1 (patch-ap) = 87f6bc9db67554f600428e3369f83849b81d23fa
SHA1 (patch-aq) = 8202b8a7adc3e3badee6de0b395d912910aa6710

View file

@ -1,17 +1,55 @@
$NetBSD: patch-aa,v 1.2 2006/06/14 09:07:45 rillig Exp $
$NetBSD: patch-aa,v 1.3 2006/06/14 14:34:10 joerg Exp $
Some systems do not define __sighandler_t.
--- unixscr.c.orig 1999-04-29 06:12:03.000000000 +0200
+++ unixscr.c 2006-06-15 08:43:15.000000000 +0200
@@ -44,6 +44,10 @@
--- unixscr.c.orig 1999-04-29 04:12:03.000000000 +0000
+++ unixscr.c
@@ -44,6 +44,8 @@
# define FNDELAY O_NONBLOCK
#endif
+#if defined(__sun) || defined(__NetBSD__)
+typedef int (*__sighandler_t)(int);
+#endif
+typedef void (*sighandler_t)(int);
+
/* Check if there is a character waiting for us. */
#define input_pending() (ioctl(0,FIONREAD,&iocount),(int)iocount)
@@ -241,7 +243,7 @@ UnixInit()
initdacbox();
if (!simple_input) {
- signal(SIGINT,(__sighandler_t)goodbye);
+ signal(SIGINT,(sighandler_t)goodbye);
}
signal(SIGFPE, fpe_handler);
/*
@@ -2068,12 +2070,12 @@ xgetfont()
void
shell_to_dos()
{
- __sighandler_t sigint;
+ sighandler_t sigint;
char *shell;
char *argv[2];
int pid, donepid;
- sigint = (__sighandler_t)signal(SIGINT, SIG_IGN);
+ sigint = (sighandler_t)signal(SIGINT, SIG_IGN);
shell = getenv("SHELL");
if (shell==NULL) {
shell = SHELL;
@@ -2121,7 +2123,7 @@ shell_to_dos()
fcntl(0,F_SETFL,FNDELAY);
}
- signal(SIGINT, (__sighandler_t)sigint);
+ signal(SIGINT, (sighandler_t)sigint);
putchar('\n');
}
@@ -2146,7 +2148,7 @@ schedulealarm(soon)
int soon;
{
if (!fastmode) return;
- signal(SIGALRM, (__sighandler_t)setredrawscreen);
+ signal(SIGALRM, (sighandler_t)setredrawscreen);
if (soon) {
alarm(1);
} else {

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ag,v 1.1 2006/06/14 09:07:45 rillig Exp $
$NetBSD: patch-ag,v 1.2 2006/06/14 14:34:10 joerg Exp $
--- fracsubr.c.orig 2006-06-15 07:57:40.000000000 +0200
+++ fracsubr.c 2006-06-15 08:30:43.000000000 +0200
--- fracsubr.c.orig 1999-09-06 15:38:10.000000000 +0000
+++ fracsubr.c
@@ -3,12 +3,15 @@ FRACSUBR.C contains subroutines which be
FRACTALS.C, i.e. which are non-fractal-specific fractal engine subroutines.
*/
@ -29,7 +29,14 @@ $NetBSD: patch-ag,v 1.1 2006/06/14 09:07:45 rillig Exp $
int put_resume(int len, ...)
#else
int put_resume(va_alist)
@@ -1065,7 +1068,7 @@ va_dcl
@@ -1059,13 +1062,13 @@ va_dcl
{
va_list arg_marker; /* variable arg list */
BYTE *source_ptr;
-#ifdef XFRACT
+#if defined(USE_VARARGS)
int len;
#endif
if (resume_info == 0)
return(-1);
@ -47,7 +54,14 @@ $NetBSD: patch-ag,v 1.1 2006/06/14 09:07:45 rillig Exp $
int get_resume(int len, ...)
#else
int get_resume(va_alist)
@@ -1116,7 +1119,7 @@ va_dcl
@@ -1110,13 +1113,13 @@ va_dcl
{
va_list arg_marker; /* variable arg list */
BYTE *dest_ptr;
-#ifdef XFRACT
+#if defined(USE_VARARGS)
int len;
#endif
if (resume_info == 0)
return(-1);

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ao,v 1.1 2006/06/14 09:07:45 rillig Exp $
$NetBSD: patch-ao,v 1.2 2006/06/14 14:34:10 joerg Exp $
--- port.h.orig 1999-09-06 17:38:10.000000000 +0200
+++ port.h 2006-06-15 08:52:47.000000000 +0200
@ -7,7 +7,7 @@ $NetBSD: patch-ao,v 1.1 2006/06/14 09:07:45 rillig Exp $
/* but if you have this file, it can make it more fool proof. */
#if (defined(XFRACT) && !defined(__sun))
-#if defined(sgi)
+#if defined(sgi) || defined(__NetBSD__)
+#if defined(sgi) || defined(__NetBSD__) || defined(__DragonFly__)
#include <sys/endian.h>
#else
#include <endian.h>
@ -15,7 +15,7 @@ $NetBSD: patch-ao,v 1.1 2006/06/14 09:07:45 rillig Exp $
#ifdef sun
#define DO_NOT_USE_LONG_DOUBLE
#endif
+#if defined(__NetBSD__)
+#if defined(__NetBSD__) || defined(__DragonFly__)
+#define DO_NOT_USE_LONG_DOUBLE
+#endif