Added two patches for ISO C90 compatibility.
This commit is contained in:
parent
9dde5e89c7
commit
b0604c3d75
3 changed files with 38 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.15 2005/10/16 12:12:01 jmmv Exp $
|
||||
$NetBSD: distinfo,v 1.16 2005/12/18 22:23:56 rillig Exp $
|
||||
|
||||
SHA1 (gnopernicus-0.11.7.tar.bz2) = 1e8cb6a8c9b4ed900fe033ba4fd6a2568d22e742
|
||||
RMD160 (gnopernicus-0.11.7.tar.bz2) = ab6246174377d78abd85f2b2b982cb68a906effc
|
||||
|
@ -6,3 +6,5 @@ Size (gnopernicus-0.11.7.tar.bz2) = 2183962 bytes
|
|||
SHA1 (patch-ab) = d17ba1a57ad795f018bd224444c987b9e0c57b16
|
||||
SHA1 (patch-ac) = 29fbb4e5c0a71d86f288cdbf21320775abbc104f
|
||||
SHA1 (patch-ad) = 606a16934f173a10897d3297b099342244169d24
|
||||
SHA1 (patch-ae) = ff936ff26a260138f438842260cdbac6d869d21f
|
||||
SHA1 (patch-af) = 2cbe6f4bed223ecf0f7c88249e47fee515bd0390
|
||||
|
|
17
x11/gnopernicus/patches/patch-ae
Normal file
17
x11/gnopernicus/patches/patch-ae
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-ae,v 1.3 2005/12/18 22:23:56 rillig Exp $
|
||||
|
||||
Keywords: c90
|
||||
|
||||
--- srcore/srspc.c.orig Mon Aug 22 14:08:02 2005
|
||||
+++ srcore/srspc.c Sun Dec 18 23:07:08 2005
|
||||
@@ -1536,8 +1536,9 @@ src_timeout_start_speech (gpointer data)
|
||||
static void
|
||||
src_restart_speech ()
|
||||
{
|
||||
- g_printerr ("\nRestarting speech.\n");
|
||||
gboolean use_speech = FALSE;
|
||||
+
|
||||
+ g_printerr ("\nRestarting speech.\n");
|
||||
SET_SRCORE_CONFIG_DATA (SRCORE_SPEECH_ACTIVE, CFGT_BOOL, &use_speech);
|
||||
speech_timeout_id = g_timeout_add (SRC_SPEECH_RESTART_TIMEOUT, src_timeout_start_speech, NULL);
|
||||
}
|
18
x11/gnopernicus/patches/patch-af
Normal file
18
x11/gnopernicus/patches/patch-af
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-af,v 1.3 2005/12/18 22:23:56 rillig Exp $
|
||||
|
||||
Keywords: c90
|
||||
|
||||
--- srlow/libsrlow/SRLow.c.orig Mon Jul 25 16:21:54 2005
|
||||
+++ srlow/libsrlow/SRLow.c Sun Dec 18 23:00:29 2005
|
||||
@@ -666,8 +666,10 @@ srl_get_focused_cell (Accessible *acc_ta
|
||||
for (i = rows; !rv && i <= rowe && count < SRL_MAX_CHILDREN_CNT; i++)
|
||||
for (j = cols; !rv && j <= cole && count < SRL_MAX_CHILDREN_CNT; j++)
|
||||
{
|
||||
+ Accessible *cell;
|
||||
+
|
||||
count++;
|
||||
- Accessible *cell = AccessibleTable_getAccessibleAt (table, i, j);
|
||||
+ cell = AccessibleTable_getAccessibleAt (table, i, j);
|
||||
if (cell)
|
||||
{
|
||||
if (srl_acc_has_state (cell, SPI_STATE_FOCUSED))
|
Loading…
Reference in a new issue