Update to 2.1:
Changes between 0.2.0 and 0.2.1: -------------------------------- * ignore initial discontinuity * Build fixes for BSD builds * Build fixes for MSYS builds Changes between 0.1.7 and 0.2.0: -------------------------------- * Relicense libdvbpsi from GPLv2 to LGPLv2.1 * bump version number to 0.2.0 (skipping 0.1.8 and 0.1.9) to indicate GPL -> LGPL license change * new CUE Identifier descriptor support (0x8a) * new Splice Information Section table support (0xFC) (SCTE 35 2004) * new BAT table (decoder and generator) * new descriptor 0x44 * depreceated all API's in preparation for 1.0.0 release with revamped API packagers and application developers should anticipate: - structure renames dvbpsi_handle to dvbpsi_t - prototype changes - removal of printf for message printing - message callback function For more information see changes in libdvbpsi-ng branch.
This commit is contained in:
parent
0357752505
commit
b0aef575ff
5 changed files with 21 additions and 17 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.10 2011/02/28 14:52:57 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2011/09/08 21:10:26 wiz Exp $
|
||||
|
||||
DISTNAME= libdvbpsi-0.1.7
|
||||
DISTNAME= libdvbpsi-0.2.1
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://www.videolan.org/pub/libdvbpsi/${PKGVERSION_NOREV}/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -8,7 +8,7 @@ EXTRACT_SUFX= .tar.bz2
|
|||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.videolan.org/
|
||||
COMMENT= PSI decoder and generator library for MPEG2 and DVB streams
|
||||
LICENSE= gnu-gpl-v2
|
||||
LICENSE= gnu-lgpl-v2.1
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
|
|
|
@ -1,4 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2010/11/04 19:43:32 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.6 2011/09/08 21:10:26 wiz Exp $
|
||||
include/dvbpsi/bat.h
|
||||
include/dvbpsi/cat.h
|
||||
include/dvbpsi/demux.h
|
||||
include/dvbpsi/descriptor.h
|
||||
|
@ -19,6 +20,7 @@ include/dvbpsi/dr_0e.h
|
|||
include/dvbpsi/dr_0f.h
|
||||
include/dvbpsi/dr_42.h
|
||||
include/dvbpsi/dr_43.h
|
||||
include/dvbpsi/dr_44.h
|
||||
include/dvbpsi/dr_45.h
|
||||
include/dvbpsi/dr_47.h
|
||||
include/dvbpsi/dr_48.h
|
||||
|
@ -31,6 +33,7 @@ include/dvbpsi/dr_58.h
|
|||
include/dvbpsi/dr_59.h
|
||||
include/dvbpsi/dr_5a.h
|
||||
include/dvbpsi/dr_69.h
|
||||
include/dvbpsi/dr_8a.h
|
||||
include/dvbpsi/dvbpsi.h
|
||||
include/dvbpsi/eit.h
|
||||
include/dvbpsi/nit.h
|
||||
|
@ -38,6 +41,7 @@ include/dvbpsi/pat.h
|
|||
include/dvbpsi/pmt.h
|
||||
include/dvbpsi/psi.h
|
||||
include/dvbpsi/sdt.h
|
||||
include/dvbpsi/sis.h
|
||||
include/dvbpsi/tot.h
|
||||
lib/libdvbpsi.la
|
||||
lib/pkgconfig/libdvbpsi.pc
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.4 2010/11/04 19:43:32 adam Exp $
|
||||
$NetBSD: distinfo,v 1.5 2011/09/08 21:10:26 wiz Exp $
|
||||
|
||||
SHA1 (libdvbpsi-0.1.7.tar.bz2) = 4fc21425068a42daf6b261b413e0107cc67fb37c
|
||||
RMD160 (libdvbpsi-0.1.7.tar.bz2) = 0ce91c22e8a6abf01f75c719951b524bd31c87ff
|
||||
Size (libdvbpsi-0.1.7.tar.bz2) = 308173 bytes
|
||||
SHA1 (patch-aa) = 50ac67f20b06b8c9ebeef0140e279085df9164af
|
||||
SHA1 (patch-ab) = 462d926b4f78a20502f4bb6fb70302e85556ecc6
|
||||
SHA1 (libdvbpsi-0.2.1.tar.bz2) = 75c42de1cb391a65f8d41c72d39ce6968de48b63
|
||||
RMD160 (libdvbpsi-0.2.1.tar.bz2) = 1e8ab8835a5873d5a5d198c7574a227bd3026776
|
||||
Size (libdvbpsi-0.2.1.tar.bz2) = 330137 bytes
|
||||
SHA1 (patch-aa) = dc8c3b5a99e5e6dd73f0d0461e0924bcbdfbeb7d
|
||||
SHA1 (patch-ab) = eea9e53dac6982d1681ccd005960ceef3a0d74e8
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
$NetBSD: patch-aa,v 1.2 2010/11/04 19:43:33 adam Exp $
|
||||
$NetBSD: patch-aa,v 1.3 2011/09/08 21:10:26 wiz Exp $
|
||||
|
||||
--- examples/connect.c.orig 2008-09-17 09:39:35.000000000 +0000
|
||||
--- examples/connect.c.orig 2011-05-19 13:04:02.000000000 +0000
|
||||
+++ examples/connect.c
|
||||
@@ -38,7 +38,7 @@
|
||||
# include <netinet/if_ether.h>
|
||||
#endif
|
||||
#include <netdb.h>
|
||||
-#ifndef __FreeBSD__
|
||||
-#ifndef BSD
|
||||
+#if !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__DragonFly__)
|
||||
# include <netinet/ip.h>
|
||||
#endif
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.1 2010/11/04 19:43:33 adam Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2011/09/08 21:10:26 wiz Exp $
|
||||
|
||||
--- configure.orig 2010-11-04 09:06:29.000000000 +0000
|
||||
--- configure.orig 2011-09-01 08:45:08.000000000 +0000
|
||||
+++ configure
|
||||
@@ -11226,8 +11226,6 @@ fi
|
||||
@@ -11643,8 +11643,6 @@ fi
|
||||
if test "$release" = "true"
|
||||
then
|
||||
CFLAGS="${CFLAGS} -O6"
|
||||
|
@ -10,4 +10,4 @@ $NetBSD: patch-ab,v 1.1 2010/11/04 19:43:33 adam Exp $
|
|||
- CFLAGS="${CFLAGS} -O2"
|
||||
fi
|
||||
|
||||
|
||||
for ac_header in stdint.h inttypes.h
|
||||
|
|
Loading…
Reference in a new issue