Updated to OpenLDAP-1.2.7 release.
This commit is contained in:
parent
3dc14856ae
commit
b0be95c9fc
6 changed files with 66 additions and 65 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.10 1999/08/18 09:28:01 agc Exp $
|
||||
# $NetBSD: Makefile,v 1.11 1999/09/10 10:41:39 hwr Exp $
|
||||
#
|
||||
|
||||
DISTNAME= openldap-1.2.1
|
||||
PKGNAME= openldap-1.2.1p1
|
||||
DISTNAME= openldap-1.2.7
|
||||
PKGNAME= openldap-1.2.7p1
|
||||
WRKSRC= ${WRKDIR}/ldap
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.5 1999/04/01 15:25:02 hwr Exp $
|
||||
$NetBSD: md5,v 1.6 1999/09/10 10:41:40 hwr Exp $
|
||||
|
||||
MD5 (openldap-1.2.1.tgz) = f0862c4aa358dd24bc6eafe3e5e4f3f7
|
||||
MD5 (openldap-1.2.7.tgz) = be5866cfa50fdf083f5230b3837181e8
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-sum,v 1.1 1999/07/09 13:50:30 agc Exp $
|
||||
$NetBSD: patch-sum,v 1.2 1999/09/10 10:41:40 hwr Exp $
|
||||
|
||||
MD5 (patch-aa) = 8fe7e98213578f80f5c5e4713c321143
|
||||
MD5 (patch-ab) = ecf93de09c0393ca7ce3e2799e5dfdc9
|
||||
MD5 (patch-aa) = e0cc168bd80d56f1fc5c778be0260f8b
|
||||
MD5 (patch-ab) = 92550b6ef0e556cba008d38079e8f1e9
|
||||
|
|
|
@ -1,21 +1,21 @@
|
|||
$NetBSD: patch-aa,v 1.1 1999/05/04 00:08:43 tv Exp $
|
||||
$NetBSD: patch-aa,v 1.2 1999/09/10 10:41:41 hwr Exp $
|
||||
|
||||
--- configure.orig Mon May 3 18:51:06 1999
|
||||
+++ configure Mon May 3 18:51:24 1999
|
||||
@@ -2067,6 +2067,7 @@
|
||||
echo "$ac_t""no" 1>&6
|
||||
fi
|
||||
--- configure.orig Wed Aug 25 20:39:37 1999
|
||||
+++ configure Fri Sep 10 12:11:36 1999
|
||||
@@ -2318,6 +2318,7 @@
|
||||
# Save cache, so that ltconfig can load it
|
||||
|
||||
|
||||
+if false; then
|
||||
# Actually configure libtool. ac_aux_dir is where install-sh is found.
|
||||
CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
|
||||
LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
|
||||
@@ -2335,6 +2336,8 @@
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
|
||||
@@ -2112,7 +2113,7 @@
|
||||
${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig \
|
||||
$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $host \
|
||||
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
|
||||
-
|
||||
+
|
||||
+fi
|
||||
|
||||
# Extract the first word of "sendmail", so it can be a program name with args.
|
||||
set dummy sendmail; ac_word=$2
|
||||
# Redirect the config.log output again, so that the ltconfig log is not
|
||||
# clobbered by the next message.
|
||||
|
|
|
@ -1,19 +1,20 @@
|
|||
$NetBSD: patch-ab,v 1.1 1999/05/04 00:08:43 tv Exp $
|
||||
$NetBSD: patch-ab,v 1.2 1999/09/10 10:41:41 hwr Exp $
|
||||
|
||||
--- build/lib-shared.mk.orig Mon May 3 19:21:39 1999
|
||||
+++ build/lib-shared.mk Mon May 3 19:24:56 1999
|
||||
@@ -18,9 +18,10 @@
|
||||
--- build/lib-shared.mk.orig Fri Jul 23 17:31:32 1999
|
||||
+++ build/lib-shared.mk Fri Sep 10 12:19:58 1999
|
||||
@@ -16,9 +16,11 @@
|
||||
|
||||
$(LIBRARY): version.lo
|
||||
$(LINK) -rpath $(libdir) -o $@ $(OBJS) version.lo
|
||||
$(LTLIBLINK) -rpath $(libdir) -o $@ $(OBJS) version.lo
|
||||
- $(RM) ../$@; \
|
||||
- (d=`$(PWD)` ; $(LN_S) `$(BASENAME) $$d`/$@ ../$@)
|
||||
- $(RM) ../`$(BASENAME) $@ .la`.a; \
|
||||
- (d=`$(PWD)`; t=`$(BASENAME) $@ .la`.a; $(LN_S) `$(BASENAME) $$d`/.libs/$$t ../$$t)
|
||||
+ @$(RM) ../$@
|
||||
+ @for ext in a so so.1.0; do \
|
||||
+ $(RM) ../`$(BASENAME) $@ .la`.$$ext; \
|
||||
+ $(RM) ../`$(BASENAME) $@ .la`.$$ext; \
|
||||
+ (d=`$(PWD)`; t=`$(BASENAME) $@ .la`.$$ext; $(LN_S) `$(BASENAME) $$d`/.libs/$$t ../$$t); \
|
||||
+ done
|
||||
+ done
|
||||
+
|
||||
|
||||
Makefile: $(top_srcdir)/build/lib-shared.mk
|
||||
|
|
|
@ -1,49 +1,21 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 1999/05/04 00:08:44 tv Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 1999/09/10 10:41:41 hwr Exp $
|
||||
bin/ud
|
||||
bin/ldapsearch
|
||||
bin/ldapmodify
|
||||
bin/ldapdelete
|
||||
bin/ldapmodrdn
|
||||
bin/ldapadd
|
||||
bin/ldappasswd
|
||||
bin/ud
|
||||
etc/openldap/ldap.conf.default
|
||||
@exec [ -f %B/ldap.conf ] || cp %D/%F %B/ldap.conf
|
||||
etc/openldap/ldapfilter.conf.default
|
||||
@exec [ -f %B/ldapfilter.conf ] || cp %D/%F %B/ldapfilter.conf
|
||||
etc/openldap/ldaptemplates.conf.default
|
||||
@exec [ -f %B/ldaptemplates.conf ] || cp %D/%F %B/ldaptemplates.conf
|
||||
etc/openldap/ldapsearchprefs.conf.default
|
||||
@exec [ -f %B/ldapsearchprefs.conf ] || cp %D/%F %B/ldapsearchprefs.conf
|
||||
etc/openldap/slapd.conf.default
|
||||
@exec [ -f %B/slapd.conf ] || cp %D/%F %B/slapd.conf
|
||||
etc/openldap/slapd.at.conf.default
|
||||
@exec [ -f %B/slapd.at.conf ] || cp %D/%F %B/slapd.at.conf
|
||||
etc/openldap/slapd.oc.conf.default
|
||||
@exec [ -f %B/slapd.oc.conf ] || cp %D/%F %B/slapd.oc.conf
|
||||
include/ldap.h
|
||||
include/lber.h
|
||||
include/ldap_cdefs.h
|
||||
include/disptmpl.h
|
||||
include/srchpref.h
|
||||
lib/liblber.a
|
||||
bin/ldapadd
|
||||
lib/liblber.so.1.0
|
||||
lib/libldap.a
|
||||
lib/liblber.a
|
||||
lib/libldap.so.1.0
|
||||
libexec/in.xfingerd
|
||||
libexec/go500
|
||||
libexec/go500gw
|
||||
libexec/mail500
|
||||
libexec/rp500
|
||||
libexec/fax500
|
||||
libexec/xrpcomp
|
||||
libexec/rcpt500
|
||||
libexec/slapd
|
||||
lib/libldap.a
|
||||
man/man1/ldapadd.1
|
||||
man/man1/ldapdelete.1
|
||||
man/man1/ldapmodify.1
|
||||
man/man1/ldapadd.1
|
||||
man/man1/ldapmodrdn.1
|
||||
man/man1/ldapsearch.1
|
||||
man/man1/ldappasswd.1
|
||||
man/man1/ldapsearch.1
|
||||
man/man1/ud.1
|
||||
man/man3/ldap.3
|
||||
man/man3/cldap.3
|
||||
|
@ -203,11 +175,39 @@ man/man8/fax500.8
|
|||
man/man8/rcpt500.8
|
||||
man/man8/slapd.8
|
||||
man/man8/slurpd.8
|
||||
@exec [ -f %B/ldap.conf ] || cp %D/%F %B/ldap.conf
|
||||
etc/openldap/ldap.conf.default
|
||||
@exec [ -f %B/ldapfilter.conf ] || cp %D/%F %B/ldapfilter.conf
|
||||
etc/openldap/ldapfilter.conf.default
|
||||
@exec [ -f %B/ldaptemplates.conf ] || cp %D/%F %B/ldaptemplates.conf
|
||||
etc/openldap/ldaptemplates.conf.default
|
||||
@exec [ -f %B/ldapsearchprefs.conf ] || cp %D/%F %B/ldapsearchprefs.conf
|
||||
etc/openldap/ldapsearchprefs.conf.default
|
||||
@exec [ -f %B/slapd.conf ] || cp %D/%F %B/slapd.conf
|
||||
etc/openldap/slapd.conf.default
|
||||
@exec [ -f %B/slapd.at.conf ] || cp %D/%F %B/slapd.at.conf
|
||||
etc/openldap/slapd.at.conf.default
|
||||
@exec [ -f %B/slapd.oc.conf ] || cp %D/%F %B/slapd.oc.conf
|
||||
etc/openldap/slapd.oc.conf.default
|
||||
include/ldap.h
|
||||
include/lber.h
|
||||
include/ldap_cdefs.h
|
||||
include/disptmpl.h
|
||||
include/srchpref.h
|
||||
libexec/in.xfingerd
|
||||
libexec/go500
|
||||
libexec/go500gw
|
||||
libexec/mail500
|
||||
libexec/rp500
|
||||
libexec/fax500
|
||||
libexec/xrpcomp
|
||||
libexec/rcpt500
|
||||
libexec/slapd
|
||||
sbin/ldif2ldbm
|
||||
sbin/ldif2index
|
||||
sbin/ldbmcat
|
||||
sbin/ldif2id2entry
|
||||
sbin/ldif2id2children
|
||||
sbin/ldbmcat
|
||||
sbin/ldif
|
||||
sbin/centipede
|
||||
sbin/ldbmtest
|
||||
|
|
Loading…
Reference in a new issue