one more patch to get this going with sunpro compilers

This commit is contained in:
dmcmahill 2007-01-25 03:13:59 +00:00
parent abf394b00b
commit b0c52c1687
2 changed files with 30 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.31 2007/01/23 03:27:19 dmcmahill Exp $
$NetBSD: distinfo,v 1.32 2007/01/25 03:13:59 dmcmahill Exp $
SHA1 (gc6.8.tar.gz) = 6d5def5ba5d29292ba9c76f04df3ec06d3ab3278
RMD160 (gc6.8.tar.gz) = 6e894e7a51683a9342fd738baa6f1a2861e27400
@ -6,5 +6,6 @@ Size (gc6.8.tar.gz) = 756879 bytes
SHA1 (patch-aa) = 6a0795787aee08f015bcdbdd590d8e2583b5a274
SHA1 (patch-ab) = 0e8b628a023a67a7da461d4fcd22df0792e4efe3
SHA1 (patch-ac) = 64c0f042a1ed7488158d49c77bab0330537d9e96
SHA1 (patch-ad) = 42b3541bfacb8506ef681a9a9e350d986e0d9683
SHA1 (patch-ae) = e8da710ece0400136c71ee7888c0ce7f719ac660
SHA1 (patch-af) = b8505855125cd90987873e7a40f2a6b246226979

View file

@ -0,0 +1,28 @@
$NetBSD: patch-ad,v 1.23 2007/01/25 03:13:59 dmcmahill Exp $
Needed to build with the sun studio compilers
--- include/gc_cpp.h.orig 2005-12-05 19:35:14.000000000 -0500
+++ include/gc_cpp.h
@@ -212,8 +212,8 @@ extern "C" {typedef void (*GCCleanUpFunc
inline void* operator new(
size_t size,
GCPlacement gcp,
- GCCleanUpFunc cleanup = 0,
- void* clientData = 0 );
+ GCCleanUpFunc cleanup,
+ void* clientData);
/*
Allocates a collectable or uncollected object, according to the
value of "gcp".
@@ -257,8 +257,8 @@ inline void* operator new(
inline void* operator new[](
size_t size,
GCPlacement gcp,
- GCCleanUpFunc cleanup = 0,
- void* clientData = 0 );
+ GCCleanUpFunc cleanup,
+ void* clientData);
/*
The operator new for arrays, identical to the above. */