fish: Update to 3.2.1

fish 3.2.1 (released March 18, 2021)
====================================

This release of fish fixes the following problems identified in fish 3.2.0:

-  Commands in key bindings are run with fish's internal terminal modes, instead of the terminal modes typically used for commands. This fixes a bug introduced in 3.2.0, where text would unexpectedly appear on the terminal, especially when pasting (:issue:`7770`).
-  Prompts which use the internal ``__fish_print_pipestatus`` function will display correctly rather than carrying certain modifiers (such as bold) further than intended (:issue:`7771`).
-  Redirections to internal file descriptors is allowed again, reversing the changes in 3.2.0. This fixes a problem with Midnight Commander (:issue:`7769`).
-  Universal variables should be fully reliable regardless of operating system again (:issue:`7774`).
-  ``fish_git_prompt`` no longer causes screen flickering in certain terminals (:issue:`7775`).
-  ``fish_add_path`` manipulates the ``fish_user_paths`` variable correctly when moving multiple paths (:issue:`7776`).
-  Pasting with a multi-line command no longer causes a ``__fish_tokenizer_state`` error (:issue:`7782`).
-  ``psub`` inside event handlers cleans up temporary files properly (:issue:`7792`).
-  Event handlers declared with ``--on-job-exit $fish_pid`` no longer run constantly (:issue:`7721`), although these functions should use ``--on-event fish_exit`` instead.
-  Changing terminal modes inside ``config.fish`` works (:issue:`7783`).
-  ``set_color --print-colors`` no longer prints all colors in bold (:issue:`7805`)
-  Completing commands starting with a ``-`` no longer prints an error (:issue:`7809`).
-  Running ``fish_command_not_found`` directly no longer produces an error on macOS or other OSes which do not have a handler available (:issue:`7777`).
-  The new ``type`` builtin now has the (deprecated) ``--quiet`` long form of ``-q`` (:issue:`7766`).

It also includes some small enhancements:

-  ``help`` and ``fish_config`` work correctly when fish is running in a Chrome OS Crostini Linux VM (:issue:`7789`).
-  The history file can be made a symbolic link without it being overwritten (:issue:`7754`), matching a similar improvement for the universal variable file in 3.2.0.
-  An unhelpful error ("access: No error"), seen on Cygwin, is no longer produced (:issue:`7785`).
-  Improvements to the ``rsync`` completions (:issue:`7763`), some completion descriptions (:issue:`7788`), and completions that use IP address (:issue:`7787`).
-  Improvements to the appearance of ``fish_config`` (:issue:`7811`).

If you are upgrading from version 3.1.2 or before, please also review
the release notes for 3.2.0 (included below).
This commit is contained in:
nia 2021-03-19 10:19:35 +00:00
parent ca5b2a5efa
commit b0eb834277
4 changed files with 9 additions and 26 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.28 2021/03/05 08:47:29 nia Exp $
# $NetBSD: Makefile,v 1.29 2021/03/19 10:19:35 nia Exp $
DISTNAME= fish-3.2.0
DISTNAME= fish-3.2.1
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GITHUB:=fish-shell/}
GITHUB_PROJECT= fish-shell

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.10 2021/03/05 08:47:29 nia Exp $
@comment $NetBSD: PLIST,v 1.11 2021/03/19 10:19:35 nia Exp $
bin/fish
bin/fish_indent
bin/fish_key_reader
@ -14,8 +14,6 @@ share/doc/fish/_static/classic.css
share/doc/fish/_static/comment-bright.png
share/doc/fish/_static/comment-close.png
share/doc/fish/_static/comment.png
share/doc/fish/_static/copybutton.js
share/doc/fish/_static/custom.css
share/doc/fish/_static/default.css
share/doc/fish/_static/doctools.js
share/doc/fish/_static/documentation_options.js
@ -578,6 +576,7 @@ share/fish/completions/mkdosfs.fish
share/fish/completions/mkfs.fat.fish
share/fish/completions/mkfs.vfat.fish
share/fish/completions/mkinitcpio.fish
share/fish/completions/mkpasswd.fish
share/fish/completions/mktemp.fish
share/fish/completions/mkvextract.fish
share/fish/completions/mocha.fish

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.20 2021/03/05 08:47:29 nia Exp $
$NetBSD: distinfo,v 1.21 2021/03/19 10:19:35 nia Exp $
SHA1 (fish-3.2.0.tar.xz) = 26817401698aa8ccd7a115a4a251f5988f374fdb
RMD160 (fish-3.2.0.tar.xz) = bc270797b4b73292cc4d7e3b4151ea5fde228f68
SHA512 (fish-3.2.0.tar.xz) = 4525b8dd991179f77a298080d389813d1da8557bd394d174ded9238570715137e3aeec009d123811b34c07856d5f7cbe0ad35dc599d748f8f305036c3b74face
Size (fish-3.2.0.tar.xz) = 3403640 bytes
SHA1 (fish-3.2.1.tar.xz) = e5ce0e2fbdfd8d06d15af7d87fe23cfb2cc32b1b
RMD160 (fish-3.2.1.tar.xz) = 9cef0930c4e96852a4c8e8fe88d6d90972bc782d
SHA512 (fish-3.2.1.tar.xz) = bf565bac93e7d163af5253b4053f9c9e760508b929624440fd8a160504a127c34013882576293c72a47ce7f285f87e0b594d61d7cebcefcc3be4e92c572926bc
Size (fish-3.2.1.tar.xz) = 3409808 bytes
SHA1 (patch-cmake_Install.cmake) = 6ae3f511597773dfd9bf2d22c2d8dd0b60d87ae2
SHA1 (patch-src_common.cpp) = f9eac0ae02d1b034b960f9ab24c21f5be7f60fab

View file

@ -1,15 +0,0 @@
$NetBSD: patch-src_common.cpp,v 1.2 2021/03/05 08:47:29 nia Exp $
Cast to const char*, makes netbsd (const void* dli_saddr) happier.
--- src/common.cpp.orig 2021-03-01 12:47:02.000000000 +0000
+++ src/common.cpp
@@ -212,7 +212,7 @@ bool is_windows_subsystem_for_linux() {
status == 0 ? demangled
: info.dli_sname == nullptr ? symbols[i]
: info.dli_sname,
- static_cast<char *>(callstack[i]) - static_cast<char *>(info.dli_saddr));
+ static_cast<char *>(callstack[i]) - static_cast<const char *>(info.dli_saddr));
free(demangled);
} else {
swprintf(text, sizeof(text) / sizeof(wchar_t), L"%-3d %s", i - skip_levels, symbols[i]);