Import xmms-mad-0.0.9:

xmms-mad is an input plugin for xmms that uses libmad to decode MPEG
layer 1/2/3 file and streams. Current featured include:
        local mp3 file playback
        shoutchast/icecast stream playback
        seeking
        ID3 tag parsing
        http header parsing

See http://www.superduper.net/xmms-mad/ for more information.
This commit is contained in:
jmcneill 2002-05-26 04:00:50 +00:00
parent 5ac7bac9c0
commit b0f04d7505
6 changed files with 82 additions and 0 deletions

7
audio/xmms-mad/DESCR Normal file
View file

@ -0,0 +1,7 @@
xmms-mad is an input plugin for xmms that uses libmad to decode MPEG
layer 1/2/3 file and streams. Current featured include:
local mp3 file playback
shoutchast/icecast stream playback
seeking
ID3 tag parsing
http header parsing

28
audio/xmms-mad/Makefile Normal file
View file

@ -0,0 +1,28 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/05/26 04:00:50 jmcneill Exp $
#
DISTNAME= xmms-mad-0.0.9
CATEGORIES= audio
MASTER_SITES= http://www.superduper.net/downloads/xmms-mad/
MAINTAINER= jmcneill@netbsd.org
HOMEPAGE= http://www.superduper.net/xmms-mad/
COMMENT= Input plugin for XMMS that uses libmad
DEPENDS+= mad>=0.14:../../audio/mad
GNU_CONFIGURE= YES
CONFIGURE_ENV+= LDFLAGS="-Wl,-R${LOCALBASE}/lib -L${LOCALBASE}/lib"
CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include"
CPPFLAGS+= -D_POSIX_THREAD_SYSCALL_SOFT=1
.include "../../mk/bsd.prefs.mk"
.if (${OPSYS} == NetBSD)
CPPFLAGS+= -DHAVE_NANOSLEEP=1
.endif
.include "../../audio/xmms/buildlink.mk"
.include "../../mk/ossaudio.buildlink.mk"
.include "../../mk/x11.buildlink.mk"
.include "../../mk/bsd.pkg.mk"

3
audio/xmms-mad/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/05/26 04:00:51 jmcneill Exp $
lib/xmms/Input/libxmmsmad.la
lib/xmms/Input/libxmmsmad.so

6
audio/xmms-mad/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2002/05/26 04:00:50 jmcneill Exp $
SHA1 (xmms-mad-0.0.9.tar.gz) = b8743ff110ef0c61062f25cdd0f8a591f43b789c
Size (xmms-mad-0.0.9.tar.gz) = 203320 bytes
SHA1 (patch-aa) = f502b03b845cb54078c5d086f6bcf88ca8e8111f
SHA1 (patch-ab) = 556c28f55718acc0bb1178c107fa22bd120a5660

View file

@ -0,0 +1,14 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/05/26 04:00:51 jmcneill Exp $
--- src/decoder.c.orig Sat May 25 21:06:58 2002
+++ src/decoder.c Sat May 25 21:07:05 2002
@@ -205,6 +205,9 @@
/* main loop */
do
{
+#ifdef __NetBSD__
+ pthread_yield_np();
+#endif
if (info->stop)
break;
if (seek_skip)

View file

@ -0,0 +1,24 @@
$NetBSD: patch-ab,v 1.1.1.1 2002/05/26 04:00:51 jmcneill Exp $
--- src/xmms-mad.c.orig Sat May 25 21:07:02 2002
+++ src/xmms-mad.c Sat May 25 21:07:05 2002
@@ -83,6 +83,9 @@
printf ("waiting for thread\n");
#endif /* DEBUG */
pthread_join (decode_thread, 0);
+#ifdef __NetBSD__
+ pthread_yield_np ();
+#endif
#ifdef DEBUG
printf ("thread done\n");
#endif /* DEBUG */
@@ -99,6 +102,9 @@
info.playing = 1;
input_get_info (&info);
pthread_create (&decode_thread, 0, decode, (void *) &info);
+#ifdef __NetBSD__
+ pthread_yield_np ();
+#endif
}
}