Fix the build by adding USE_LANGUAGES=c c++ and linking myisam/isam
with CXX. Noted by kristerw's bulk-build and Michal Pasternak on tech-pkg@.
This commit is contained in:
parent
8f8df9c339
commit
b1004161e8
4 changed files with 31 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.4 2004/03/10 14:54:05 tv Exp $
|
||||
# $NetBSD: Makefile.common,v 1.5 2004/03/13 12:09:36 recht Exp $
|
||||
|
||||
DISTNAME= mysql-4.0.18
|
||||
CATEGORIES= databases
|
||||
|
@ -62,6 +62,7 @@ CFLAGS+= -DHAVE_CURSES_H
|
|||
CXXFLAGS+= -DHAVE_CURSES_H
|
||||
.endif
|
||||
|
||||
USE_LANGUAGES= c c++
|
||||
USE_GNU_TOOLS+= make
|
||||
USE_PERL5= # defined
|
||||
USE_LIBTOOL= # defined
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.3 2004/03/07 19:42:55 martti Exp $
|
||||
$NetBSD: distinfo,v 1.4 2004/03/13 12:09:37 recht Exp $
|
||||
|
||||
SHA1 (mysql-4.0.18.tar.gz) = 101f199faead0d22d2da2b1ac82b8c071aa987a8
|
||||
Size (mysql-4.0.18.tar.gz) = 13422686 bytes
|
||||
|
@ -13,3 +13,5 @@ SHA1 (patch-as) = c1f61c4f02d89fc5e89617a063f7ea1b0fa438d6
|
|||
SHA1 (patch-at) = 3a457c3f6b13312cb71b663108abd0ace09f2be4
|
||||
SHA1 (patch-au) = 9183bfa3a6f5b4a9553a6de83448fb684d514a91
|
||||
SHA1 (patch-av) = 6ea5b9338d223f1380386288c537f55d4fd7a7d7
|
||||
SHA1 (patch-aw) = 6beb03517de678def5631517c8a7db7ea6540137
|
||||
SHA1 (patch-ax) = 8e21c394b9cd6f7f2a0cae0c76ac08d224a18420
|
||||
|
|
13
databases/mysql4-server/patches/patch-aw
Normal file
13
databases/mysql4-server/patches/patch-aw
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aw,v 1.1 2004/03/13 12:09:37 recht Exp $
|
||||
|
||||
--- isam/Makefile.in.orig 2004-02-10 19:16:49.000000000 +0100
|
||||
+++ isam/Makefile.in 2004-03-13 12:26:18.000000000 +0100
|
||||
@@ -370,7 +370,7 @@
|
||||
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
-CCLD = $(CC)
|
||||
+CCLD = $(CXX)
|
||||
LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
$(AM_LDFLAGS) $(LDFLAGS) -o $@
|
||||
DIST_SOURCES = $(libnisam_a_SOURCES) $(isamchk_SOURCES) isamlog.c \
|
13
databases/mysql4-server/patches/patch-ax
Normal file
13
databases/mysql4-server/patches/patch-ax
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ax,v 1.1 2004/03/13 12:09:37 recht Exp $
|
||||
|
||||
--- myisam/Makefile.in.orig 2004-03-13 12:38:20.000000000 +0100
|
||||
+++ myisam/Makefile.in 2004-03-13 12:38:46.000000000 +0100
|
||||
@@ -407,7 +407,7 @@
|
||||
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
|
||||
$(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
-CCLD = $(CC)
|
||||
+CCLD = $(CXX)
|
||||
LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
$(AM_LDFLAGS) $(LDFLAGS) -o $@
|
||||
DIST_SOURCES = $(libmyisam_a_SOURCES) mi_test1.c mi_test2.c mi_test3.c \
|
Loading…
Reference in a new issue