Initial import of cbrowser-0.6 into the NetBSD Packages Collection.
Cbrowser helps manage the recursive process of searching through source code for usages by providing a history mechanism. Every query is recorded and can be recalled at any time, without the need of re-querying the database. Cbrowser allows you to build and use multiple source code databases for individual software projects. Switching databases is as simple as selecting the file, and a history of all databases used is kept at all times. Best of all, cbrowser provides a hierarchical function viewer. Functions may be expanded and contracted to show or hide the functions they call. The function's code itself is shown in an adjoining viewer. This feature is implemented using the megawidget Library by Jeff Hobbs.
This commit is contained in:
parent
47bada094e
commit
b1118bd2fd
5 changed files with 75 additions and 0 deletions
15
devel/cbrowser/DESCR
Normal file
15
devel/cbrowser/DESCR
Normal file
|
@ -0,0 +1,15 @@
|
|||
Cbrowser helps manage the recursive process of searching through
|
||||
source code for usages by providing a history mechanism. Every query
|
||||
is recorded and can be recalled at any time, without the need of
|
||||
re-querying the database.
|
||||
|
||||
Cbrowser allows you to build and use multiple source code databases
|
||||
for individual software projects. Switching databases is as simple as
|
||||
selecting the file, and a history of all databases used is kept at all
|
||||
times.
|
||||
|
||||
Best of all, cbrowser provides a hierarchical function viewer.
|
||||
Functions may be expanded and contracted to show or hide the functions
|
||||
they call. The function's code itself is shown in an adjoining
|
||||
viewer. This feature is implemented using the megawidget Library by
|
||||
Jeff Hobbs which luckily for me comes with an unrestricted license.
|
28
devel/cbrowser/Makefile
Normal file
28
devel/cbrowser/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/11/14 11:27:03 agc Exp $
|
||||
#
|
||||
|
||||
DISTNAME= cbrowser-0.6
|
||||
CATEGORIES= devel tk80
|
||||
MASTER_SITES= http://www.ziplink.net/~felaco/cbrowser/
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://www.ziplink.net/~felaco/cbrowser/
|
||||
COMMENT= graphical C/C++ source code browsing tool, and call graph viewer
|
||||
|
||||
DEPENDS+= cscope-[0-9]*:../../devel/cscope
|
||||
|
||||
NO_BUILD= # defined
|
||||
|
||||
post-patch:
|
||||
${MV} ${WRKSRC}/cbrowser ${WRKSRC}/cbrowser.input && \
|
||||
${SED} -e 's|@PREFIX@|${PREFIX}|' ${WRKSRC}/cbrowser.input > ${WRKSRC}/cbrowser
|
||||
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/cbrowser ${PREFIX}/bin
|
||||
${INSTALL_SCRIPT_DIR} ${PREFIX}/share/cbrowser
|
||||
for f in builder.tcl calltree.tcl hierarchy.tcl widget.tcl tclIndex; do \
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/$$f ${PREFIX}/share/cbrowser; \
|
||||
done
|
||||
|
||||
.include "../../x11/tk/buildlink.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
8
devel/cbrowser/PLIST
Normal file
8
devel/cbrowser/PLIST
Normal file
|
@ -0,0 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2001/11/14 11:27:03 agc Exp $
|
||||
bin/cbrowser
|
||||
share/cbrowser/builder.tcl
|
||||
share/cbrowser/calltree.tcl
|
||||
share/cbrowser/hierarchy.tcl
|
||||
share/cbrowser/tclIndex
|
||||
share/cbrowser/widget.tcl
|
||||
@dirrm share/cbrowser
|
5
devel/cbrowser/distinfo
Normal file
5
devel/cbrowser/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2001/11/14 11:27:03 agc Exp $
|
||||
|
||||
SHA1 (cbrowser-0.6.tar.gz) = ca2470188345484aa1e07bf9fda49ef0c5770a3b
|
||||
Size (cbrowser-0.6.tar.gz) = 56053 bytes
|
||||
SHA1 (patch-aa) = ebd63eec2484b5e877bd09f02f861e180f233347
|
19
devel/cbrowser/patches/patch-aa
Normal file
19
devel/cbrowser/patches/patch-aa
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/11/14 11:27:03 agc Exp $
|
||||
|
||||
Set up cbrowser so that it can find its subsidiary tcl files
|
||||
|
||||
--- cbrowser 2001/11/14 11:06:30 1.1
|
||||
+++ cbrowser 2001/11/14 11:07:59
|
||||
@@ -3594,6 +3594,12 @@
|
||||
}
|
||||
set button_defaults [expr [info tclversion] >= 8.0]
|
||||
|
||||
+set env(CBROWSER_LIB) "@PREFIX@/share/cbrowser"
|
||||
+
|
||||
+if {[info exists env(CBROWSER_LIB)]} {
|
||||
+ lappend auto_path $env(CBROWSER_LIB)
|
||||
+}
|
||||
+
|
||||
# Setup some aliases for those pesky string commands
|
||||
interp alias {} strcmp {} string compare
|
||||
interp alias {} strlen {} string length
|
Loading…
Reference in a new issue