Fix a couple new-to-5.0.8 issues with command completion.

- non-GNU du wouldn't complete filenames (taken from upstream)
- sort completion threw a syntax error on NetBSD (reported upstream)

Bump PKGREVISION to 1.
This commit is contained in:
snj 2015-07-26 22:04:13 +00:00
parent e06b0c7f5b
commit b12ba95ac9
4 changed files with 37 additions and 2 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.69 2015/06/13 12:57:28 ryoon Exp $
# $NetBSD: Makefile,v 1.70 2015/07/26 22:04:13 snj Exp $
.include "../../shells/zsh/Makefile.common"
ZSH_VERSION= 5.0.8
PKGREVISION= 1
ZSH_MAINTAINER= uebayasi@NetBSD.org
CONFIGURE_ARGS+= --disable-gdbm

View file

@ -1,8 +1,10 @@
$NetBSD: distinfo,v 1.52 2015/06/13 12:57:28 ryoon Exp $
$NetBSD: distinfo,v 1.53 2015/07/26 22:04:13 snj Exp $
SHA1 (zsh-5.0.8.tar.bz2) = e15e00bd4b80e96e87301bf682d86fdf56929989
RMD160 (zsh-5.0.8.tar.bz2) = 2c831d5dee22d79b6e2fd6ad7b8392c1d201f017
Size (zsh-5.0.8.tar.bz2) = 3250542 bytes
SHA1 (patch-Completion_Unix_Command__du) = 267c6adc4941c9487b7a4a524472e65fef39dda6
SHA1 (patch-Completion_Unix_Command__sort) = 34ec91557c1a8b78042ab333f73a18111dd64d18
SHA1 (patch-Src_builtin.c) = 500ad7e79c38ba35055e39c3879e8d72f2f4a59d
SHA1 (patch-Test_B03print.ztst) = 5e534fbacf1648faa6deeaae8af57f37498a98c4
SHA1 (patch-ac) = 75c1b9e56858289adf9f1d9c58d2319bb6df7abc

View file

@ -0,0 +1,14 @@
$NetBSD: patch-Completion_Unix_Command__du,v 1.1 2015/07/26 22:04:13 snj Exp $
Unbreak filename completion on non-GNU du binaries like NetBSD's.
Upstreadm commit 806f73a0b3d3959d5af12ce97e0258b4d4fe7d76
--- Completion/Unix/Command/_du.orig 2015-07-26 14:39:36.000000000 -0700
+++ Completion/Unix/Command/_du 2015-07-26 14:39:17.000000000 -0700
@@ -74,5 +74,5 @@ else
do
[[ $OSTYPE = $~pattern ]] && args+=( $arg )
done
- _arguments -s -A "-*" $args
+ _arguments -s -A "-*" $args '*:file:_files'
fi

View file

@ -0,0 +1,18 @@
$NetBSD: patch-Completion_Unix_Command__sort,v 1.1 2015/07/26 22:04:13 snj Exp $
Add missing ]. Fixes NetBSD and DragonFly completion of the sort
command. Without this, you get:
"_arguments:comparguments:312: invalid option definition: (-s)-S[don't
use stable sort"
--- Completion/Unix/Command/_sort.orig 2015-07-26 14:58:06.000000000 -0700
+++ Completion/Unix/Command/_sort 2015-07-26 14:58:16.000000000 -0700
@@ -55,7 +55,7 @@ case $variant in
netbsd*|dragonfly*)
args+=(
"${ordering}-l[sort by string length of field]"
- "(-s)-S[don't use stable sort"
+ "(-s)-S[don't use stable sort]"
)
;|
openbsd*)