Fix autoconf header to not re-declare inet_ntop and friends.

Fix text relocations by ensuring the Perl module can use -fPIC builds.
Bump revision.
This commit is contained in:
joerg 2008-06-21 17:58:17 +00:00
parent da38a8af80
commit b146d123da
5 changed files with 46 additions and 3 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.8 2007/11/27 08:04:10 seb Exp $
# $NetBSD: Makefile,v 1.9 2008/06/21 17:58:17 joerg Exp $
#
DISTNAME= beacon-1.1-0
PKGNAME= beacon-1.1.0
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= mbone
MASTER_SITES= http://dast.nlanr.net/Projects/Beacon/releases/
@ -11,6 +11,8 @@ MAINTAINER= manu@NetBSD.org
HOMEPAGE= http://dast.nlanr.net/Projects/Beacon/
COMMENT= Multicast supervision tool
PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= YES
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/share/examples/beacon

View file

@ -1,6 +1,9 @@
$NetBSD: distinfo,v 1.3 2005/08/08 18:13:13 jlam Exp $
$NetBSD: distinfo,v 1.4 2008/06/21 17:58:17 joerg Exp $
SHA1 (beacon-1.1-0.tar.gz) = f6d5e88e00d26e53df8c9742e7454b84d72e0911
RMD160 (beacon-1.1-0.tar.gz) = efa8097288b110572f5e2f0a1bed5ed8532a28bd
Size (beacon-1.1-0.tar.gz) = 247815 bytes
SHA1 (patch-aa) = 30e80b4a0f9dedfd7c4149b3d32d820ac17707c8
SHA1 (patch-ab) = 749360884745c5f2138b3ab2829a682bdd73d79a
SHA1 (patch-ac) = e7ba066f09382ff27ad93ce9e5731a4028290a88
SHA1 (patch-ad) = 5ea95045071112d5b70745edd335c6fa82233b48

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ab,v 1.1 2008/06/21 17:58:17 joerg Exp $
--- librtp/config.h.in.orig 2008-06-21 11:29:06.000000000 +0000
+++ librtp/config.h.in
@@ -48,6 +48,9 @@
#undef NEED_INET_PTON
#undef NEED_INET_NTOP
+#undef HAVE_INET_NTOP
+#undef HAVE_INET_PTON
+
/*
* If you don't have these types in <inttypes.h>, #define these to be
* the types you do have.

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ac,v 1.1 2008/06/21 17:58:17 joerg Exp $
--- librtp/Makefile.in.orig 2008-06-21 11:37:16.000000000 +0000
+++ librtp/Makefile.in
@@ -88,6 +88,7 @@ AWK = @AWK@
CC = @CC@
CCDEPMODE = @CCDEPMODE@
CFLAGS = @CFLAGS@
+AM_CFLAGS= -fPIC
CPP = @CPP@
CPPFLAGS = @CPPFLAGS@
CYGPATH_W = @CYGPATH_W@

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ad,v 1.1 2008/06/21 17:58:17 joerg Exp $
--- libbeacon/Makefile.in.orig 2008-06-21 11:44:56.000000000 +0000
+++ libbeacon/Makefile.in
@@ -78,6 +78,7 @@ AWK = @AWK@
CC = @CC@
CCDEPMODE = @CCDEPMODE@
CFLAGS = @CFLAGS@
+AM_CFLAGS= -fPIC
CPP = @CPP@
CPPFLAGS = @CPPFLAGS@
CYGPATH_W = @CYGPATH_W@